aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-textbuf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ruby-textbuf/Makefile')
-rw-r--r--devel/ruby-textbuf/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/devel/ruby-textbuf/Makefile b/devel/ruby-textbuf/Makefile
new file mode 100644
index 000000000000..b366fd72303c
--- /dev/null
+++ b/devel/ruby-textbuf/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: Ruby-
+# Date created: 19 Jan 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= textbuf
+PORTVERSION= 0.3.6
+CATEGORIES= devel ruby
+MASTER_SITES= http://www1.u-netsurf.ne.jp/~brew/mine/soft/
+MASTER_SITE_SUBDIR= knu
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+USE_RUBY_AMSTD= yes
+USE_RUBY_SETUP= yes
+
+DOCS_EN= README.en
+DOCS_JA= README.ja
+
+do-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_DOCDIR}/textbuf/ja
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/textbuf/
+.endfor
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/textbuf/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>