aboutsummaryrefslogtreecommitdiff
path: root/devel/ruby-tzfile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ruby-tzfile')
-rw-r--r--devel/ruby-tzfile/Makefile22
-rw-r--r--devel/ruby-tzfile/pkg-plist2
2 files changed, 15 insertions, 9 deletions
diff --git a/devel/ruby-tzfile/Makefile b/devel/ruby-tzfile/Makefile
index fc5ce7c27c5c..a80383f9c7d7 100644
--- a/devel/ruby-tzfile/Makefile
+++ b/devel/ruby-tzfile/Makefile
@@ -16,20 +16,26 @@ DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
USE_RUBY= yes
-USE_RUBY_RDTOOL= yes
+
+NO_BUILD= yes
+
+RUBY_RD_FILES= tzfile.rb
WRKSRC= ${WRKDIR}/${PORTNAME}
-do-build:
-.if !defined(NOPORTDOCS)
- cd ${WRKSRC}; ${RUBY_RD2} tzfile.rb > tzfile.html
-.endif
+DOCS= ${RUBY_RD_HTML_FILES}
do-install:
${INSTALL_DATA} ${WRKSRC}/tzfile.rb ${RUBY_SITELIBDIR}/
+
+post-install: doc-install
+
+.include <bsd.port.mk>
+
+doc-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODDOCDIR}
- ${INSTALL_DATA} ${WRKSRC}/tzfile.html ${RUBY_MODDOCDIR}/
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
+.endfor
.endif
-
-.include <bsd.port.mk>
diff --git a/devel/ruby-tzfile/pkg-plist b/devel/ruby-tzfile/pkg-plist
index d95efc9d09aa..5addbb35da97 100644
--- a/devel/ruby-tzfile/pkg-plist
+++ b/devel/ruby-tzfile/pkg-plist
@@ -1,3 +1,3 @@
%%RUBY_SITELIBDIR%%/tzfile.rb
-%%PORTDOCS%%%%RUBY_MODDOCDIR%%/tzfile.html
+%%PORTDOCS%%%%RUBY_RD_HTML_FILES%%%%RUBY_MODDOCDIR%%/tzfile.html
%%PORTDOCS%%@dirrm %%RUBY_MODDOCDIR%%