aboutsummaryrefslogtreecommitdiff
path: root/devel/rubygem-gitlab_git/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/rubygem-gitlab_git/Makefile')
-rw-r--r--devel/rubygem-gitlab_git/Makefile21
1 files changed, 21 insertions, 0 deletions
diff --git a/devel/rubygem-gitlab_git/Makefile b/devel/rubygem-gitlab_git/Makefile
new file mode 100644
index 000000000000..6d8df8b625bf
--- /dev/null
+++ b/devel/rubygem-gitlab_git/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= gitlab_git
+PORTVERSION= 2.3.1
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= GitLab wrapper around git objects
+
+RUN_DEPENDS= rubygem-activesupport>=3.2.13:${PORTSDIR}/devel/rubygem-activesupport \
+ rubygem-github-linguist>=2.3.4:${PORTSDIR}/textproc/rubygem-github-linguist \
+ rubygem-gitlab-grit>=2.6.0:${PORTSDIR}/textproc/rubygem-gitlab-grit
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+NO_STAGE= yes
+
+.include <bsd.port.mk>