aboutsummaryrefslogtreecommitdiff
path: root/devel/rubygem-locale/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/rubygem-locale/Makefile')
-rw-r--r--devel/rubygem-locale/Makefile23
1 files changed, 11 insertions, 12 deletions
diff --git a/devel/rubygem-locale/Makefile b/devel/rubygem-locale/Makefile
index 80cb5ea9076c..90832507aa6e 100644
--- a/devel/rubygem-locale/Makefile
+++ b/devel/rubygem-locale/Makefile
@@ -6,12 +6,9 @@
#
PORTNAME= gettext
-PORTVERSION= 0.8.0
+PORTVERSION= 1.5.0
CATEGORIES= devel ruby
-MASTER_SITES= ftp://ftp.dvo.ru/pub/Gentoo/distfiles/ \
- ftp://ftp.tu-ilmenau.de/Mirrors/gentoo/distfiles/ \
- ftp://ftp.tugraz.at/ftp.tu-graz.ac.at/.mirror-sites/gentoo.inode.at/source/distfiles/ \
- ftp://mir1.ovh.net/gentoo-distfiles/distfiles/
+MASTER_SITES= http://rubyforge.org/frs/download.php/10363/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ruby-${PORTNAME}-package-${PORTVERSION}
DIST_SUBDIR= ruby
@@ -28,11 +25,16 @@ USE_RUBY_SETUP= yes
RUBY_SHEBANG_FILES= bin/rgettext ${WRKSRC}/samples/*.rb
-DOCS_EN= ChangeLog README
-DOCS_JA= README.ja
+DOCS= ChangeLog NEWS README
+
+RUBY_REQUIRE= Ruby >= 184
.include <bsd.port.pre.mk>
+.if !defined(RUBY_PROVIDED)
+IGNORE= requires Ruby 1.8.4 or later
+.endif
+
post-install: doc-install
doc-install:
@@ -40,13 +42,10 @@ doc-install:
cd ${WRKSRC}/samples; ${RUBY} makemo.rb
${MKDIR} ${RUBY_MODEXAMPLESDIR}
${CP} -R ${WRKSRC}/samples/* ${RUBY_MODEXAMPLESDIR}/
- ${MKDIR} ${RUBY_MODDOCDIR}/ja
-.for f in ${DOCS_EN}
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
.endfor
-.for f in ${DOCS_JA}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
-.endfor
.endif
.include <bsd.port.post.mk>