aboutsummaryrefslogtreecommitdiff
path: root/devel/rubygem-popen4
diff options
context:
space:
mode:
Diffstat (limited to 'devel/rubygem-popen4')
-rw-r--r--devel/rubygem-popen4/Makefile24
-rw-r--r--devel/rubygem-popen4/distinfo2
-rw-r--r--devel/rubygem-popen4/pkg-descr5
3 files changed, 31 insertions, 0 deletions
diff --git a/devel/rubygem-popen4/Makefile b/devel/rubygem-popen4/Makefile
new file mode 100644
index 000000000000..15a518cc2200
--- /dev/null
+++ b/devel/rubygem-popen4/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: rubygem-popen4
+# Date created: 2011-06-16
+# Whom: rpsfa@rit.edu
+#
+# $FreeBSD$
+
+PORTNAME= popen4
+PORTVERSION= 0.1.4
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+DISTNAME= ${GEM_NAME}
+
+MAINTAINER= rpsfa@rit.edu
+COMMENT= A cross platform API for managing child processes
+
+RUN_DEPENDS= rubygem-open4>=0.4.0:${PORTSDIR}/devel/rubygem-open4 \
+ rubygem-platform>=0.4.0:${PORTSDIR}/devel/rubygem-platform
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+GEM_NAME= POpen4-${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-popen4/distinfo b/devel/rubygem-popen4/distinfo
new file mode 100644
index 000000000000..a7e652fd82cb
--- /dev/null
+++ b/devel/rubygem-popen4/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/POpen4-0.1.4.gem) = b88be992108297b240299d4a8cd1f25d9bea6871d35d2e0c94edfe0a259e3432
+SIZE (rubygem/POpen4-0.1.4.gem) = 7680
diff --git a/devel/rubygem-popen4/pkg-descr b/devel/rubygem-popen4/pkg-descr
new file mode 100644
index 000000000000..8aac78db3e9b
--- /dev/null
+++ b/devel/rubygem-popen4/pkg-descr
@@ -0,0 +1,5 @@
+POpen4 provides the Rubyist a single API across platforms for
+executing a command in a child process with handles on stdout,
+stderr, stdin streams as well as access to the process ID and exit status.
+
+WWW: http://rubygems.org/gems/popen4