aboutsummaryrefslogtreecommitdiff
path: root/devel/rubygem-ruport/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/rubygem-ruport/Makefile')
-rw-r--r--devel/rubygem-ruport/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/devel/rubygem-ruport/Makefile b/devel/rubygem-ruport/Makefile
new file mode 100644
index 000000000000..d26b626e0205
--- /dev/null
+++ b/devel/rubygem-ruport/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: rubygem-ruport
+# Date created: 7 April 2009
+# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ruport
+PORTVERSION= 1.0.1
+CATEGORIES= devel rubygems
+MASTER_SITES= RF
+
+MAINTAINER= pgollucci@FreeBSD.org
+COMMENT= Ruby Reports (Ruport) is an extensible reporting system.
+
+RUN_DEPENDS= rubygem-transactionsimple>=1.4.0:${PORTSDIR}/devel/rubygem-transactionsimple \
+ rubygem-fastercsv>=1.1.0:${PORTSDIR}/devel/rubygem-fastercsv \
+ rubygem-pdfwriter>=1.1.3:${PORTSDIR}/print/rubygem-pdfwriter
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>