aboutsummaryrefslogtreecommitdiff
path: root/devel/rubygem-ruport
diff options
context:
space:
mode:
Diffstat (limited to 'devel/rubygem-ruport')
-rw-r--r--devel/rubygem-ruport/Makefile24
-rw-r--r--devel/rubygem-ruport/distinfo3
-rw-r--r--devel/rubygem-ruport/pkg-descr8
3 files changed, 35 insertions, 0 deletions
diff --git a/devel/rubygem-ruport/Makefile b/devel/rubygem-ruport/Makefile
new file mode 100644
index 000000000000..d26b626e0205
--- /dev/null
+++ b/devel/rubygem-ruport/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: rubygem-ruport
+# Date created: 7 April 2009
+# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ruport
+PORTVERSION= 1.0.1
+CATEGORIES= devel rubygems
+MASTER_SITES= RF
+
+MAINTAINER= pgollucci@FreeBSD.org
+COMMENT= Ruby Reports (Ruport) is an extensible reporting system.
+
+RUN_DEPENDS= rubygem-transactionsimple>=1.4.0:${PORTSDIR}/devel/rubygem-transactionsimple \
+ rubygem-fastercsv>=1.1.0:${PORTSDIR}/devel/rubygem-fastercsv \
+ rubygem-pdfwriter>=1.1.3:${PORTSDIR}/print/rubygem-pdfwriter
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-ruport/distinfo b/devel/rubygem-ruport/distinfo
new file mode 100644
index 000000000000..c58e547bf633
--- /dev/null
+++ b/devel/rubygem-ruport/distinfo
@@ -0,0 +1,3 @@
+MD5 (rubygem/ruport-1.0.1.gem) = 18fef29fe1ba70e686788c26e31afeb8
+SHA256 (rubygem/ruport-1.0.1.gem) = fb0aad0ed5640e885a3758c2f3bf9697fdda688df823a22a22322c6e9fdf90f6
+SIZE (rubygem/ruport-1.0.1.gem) = 308224
diff --git a/devel/rubygem-ruport/pkg-descr b/devel/rubygem-ruport/pkg-descr
new file mode 100644
index 000000000000..0d221010ce87
--- /dev/null
+++ b/devel/rubygem-ruport/pkg-descr
@@ -0,0 +1,8 @@
+Ruby Reports (Ruport) is an extensible reporting system.
+
+It aims to be as lightweight as possible while still providing core support
+for data aggregation and manipulation as well as multi-format rendering
+of reports.
+
+Ruport provides tools for using a number of data sources, including CSV files,
+ActiveRecord models, and raw SQL connections via RubyDBI (through ruport-util).