aboutsummaryrefslogtreecommitdiff
path: root/devel/sdl12
diff options
context:
space:
mode:
Diffstat (limited to 'devel/sdl12')
-rw-r--r--devel/sdl12/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/devel/sdl12/Makefile b/devel/sdl12/Makefile
index 891833a2225e..3412afed4cbc 100644
--- a/devel/sdl12/Makefile
+++ b/devel/sdl12/Makefile
@@ -21,6 +21,8 @@ BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
USE_LIBTOOL= yes
+USE_GNOMENG= yes
+WANT_GNOME= yes
CONFIGURE_ENV= NASM="${LOCALBASE}/bin/nasm" \
PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
@@ -41,12 +43,6 @@ DISPLAY_MSG= ${DO_NADA}
.if !defined(WITHOUT_X11)
USE_XLIB= yes
.endif
-.if !defined(WITHOUT_ESOUND)
-USE_GNOMENG= yes
-USE_GNOME= esound
-.else
-CONFIGURE_ARGS+=--disable-esd --disable-esdtest
-.endif
.if defined(WITHOUT_GL)
CONFIGURE_ARGS+=--disable-video-opengl
.else
@@ -68,6 +64,12 @@ MAN3!= ${CAT} ${FILESDIR}/man3
WITHOUT_SVGALIB= yes
.endif
+.if ${HAVE_GNOME:Mesound}!=""
+USE_GNOME+= esound
+.else
+CONFIGURE_ARGS+=--disable-esd --disable-esdtest
+.endif
+
.if !defined(WITHOUT_SVGALIB)
LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
CONFIGURE_ARGS+=--enable-video-svga