aboutsummaryrefslogtreecommitdiff
path: root/devel/sdl_sge/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/sdl_sge/Makefile')
-rw-r--r--devel/sdl_sge/Makefile60
1 files changed, 32 insertions, 28 deletions
diff --git a/devel/sdl_sge/Makefile b/devel/sdl_sge/Makefile
index c609cc6c76fd..385e5ef9d56d 100644
--- a/devel/sdl_sge/Makefile
+++ b/devel/sdl_sge/Makefile
@@ -7,62 +7,66 @@
PORTNAME= sdl_sge
PORTVERSION= 0.030809
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= devel graphics
-MASTER_SITES= http://www.etek.chalmers.se/~e8cal1/sge/files/ \
- http://www.digitalfanatics.org/cal/sge/files/
+MASTER_SITES= http://www.digitalfanatics.org/cal/sge/files/ \
+ http://www.sourcefiles.org/Programming/Libraries/Graphics/
DISTNAME= sge030809
MAINTAINER= ports@FreeBSD.org
COMMENT= A graphic library for the Simple DirectMedia Layer (SDL)
-DEPRECATED= Upstream disapear and distfile is no more available
-EXPIRATION_DATE= 2011-05-01
+LICENSE= LGPL21 LGPL3
+LICENSE_COMB= dual
+OPTIONS= SDL_IMAGE "Enable support for SDL_image" On \
+ FREETYPE "Enable FreeType support" On \
+ DOCS "Install documentation" On \
+ EXAMPLES "Install examples" On
+
+USE_SDL= sdl
USE_GMAKE= yes
USE_LDCONFIG= yes
-
-OPTIONS= SDL_IMAGE "Enable support for SDL_IMAGE" On \
- FREETYPE "Enable FreeType support" On \
- DOCS "Install documentation" Off
+MAKE_JOBS_SAFE= yes
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_FREETYPE)
-LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+.if defined(WITHOUT_FREETYPE)
+MAKE_ARGS+= USE_FT=n
+.else
+LIB_DEPENDS+= freetype.9:${PORTSDIR}/print/freetype2
+MAKE_ARGS+= USE_FT=y
.endif
.if defined(WITHOUT_SDL_IMAGE)
-USE_SDL= sdl
+MAKE_ARGS+= USE_IMG=n
.else
-USE_SDL= image
+USE_SDL+= image
+MAKE_ARGS+= USE_IMG=y
.endif
.if !defined(WITH_DOCS)
NOPORTDOCS= yes
.endif
-post-patch:
-.if defined(WITHOUT_SDL_IMAGE)
- @${REINPLACE_CMD} -e 's|#USE_IMG = n|USE_IMG = n|g' ${WRKSRC}/Makefile.conf
-.else
- @${REINPLACE_CMD} -e 's|#USE_IMG = n|USE_IMG = y|g' ${WRKSRC}/Makefile.conf
-.endif
-.if defined(WITHOUT_FREETYPE)
- @${REINPLACE_CMD} -e 's|#USE_FT = n|USE_FT = n|g' ${WRKSRC}/Makefile.conf
-.else
- @${REINPLACE_CMD} -e 's|#USE_FT = n|USE_FT = y|g' ${WRKSRC}/Makefile.conf
+.if !defined(WITH_EXAMPLES)
+NOPORTEXAMPLES= yes
.endif
- @${REINPLACE_CMD} -e 's|PREFIX =PREFIX|PREFIX =${PREFIX}|g' ${WRKSRC}/Makefile.conf
- @${REINPLACE_CMD} -e 's|PREFIX_H =PREFIX_H|PREFIX_H =${PREFIX}/include/SDL|g' ${WRKSRC}/Makefile.conf
- @${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG}|g' ${WRKSRC}/Makefile.conf
+
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|PREFIX =PREFIX|PREFIX =${PREFIX}|g ; \
+ s|PREFIX_H =PREFIX_H|PREFIX_H =${PREFIX}/include/SDL|g ; \
+ s|sdl-config|${SDL_CONFIG}|g' ${WRKSRC}/Makefile.conf
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- @${INSTALL_MAN} ${WRKSRC}/docs/* ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
@${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_MAN} ${WRKSRC}/examples/* ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif
.include <bsd.port.post.mk>