aboutsummaryrefslogtreecommitdiff
path: root/devel/sdl_sge/files/patch-Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/sdl_sge/files/patch-Makefile')
-rw-r--r--devel/sdl_sge/files/patch-Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/devel/sdl_sge/files/patch-Makefile b/devel/sdl_sge/files/patch-Makefile
new file mode 100644
index 000000000000..9089803403f0
--- /dev/null
+++ b/devel/sdl_sge/files/patch-Makefile
@@ -0,0 +1,29 @@
+--- work/sge030809/Makefile Tue Aug 12 00:40:41 2003
++++ Makefile Fri Aug 4 15:28:10 2006
+@@ -12,16 +12,11 @@
+
+ all: config $(OBJECTS)
+ @ar rsc libSGE.a $(OBJECTS)
++ $(CXX) $(CFLAGS) -Wl,-soname,libSGE.so.$(API_VER) -fpic -fPIC -shared -o libSGE.so $(OBJECTS) $(LIBS)
+
+ $(OBJECTS): %.o:%.cpp %.h #Each object depends on thier .cpp and .h file
+ $(CXX) $(CFLAGS) -c $<
+
+-shared: all
+- $(CXX) $(CFLAGS) -Wl,-soname,libSGE.so.$(API_VER) -fpic -fPIC -shared -o libSGE.so $(OBJECTS) $(LIBS)
+-
+-shared-strip: shared
+- @strip libSGE.so
+-
+ # Building a dll... I have no idea how to do this, but it should be something like below.
+ dll: config $(OBJECTS)
+ dlltool --output-def SGE.def $(OBJECTS)
+@@ -70,7 +65,7 @@
+ @echo ""
+ endif
+
+-install: shared
++install:
+ @mkdir -p $(PREFIX_H)
+ install -c -m 644 sge*.h $(PREFIX_H)
+ @mkdir -p $(PREFIX)/lib