aboutsummaryrefslogtreecommitdiff
path: root/devel/sdts++/files
diff options
context:
space:
mode:
Diffstat (limited to 'devel/sdts++/files')
-rw-r--r--devel/sdts++/files/patch-ab64
-rw-r--r--devel/sdts++/files/patch-ac11
2 files changed, 75 insertions, 0 deletions
diff --git a/devel/sdts++/files/patch-ab b/devel/sdts++/files/patch-ab
new file mode 100644
index 000000000000..6c964eb5ec02
--- /dev/null
+++ b/devel/sdts++/files/patch-ab
@@ -0,0 +1,64 @@
+--- sdts++/builder/sb_Accessor.cpp.orig Tue Jun 10 22:51:40 2003
++++ sdts++/builder/sb_Accessor.cpp Sat Dec 13 14:17:48 2003
+@@ -26,6 +26,12 @@
+ #include <cctype>
+ #include <cstring>
+
++#if __FreeBSD__
++# include <osreldate.h>
++# if __FreeBSD_version < 500035
++# include <stlport/iosfwd>
++# endif
++#endif
+ #include <boost/smart_ptr.hpp>
+ #include <boost/filesystem/path.hpp>
+ #include <boost/filesystem/operations.hpp>
+@@ -155,27 +158,27 @@
+
+
+
+-static const char* module_mnemonics_[] =
+-{
+- {"CATS"},
+- {"CATD"},
+- {"DDOM"},
+- {"DDSH"},
+- {"MDOM"},
+- {"MDEF"},
+- {"DQHL"},
+- {"DQPA"},
+- {"DQAA"},
+- {"DQLC"},
+- {"DQCG"},
+- {"IDEN"},
+- {"IREF"},
+- {"LDEF"},
+- {"RSDF"},
+- {"STAT"},
+- {"XREF"},
+- {""}
+-}; // module_mnemonics
++static const char* module_mnemonics_[] =
++{
++ "CATS",
++ "CATD",
++ "DDOM",
++ "DDSH",
++ "MDOM",
++ "MDEF",
++ "DQHL",
++ "DQPA",
++ "DQAA",
++ "DQLC",
++ "DQCG",
++ "IDEN",
++ "IREF",
++ "LDEF",
++ "RSDF",
++ "STAT",
++ "XREF",
++ ""
++}; // module_mnemonics
+
+
+
diff --git a/devel/sdts++/files/patch-ac b/devel/sdts++/files/patch-ac
new file mode 100644
index 000000000000..45f57105104c
--- /dev/null
+++ b/devel/sdts++/files/patch-ac
@@ -0,0 +1,11 @@
+--- sdts++/Makefile.in.orig Sat Dec 13 14:19:23 2003
++++ sdts++/Makefile.in Sat Dec 13 14:21:14 2003
+@@ -147,7 +147,7 @@
+
+ AUTOMAKE_OPTIONS := subdir-objects
+
+-AM_CPPFLAGS := -I. -I.. -Icontainer -Iio -Ibuilder -Ilogical -I${prefix}/include -I${BOOST_HEADER}
++AM_CPPFLAGS := -I. -I.. -Icontainer -Iio -Ibuilder -Ilogical -I${prefix}/include -I${BOOST_HEADER} -I${BOOST_HEADER}/stlport
+
+ container_sources := container/sc_Subfield.cpp \
+ container/sc_Field.cpp \