aboutsummaryrefslogtreecommitdiff
path: root/devel/sfslite
diff options
context:
space:
mode:
Diffstat (limited to 'devel/sfslite')
-rw-r--r--devel/sfslite/Makefile7
-rw-r--r--devel/sfslite/distinfo6
-rw-r--r--devel/sfslite/files/patch-async-arena.h11
-rw-r--r--devel/sfslite/files/patch-async-daemonize.C45
-rw-r--r--devel/sfslite/files/patch-async-parseopt.C11
-rw-r--r--devel/sfslite/files/patch-async-suio_vuprintf.C42
-rw-r--r--devel/sfslite/files/patch-async-sysconf.h30
-rw-r--r--devel/sfslite/files/patch-crypt-getsysnoise.C81
-rw-r--r--devel/sfslite/files/patch-rpcc-rpcc.C58
-rw-r--r--devel/sfslite/pkg-plist2
10 files changed, 6 insertions, 287 deletions
diff --git a/devel/sfslite/Makefile b/devel/sfslite/Makefile
index db793f7638b8..305b3fb26669 100644
--- a/devel/sfslite/Makefile
+++ b/devel/sfslite/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= sfslite
-PORTVERSION= 1.2.2
-PORTREVISION= 1
+PORTVERSION= 1.2.3
CATEGORIES= devel
MASTER_SITES= http://dist.okws.org/dist/
@@ -66,8 +65,4 @@ pre-install:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
.include <bsd.port.post.mk>
diff --git a/devel/sfslite/distinfo b/devel/sfslite/distinfo
index 3b41b27f2b1b..98e6ea2fed5c 100644
--- a/devel/sfslite/distinfo
+++ b/devel/sfslite/distinfo
@@ -1,3 +1,3 @@
-MD5 (sfslite-1.2.2.tar.gz) = a819f483eb2a0508f363c2f9cb2326e4
-SHA256 (sfslite-1.2.2.tar.gz) = 8b78bede2a2dc4d6756652a71ac22969490ab0bc2218b3651f2374067b146089
-SIZE (sfslite-1.2.2.tar.gz) = 1269819
+MD5 (sfslite-1.2.3.tar.gz) = 6948d99624977a6cc43fd8b586f5a60e
+SHA256 (sfslite-1.2.3.tar.gz) = 248882e541a5d503e402f0d2088b4a548be8ea8a572e6cec3b23e7fda9da0582
+SIZE (sfslite-1.2.3.tar.gz) = 1298113
diff --git a/devel/sfslite/files/patch-async-arena.h b/devel/sfslite/files/patch-async-arena.h
deleted file mode 100644
index 2e3c2e99a4b9..000000000000
--- a/devel/sfslite/files/patch-async-arena.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- async/arena.h.orig 2005-11-01 16:20:29.000000000 +0000
-+++ async/arena.h 2007-07-12 22:38:10.000000000 +0000
-@@ -61,7 +61,7 @@
- #ifdef DMALLOC
- char *_strdup_leap (const char *, int, const char *str)
- { return strcpy ((char *) alloc (1 + strlen (str), 1), str); }
-- char *dmalloc_strdup (const char *, int, const char *str, int)
-+ char *dmalloc_strndup (const char *, int, const char *str, int, int)
- { return strcpy ((char *) alloc (1 + strlen (str), 1), str); }
- #endif /* DMALLOC */
-
diff --git a/devel/sfslite/files/patch-async-daemonize.C b/devel/sfslite/files/patch-async-daemonize.C
deleted file mode 100644
index d4779f0a0e18..000000000000
--- a/devel/sfslite/files/patch-async-daemonize.C
+++ /dev/null
@@ -1,45 +0,0 @@
---- async/daemonize.C.orig 2005-11-01 16:20:30.000000000 +0000
-+++ async/daemonize.C 2007-07-12 22:38:51.000000000 +0000
-@@ -49,18 +49,18 @@
- const str &logfile, int flags, mode_t mode)
- {
- #ifdef PATH_LOGGER
-- char *av[] = { PATH_LOGGER, "-p", NULL, "-t", NULL, NULL, NULL };
-+ char *av[] = { (char *)PATH_LOGGER, (char *)"-p", NULL, (char *)"-t", NULL, NULL, NULL };
- av[2] = const_cast<char *> (priority.cstr ());
-
- if (line)
- av[5] = const_cast<char *> (line.cstr ());
- else
-- av[5] = "log started";
-+ av[5] = (char *)"log started";
-
- if (tag)
- av[4] = const_cast<char *> (tag.cstr ());
- else
-- av[4] = "";
-+ av[4] = (char *)"";
-
- pid_t pid;
- int status;
-@@ -93,9 +93,9 @@
- start_logger ()
- {
- #ifdef PATH_LOGGER
-- char *av[] = { PATH_LOGGER, "-p",
-+ char *av[] = { (char *)PATH_LOGGER, (char *)"-p",
- const_cast<char *> (syslog_priority.cstr ()),
-- "-t", "", NULL};
-+ (char *)"-t", (char *)"", NULL};
- int fds[2];
-
- close (0);
-@@ -177,7 +177,7 @@
- piddir = builddir;
- str path = strbuf () << piddir << "/" << progname << ".pid";
- struct stat sb;
-- if (str2file (path, strbuf ("%d\n", int (getpid ())), 0444, &sb))
-+ if (str2file (path, strbuf ("%d\n", int (getpid ())), 0444, false, &sb))
- pidfiles.push_back (pidfile (path, sb));
- }
- }
diff --git a/devel/sfslite/files/patch-async-parseopt.C b/devel/sfslite/files/patch-async-parseopt.C
deleted file mode 100644
index 5f0df5ab9b63..000000000000
--- a/devel/sfslite/files/patch-async-parseopt.C
+++ /dev/null
@@ -1,11 +0,0 @@
---- async/parseopt.C.orig 2005-11-01 16:20:32.000000000 +0000
-+++ async/parseopt.C 2007-07-12 22:38:53.000000000 +0000
-@@ -24,7 +24,7 @@
- #include "amisc.h"
- #include "parseopt.h"
-
--char *parseargs::errorbuf = "";
-+char *parseargs::errorbuf = (char *)"";
-
- static inline int
- isspc (char c)
diff --git a/devel/sfslite/files/patch-async-suio_vuprintf.C b/devel/sfslite/files/patch-async-suio_vuprintf.C
deleted file mode 100644
index 28aaf5aa19b2..000000000000
--- a/devel/sfslite/files/patch-async-suio_vuprintf.C
+++ /dev/null
@@ -1,42 +0,0 @@
---- async/suio_vuprintf.C.orig 2005-11-01 16:20:33.000000000 +0000
-+++ async/suio_vuprintf.C 2007-07-12 22:38:56.000000000 +0000
-@@ -139,7 +139,7 @@
- int dprec; /* a copy of prec if [diouxX], 0 otherwise */
- int realsz; /* field size expanded by dprec */
- int size; /* size of converted field or string */
-- char *xdigs = ""; /* digits for [xX] conversion */
-+ char *xdigs = (char *)""; /* digits for [xX] conversion */
-
- char buf[BUF]; /* space for %c, %[diouxX], %[eEfgG] */
- char ox[2]; /* space for 0x hex-prefix */
-@@ -392,7 +392,7 @@
- /* NOSTRICT */
- _uquad = (u_long) va_arg (ap, void *);
- base = HEX;
-- xdigs = "0123456789abcdef";
-+ xdigs = (char *)"0123456789abcdef";
- flags |= HEXPREFIX;
- ch = 'x';
- goto nosign;
-@@ -435,10 +435,10 @@
- base = DEC;
- goto nosign;
- case 'X':
-- xdigs = "0123456789ABCDEF";
-+ xdigs = (char *)"0123456789ABCDEF";
- goto hex;
- case 'x':
-- xdigs = "0123456789abcdef";
-+ xdigs = (char *)"0123456789abcdef";
- hex:
- _uquad = UARG ();
- base = HEX;
-@@ -498,7 +498,7 @@
- break;
-
- default:
-- cp = "bug in vfprintf: bad base";
-+ cp = (char *)"bug in vfprintf: bad base";
- size = strlen (cp);
- goto skipsize;
- }
diff --git a/devel/sfslite/files/patch-async-sysconf.h b/devel/sfslite/files/patch-async-sysconf.h
deleted file mode 100644
index 0bca4646e2e6..000000000000
--- a/devel/sfslite/files/patch-async-sysconf.h
+++ /dev/null
@@ -1,30 +0,0 @@
---- async/sysconf.h.orig Thu Aug 30 16:57:16 2007
-+++ async/sysconf.h Fri Sep 14 01:46:21 2007
-@@ -495,15 +495,16 @@
- #include <dmalloc.h>
-
- #undef memcpy
-+#undef memmove
- #undef xfree
-
- #if DMALLOC_VERSION_MAJOR < 5 || \
- (DMALLOC_VERSION_MAJOR == 5 && DMALLOC_VERSION_MINOR < 5)
-
- #define memcpy(to, from, len) \
-- _dmalloc_memcpy((char *) (to), (const char *) (from), len)
-+ _dmalloc_memcpy(__FILE__, __LINE__, (char *) (to), (const char *) (from), len)
- #define memmove(to, from, len) \
-- _dmalloc_bcopy((const char *) (from), (char *) (to), len)
-+ _dmalloc_bcopy(__FILE__, __LINE__, (const char *) (from), (char *) (to), len)
-
- #endif /* version < 5.5 */
-
-@@ -515,7 +516,7 @@
- dmalloc_malloc (f, l, s, DMALLOC_FUNC_MALLOC, 0, 0)
- #define _xfree_leap(f, l, p) dmalloc_free (f, l, p, DMALLOC_FUNC_FREE)
- #undef xstrdup
--#define xstrdup(__s) ((char *) dmalloc_strdup(__FILE__, __LINE__, __s, 1))
-+#define xstrdup(__s) ((char *) dmalloc_strndup(__FILE__, __LINE__, __s, -1, 1))
- #endif /* DMALLOC_VERSION_MAJOR >= 5 */
-
- static inline void
diff --git a/devel/sfslite/files/patch-crypt-getsysnoise.C b/devel/sfslite/files/patch-crypt-getsysnoise.C
deleted file mode 100644
index 83223d62e3cb..000000000000
--- a/devel/sfslite/files/patch-crypt-getsysnoise.C
+++ /dev/null
@@ -1,81 +0,0 @@
---- crypt/getsysnoise.C.orig 2005-11-01 16:20:36.000000000 +0000
-+++ crypt/getsysnoise.C 2007-07-12 22:38:59.000000000 +0000
-@@ -27,57 +27,57 @@
- #include <sys/resource.h>
-
- char *const noiseprogs[][5] = {
-- { PATH_PS, "laxwww" },
-- { PATH_PS, "-al" },
-- { PATH_LS, "-nfail", "/tmp/." },
-+ { (char *)PATH_PS, (char *)"laxwww" },
-+ { (char *)PATH_PS, (char *)"-al" },
-+ { (char *)PATH_LS, (char *)"-nfail", (char *)"/tmp/." },
- #ifdef PATH_NETSTAT
-- { PATH_NETSTAT, "-s" },
-- { PATH_NETSTAT, "-an" },
-- { PATH_NETSTAT, "-in" },
-+ { (char *)PATH_NETSTAT, (char *)"-s" },
-+ { (char *)PATH_NETSTAT, (char *)"-an" },
-+ { (char *)PATH_NETSTAT, (char *)"-in" },
- #endif /* PATH_NETSTAT */
- #ifdef PATH_NTPQ
-- { PATH_NTPQ, "-np" },
-+ { (char *)PATH_NTPQ, (char *)"-np" },
- #endif /* PATH_NTPQ */
- #ifdef PATH_W
-- { PATH_W },
-+ { (char *)PATH_W },
- #endif /* PATH_W */
- #ifdef PATH_NFSSTAT
-- { PATH_NFSSTAT },
-+ { (char *)PATH_NFSSTAT },
- #endif /* PATH_NFSSTAT */
- #ifdef PATH_VNSTAT
-- { PATH_VMSTAT },
-- { PATH_VMSTAT, "-i" },
-- { PATH_VMSTAT, "-s" },
-+ { (char *)PATH_VMSTAT },
-+ { (char *)PATH_VMSTAT, (char *)"-i" },
-+ { (char *)PATH_VMSTAT, (char *)"-s" },
- #endif /* PATH_VNSTAT */
- #ifdef PATH_IOSTAT
- #if defined (__linux__) || defined (__osf__)
-- { PATH_IOSTAT },
-+ { (char *)PATH_IOSTAT },
- #else /* not linux or osf */
-- { PATH_IOSTAT, "-I" },
-+ { (char *)PATH_IOSTAT, (char *)"-I" },
- #endif /* not linux or osf */
- #endif /* PATH_IOSTAT */
- #ifdef PATH_LSOF
-- { PATH_LSOF, "-bwn",
-+ { (char *)PATH_LSOF, (char *)"-bwn",
- # ifdef LSOF_DEVCACHE
-- "-Di"
-+ (char *)"-Di"
- # endif /* LSOF_DEVCACHE */
- },
- #else /* no lsof */
- # ifdef PATH_FSTAT
-- { PATH_FSTAT },
-+ { (char *)PATH_FSTAT },
- # endif /* PATH_FSTAT */
- # ifdef PATH_PSTAT
-- { PATH_PSTAT, "-f" },
-+ { (char *)PATH_PSTAT, (char *)"-f" },
- # endif /* PATH_PSTAT */
- #endif /* no lsof */
- #ifdef PATH_PSTAT
-- { PATH_PSTAT, "-t" },
-+ { (char *)PATH_PSTAT, (char *)"-t" },
- # if defined (__OpenBSD__) || defined (__NetBSD__) || defined (__FreeBSD__)
-- { PATH_PSTAT, "-v" },
-+ { (char *)PATH_PSTAT, (char *)"-v" },
- # endif /* open/net/freebsd */
- #endif /* PATH_PSTAT */
- #ifdef PATH_NFSSTAT
-- { PATH_NFSSTAT },
-+ { (char *)PATH_NFSSTAT },
- #endif /* PATH_NFSSTAT */
- #if 0
- { PATH_RUP },
diff --git a/devel/sfslite/files/patch-rpcc-rpcc.C b/devel/sfslite/files/patch-rpcc-rpcc.C
deleted file mode 100644
index 41383c390340..000000000000
--- a/devel/sfslite/files/patch-rpcc-rpcc.C
+++ /dev/null
@@ -1,58 +0,0 @@
---- rpcc/rpcc.C.orig 2005-07-15 23:21:51.000000000 +0000
-+++ rpcc/rpcc.C 2007-07-12 22:39:01.000000000 +0000
-@@ -152,8 +152,8 @@
- void (*fn) (str) = NULL;
- int len;
-
-- av.push_back (PATH_CPP);
-- av.push_back ("-DRPCC");
-+ av.push_back ((char *)PATH_CPP);
-+ av.push_back ((char *)"-DRPCC");
- av.push_back (NULL);
-
- for (an = 1; an < argc; an++) {
-@@ -213,38 +213,38 @@
-
- switch (mode) {
- case HEADER:
-- av[2] = "-DRPCC_H";
-+ av[2] = (char *)"-DRPCC_H";
- fn = genheader;
- if (!outfile)
- outfile = strbuf ("%.*sh", len - 1, basename);
- break;
- case CFILE:
-- av[2] = "-DRPCC_C";
-+ av[2] = (char *)"-DRPCC_C";
- fn = gencfile;
- if (!outfile)
- outfile = strbuf ("%.*sC", len - 1, basename);
- break;
- case PYTHON:
-- av[2] = "-DRPCC_P";
-+ av[2] = (char *)"-DRPCC_P";
- fn = genpython;
- if (!outfile)
- outfile = strbuf ("%.*spy", len - 1, basename);
- break;
- case PYL:
-- av[2] = "-DRPCC_PYL";
-+ av[2] = (char *)"-DRPCC_PYL";
- fn = genpyc_lib;
- // foo.x -> foo_lib.C
- if (!outfile)
- outfile = strbuf ("%.*s_lib.C", len - 2, basename);
- break;
- case PYH:
-- av[2] = "-DRPCC_PYH";
-+ av[2] = (char *)"-DRPCC_PYH";
- fn = genpyh;
- if (!outfile)
- outfile = strbuf ("%.*sh", len -1, basename);
- break;
- case PYS:
-- av[2] = "-DRPCC_PYS";
-+ av[2] = (char *)"-DRPCC_PYS";
- fn = genpyc_so;
- // foo.x -> foo_so.C
- if (!outfile)
diff --git a/devel/sfslite/pkg-plist b/devel/sfslite/pkg-plist
index 17bb6956a799..410b1a217ff0 100644
--- a/devel/sfslite/pkg-plist
+++ b/devel/sfslite/pkg-plist
@@ -35,6 +35,7 @@ include/sfslite-%%VERSION%%/%%TAG%%/crypthash.h
include/sfslite-%%VERSION%%/%%TAG%%/dns.h
include/sfslite-%%VERSION%%/%%TAG%%/dnsimpl.h
include/sfslite-%%VERSION%%/%%TAG%%/dnsparse.h
+include/sfslite-%%VERSION%%/%%TAG%%/dynenum.h
include/sfslite-%%VERSION%%/%%TAG%%/err.h
include/sfslite-%%VERSION%%/%%TAG%%/esign.h
include/sfslite-%%VERSION%%/%%TAG%%/fdlim.h
@@ -65,6 +66,7 @@ include/sfslite-%%VERSION%%/%%TAG%%/prime.h
include/sfslite-%%VERSION%%/%%TAG%%/prng.h
include/sfslite-%%VERSION%%/%%TAG%%/qhash.h
include/sfslite-%%VERSION%%/%%TAG%%/rabin.h
+include/sfslite-%%VERSION%%/%%TAG%%/rclist.h
include/sfslite-%%VERSION%%/%%TAG%%/refcnt.h
include/sfslite-%%VERSION%%/%%TAG%%/rex.h
include/sfslite-%%VERSION%%/%%TAG%%/rpctypes.h