aboutsummaryrefslogtreecommitdiff
path: root/devel/shapelib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/shapelib/Makefile')
-rw-r--r--devel/shapelib/Makefile8
1 files changed, 6 insertions, 2 deletions
diff --git a/devel/shapelib/Makefile b/devel/shapelib/Makefile
index 172a5fb091e1..a658f6bb44c7 100644
--- a/devel/shapelib/Makefile
+++ b/devel/shapelib/Makefile
@@ -13,11 +13,15 @@ MASTER_SITES= ftp://gdal.velocet.ca/pub/outgoing/
MAINTAINER= ports@FreeBSD.org
COMMENT= C API for reading and writing ArcView Shapefiles
-BUILD_DEPENDS= libtool:${PORTSDIR}/devel/libtool
-
+USE_LIBTOOL= yes
+LIBTOOLFILES= # none
ALL_TARGET= lib
INSTALLS_SHLIB= yes
+# no configure script, but we need the libtool environment
+do-configure:
+ @${CP} ${LIBTOOL} ${WRKSRC}
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/.libs/libshp.so.1 ${PREFIX}/lib
${LN} -sf libshp.so.1 ${PREFIX}/lib/libshp.so