aboutsummaryrefslogtreecommitdiff
path: root/devel/simulavr
diff options
context:
space:
mode:
Diffstat (limited to 'devel/simulavr')
-rw-r--r--devel/simulavr/Makefile2
-rw-r--r--devel/simulavr/files/patch-test_asm22
2 files changed, 23 insertions, 1 deletions
diff --git a/devel/simulavr/Makefile b/devel/simulavr/Makefile
index 2e32330ce41d..bd985f5f49b2 100644
--- a/devel/simulavr/Makefile
+++ b/devel/simulavr/Makefile
@@ -7,7 +7,7 @@
PORTNAME= simulavr
PORTVERSION= 0.1.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/devel/simulavr/files/patch-test_asm b/devel/simulavr/files/patch-test_asm
new file mode 100644
index 000000000000..56a7749fb4d6
--- /dev/null
+++ b/devel/simulavr/files/patch-test_asm
@@ -0,0 +1,22 @@
+--- test_asm/test_8515/Makefile.am.orig Thu Aug 14 04:35:06 2003
++++ test_asm/test_8515/Makefile.am Thu Jun 17 10:22:38 2004
+@@ -51,7 +51,7 @@
+
+ all-local: $(TEST_ELF) $(TEST_LST) $(TEST_BIN) $(TEST_HEX)
+ for prg in $(TEST_PRG); do \
+- $(AVR_LD) -m avr85xx -o $$prg $${prg}.elf || exit 1; \
++ $(AVR_LD) -m avr2 -o $$prg $${prg}.elf || exit 1; \
+ done
+
+ clean-local:
+--- test_asm/test_8515/Makefile.in.orig Mon Jan 19 00:58:31 2004
++++ test_asm/test_8515/Makefile.in Thu Jun 17 10:23:08 2004
+@@ -379,7 +379,7 @@
+
+ all-local: $(TEST_ELF) $(TEST_LST) $(TEST_BIN) $(TEST_HEX)
+ for prg in $(TEST_PRG); do \
+- $(AVR_LD) -m avr85xx -o $$prg $${prg}.elf || exit 1; \
++ $(AVR_LD) -m avr2 -o $$prg $${prg}.elf || exit 1; \
+ done
+
+ clean-local: