aboutsummaryrefslogtreecommitdiff
path: root/devel/smokeqt/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/smokeqt/Makefile')
-rw-r--r--devel/smokeqt/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/devel/smokeqt/Makefile b/devel/smokeqt/Makefile
index 44bb53c5539c..e06e0afcabd5 100644
--- a/devel/smokeqt/Makefile
+++ b/devel/smokeqt/Makefile
@@ -5,7 +5,7 @@ PORTVERSION= ${KDE4_VERSION}
CATEGORIES= devel kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= ${KDE4_BRANCH}/${PORTVERSION}/src
-DIST_SUBDIR= KDE
+DIST_SUBDIR= KDE/${PORTVERSION}
MAINTAINER= kde@FreeBSD.org
COMMENT= SMOKE bindings for Qt
@@ -16,12 +16,12 @@ LIB_DEPENDS= qscintilla2:${PORTSDIR}/devel/qscintilla2 \
CONFLICTS= kdebindings-smoke-4.[0-6].*
USE_KDE4= kdehier kdeprefix smokegen qimageblitz
-USE_QT4= dbus declarative designer gui help multimedia \
- network opengl phonon qt3support qtestlib \
- script sql svg xml xmlpatterns webkit \
+USE_QT4= corelib dbus declarative designer_build gui help \
+ multimedia network opengl phonon qtestlib script \
+ sql svg webkit xml xmlpatterns \
qmake_build moc_build uic_build rcc_build
-USE_XZ= yes
-USES= cmake
+USE_XZ= yes
+USES= cmake:outsource
MAKE_JOBS_SAFE= yes
USE_LDCONFIG= yes