aboutsummaryrefslogtreecommitdiff
path: root/devel/stlfilt
diff options
context:
space:
mode:
Diffstat (limited to 'devel/stlfilt')
-rw-r--r--devel/stlfilt/Makefile35
-rw-r--r--devel/stlfilt/distinfo2
-rw-r--r--devel/stlfilt/pkg-descr6
3 files changed, 43 insertions, 0 deletions
diff --git a/devel/stlfilt/Makefile b/devel/stlfilt/Makefile
new file mode 100644
index 000000000000..4486441bf63a
--- /dev/null
+++ b/devel/stlfilt/Makefile
@@ -0,0 +1,35 @@
+# ex:ts=8
+# Ports collection makefile for: stlfilt
+# Date created: Mar 12, 2004
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= stlfilt
+PORTVERSION= 20040221
+CATEGORIES= devel
+MASTER_SITES= http://www.bdsoft.com/dist/
+DISTNAME= g${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= An STL Error Message Decryptor for C++
+
+USE_ZIP= yes
+USE_REINPLACE= yes
+USE_PERL5_RUN= yes
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+PLIST_FILES= bin/gSTLFilt.pl bin/gfilt
+
+post-patch:
+ @${REINPLACE_CMD} -e "s, ,," ${WRKSRC}/gSTLFilt.pl ${WRKSRC}/gfilt
+ @${REINPLACE_CMD} -e "s,[$$]HOME,${PREFIX}/bin," ${WRKSRC}/gfilt
+
+do-install:
+.for file in gSTLFilt.pl gfilt
+ @${INSTALL_SCRIPT} ${WRKSRC}/${file} ${PREFIX}/bin
+.endfor
+
+.include <bsd.port.mk>
diff --git a/devel/stlfilt/distinfo b/devel/stlfilt/distinfo
new file mode 100644
index 000000000000..063dbc5501b5
--- /dev/null
+++ b/devel/stlfilt/distinfo
@@ -0,0 +1,2 @@
+MD5 (gstlfilt.zip) = 49328821de2a8cd69f91c2f2e4328e08
+SIZE (gstlfilt.zip) = 412277
diff --git a/devel/stlfilt/pkg-descr b/devel/stlfilt/pkg-descr
new file mode 100644
index 000000000000..ff85f63b1059
--- /dev/null
+++ b/devel/stlfilt/pkg-descr
@@ -0,0 +1,6 @@
+STLFilt simplifies and/or reformats long-winded C++ error and warning
+messages, with a focus on STL-related diagnostics (and for MSVC 6, it
+fully eliminates C4786 warnings and their detritus). The result renders
+many of even the most cryptic diagnostics comprehensible.
+
+WWW: http://www.bdsoft.com/tools/stlfilt.html