aboutsummaryrefslogtreecommitdiff
path: root/devel/swarm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/swarm/Makefile')
-rw-r--r--devel/swarm/Makefile13
1 files changed, 12 insertions, 1 deletions
diff --git a/devel/swarm/Makefile b/devel/swarm/Makefile
index e8223bd846d5..1419ee5094a2 100644
--- a/devel/swarm/Makefile
+++ b/devel/swarm/Makefile
@@ -26,6 +26,7 @@ USE_JAVA= 1.3+
USE_GMAKE= yes
USE_XPM= yes
USE_LIBTOOL= yes
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --with-defaultdir=${PREFIX} \
--with-tclincludedir=${PREFIX}/include/tcl8.3 \
@@ -33,11 +34,18 @@ CONFIGURE_ARGS= --with-defaultdir=${PREFIX} \
--with-tclscriptdir=${PREFIX}/lib/tcl8.3 \
--with-tkscriptdir=${PREFIX}/lib/tk8.3 \
--enable-subdirs
+PLIST_SUB= JAVA="@comment "
.if defined(WITH_JAVA)
CONFIGURE_ARGS+= --with-jdkdir=${JAVA_HOME}
-PLIST= ${PKGDIR}/pkg-plist.withjava
+PLIST_SUB= JAVA=""
.endif
+post-patch:
+ @${REINPLACE_CMD} \
+ -e 's|%%LTCONFIG%%|${LIBTOOL_SHAREDIR}/ltconfig${LIBTOOL_VERSION}|g' \
+ -e 's|%%LTMAIN%%|${LIBTOOL_SHAREDIR}/ltmain.sh|g' \
+ ${WRKSRC}/configure
+
pre-everything::
.if !defined(WITH_JAVA)
@${ECHO_MSG} "===>"
@@ -50,6 +58,9 @@ pre-everything::
@${ECHO_MSG} "===>"
.endif
+post-patch:
+
+
post-install:
${CAT} ${PKGMESSAGE} | ${SED} -e "s:%%PREFIX%%:${PREFIX}:g"