aboutsummaryrefslogtreecommitdiff
path: root/devel/tclbsd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/tclbsd/Makefile')
-rw-r--r--devel/tclbsd/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/devel/tclbsd/Makefile b/devel/tclbsd/Makefile
index 2d9463a9fe88..015885c8eaec 100644
--- a/devel/tclbsd/Makefile
+++ b/devel/tclbsd/Makefile
@@ -14,18 +14,15 @@ LICENSE= MIT
OPTIONS_DEFINE= DOCS
PORTDOCS= bsd.pdf
-USES= tcl
-USE_AUTOTOOLS= autoconf
+USES= autoreconf tcl:tea
+TCL_PKG= BSD${PORTVERSION}
USE_GITHUB= yes
GH_ACCOUNT= flightaware
-CONFIGURE_ARGS+=--exec-prefix=${PREFIX} \
- --with-tcl=${TCL_LIBDIR}
-
-PLIST_FILES= lib/BSD${PORTVERSION}/bsd_procs.tcl \
- lib/BSD${PORTVERSION}/libBSD${PORTVERSION}.so \
- lib/BSD${PORTVERSION}/pkgIndex.tcl \
+PLIST_FILES= lib/${TCL_PKG}/bsd_procs.tcl \
+ lib/${TCL_PKG}/lib${TCL_PKG}.so \
+ lib/${TCL_PKG}/pkgIndex.tcl \
man/mann/bsd.n.gz
post-install: