aboutsummaryrefslogtreecommitdiff
path: root/devel/tcloo/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/tcloo/Makefile')
-rw-r--r--devel/tcloo/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/devel/tcloo/Makefile b/devel/tcloo/Makefile
index 4f7d7eadc7a5..b4eac3c21f6e 100644
--- a/devel/tcloo/Makefile
+++ b/devel/tcloo/Makefile
@@ -2,20 +2,25 @@
# $FreeBSD$
PORTNAME= tcloo
-PORTVERSION= 1.0.2
+PORTVERSION= 1.0.4
CATEGORIES= devel
-MASTER_SITES= SF/tcl/TclOO%20Package/${PORTVERSION}/
-DISTNAME= TclOO${PORTVERSION}
+MASTER_SITES= http://core.tcl.tk/tcloo/tarball/
+DISTNAME= TclOO+Package-${FOSSIL_CHECKIN}
MAINTAINER= tcltk@FreeBSD.org
COMMENT= Implementation of TclOO for Tcl 8.5
+FOSSIL_CHECKIN= 0a6e9f1ea3
+WRKSRC= ${WRKDIR}/${DISTNAME:S/+/_/}
USES+= tcl:85
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR} \
--exec-prefix=${PREFIX}
+CFLAGS+= -fPIC
PLIST_SUB+= PORTVERSION=${PORTVERSION}
+TEST_TARGET= test
+
.include <bsd.port.mk>