aboutsummaryrefslogtreecommitdiff
path: root/devel/thrift-cpp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/thrift-cpp/Makefile')
-rw-r--r--devel/thrift-cpp/Makefile5
1 files changed, 1 insertions, 4 deletions
diff --git a/devel/thrift-cpp/Makefile b/devel/thrift-cpp/Makefile
index 8a2652dabd0f..366e1f43da2d 100644
--- a/devel/thrift-cpp/Makefile
+++ b/devel/thrift-cpp/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libevent.so:devel/libevent2
USES= autoreconf pkgconfig gmake compiler:c++11-lang \
- libtool ssl
+ libtool pathfix ssl
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
@@ -60,9 +60,6 @@ BROKEN_FreeBSD_9= does not build with 9.x base OpenSSL
USE_CXXSTD= c++11
.endif
-post-patch:
- @${REINPLACE_CMD} 's,^pkgconfigdir = .*,pkgconfigdir=$${prefix}/libdata/pkgconfig,' ${WRKSRC}/lib/cpp/Makefile.am
-
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/lib*.so
${LN} -sf libthrift-${PORTVERSION}.so ${STAGEDIR}${PREFIX}/lib/libthrift.so.0