aboutsummaryrefslogtreecommitdiff
path: root/devel/uclmmbase/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/uclmmbase/Makefile')
-rw-r--r--devel/uclmmbase/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/devel/uclmmbase/Makefile b/devel/uclmmbase/Makefile
index 3060c90dd97a..785e2e71565c 100644
--- a/devel/uclmmbase/Makefile
+++ b/devel/uclmmbase/Makefile
@@ -6,9 +6,9 @@
#
PORTNAME= uclmmbase
-PORTVERSION= 1.2.16
+PORTVERSION= 1.2.18
CATEGORIES= devel ipv6
-MASTER_SITES= http://www-mice.cs.ucl.ac.uk/multimedia/software/common/
+MASTER_SITES= http://aldan.algebra.com/~mi/port-stuff/
DISTNAME= common-${PORTVERSION}
MAINTAINER= mi@aldan.algebra.com
@@ -17,7 +17,11 @@ COMMENT= Common subroutines for UCL mbone applications
WRKSRC= ${WRKDIR}/common
GNU_CONFIGURE= yes
USE_OPENSSL= yes
+.ifndef (NO_INET6)
CONFIGURE_ARGS= --enable-ipv6
+.endif
+USE_XZ= yes
+MAKE_JOBS_SAFE= yes
post-configure:
@for f in ${FILESDIR}/*.bsd ; do \
@@ -28,7 +32,7 @@ post-configure:
# the networking-error, which may be due IPv6 (or IPv4) being unavailable
# or some network (mis)configuration:
post-build test:
- ${WRKSRC}/tests/test-libcommon 2>&1 | ${AWK} ' \
+ cd ${WRKSRC} && tests/test-libcommon 2>&1 | ${AWK} ' \
/fail$$/ && $$2 != "networking" { code=1 } \
{ print } END { exit code }'