aboutsummaryrefslogtreecommitdiff
path: root/devel/ucpp
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ucpp')
-rw-r--r--devel/ucpp/Makefile3
-rw-r--r--devel/ucpp/distinfo2
-rw-r--r--devel/ucpp/files/patch-Makefile18
3 files changed, 11 insertions, 12 deletions
diff --git a/devel/ucpp/Makefile b/devel/ucpp/Makefile
index bf91d7236fb4..cb6fbf64e7cb 100644
--- a/devel/ucpp/Makefile
+++ b/devel/ucpp/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= ucpp
-PORTVERSION= 1.2
-PORTREVISION= 1
+PORTVERSION= 1.3
CATEGORIES= devel
MASTER_SITES= http://pornin.nerim.net/ucpp/
diff --git a/devel/ucpp/distinfo b/devel/ucpp/distinfo
index f1492a9525bb..14b35c67fff0 100644
--- a/devel/ucpp/distinfo
+++ b/devel/ucpp/distinfo
@@ -1 +1 @@
-MD5 (ucpp-1.2.tar.gz) = 2bc332b2158d5274b0154b5939afbca4
+MD5 (ucpp-1.3.tar.gz) = f6f508ab42dd3eb57c0411a25429c9e8
diff --git a/devel/ucpp/files/patch-Makefile b/devel/ucpp/files/patch-Makefile
index 859fa3ea81f8..b357f843dfc0 100644
--- a/devel/ucpp/files/patch-Makefile
+++ b/devel/ucpp/files/patch-Makefile
@@ -1,20 +1,20 @@
---- Makefile.orig Wed Feb 20 18:49:16 2002
-+++ Makefile Sun Dec 1 09:01:06 2002
+--- Makefile.orig Wed Jan 15 02:07:44 2003
++++ Makefile Sun Jul 27 14:51:51 2003
@@ -56,8 +56,8 @@
#FLAGS = -O -m -DMEM_CHECK
# for gcc
-CC = gcc
--FLAGS = -g -Wall -ansi -pedantic -DAUDIT -DMEM_DEBUG
+-FLAGS = -g -W -Wall -ansi -DAUDIT -DMEM_DEBUG
+CC ?= gcc
-+FLAGS = -ansi -pedantic -DAUDIT -DMEM_DEBUG
- #FLAGS = -O3 -Wall -ansi -pedantic -DMEM_CHECK
-
- # for the Compaq C compiler on Alpha/Linux
-@@ -78,7 +78,7 @@
++FLAGS = -ansi -DAUDIT -DMEM_DEBUG
+ #FLAGS = -O3 -mcpu=pentiumpro -fomit-frame-pointer -W -Wall -ansi -DMEM_CHECK
+ #FLAGS = -O -pg -W -Wall -ansi -DMEM_CHECK
+ #LDFLAGS = -pg
+@@ -80,7 +80,7 @@
# ----- nothing should be changed below this line -----
- COBJ = mem.o hash.o cpp.o lexer.o assert.o macro.o eval.o
+ COBJ = mem.o nhash.o cpp.o lexer.o assert.o macro.o eval.o
-CFLAGS = $(FLAGS) -DSTAND_ALONE
+CFLAGS += $(FLAGS) -DSTAND_ALONE