aboutsummaryrefslogtreecommitdiff
path: root/devel/ustl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/ustl/Makefile')
-rw-r--r--devel/ustl/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/devel/ustl/Makefile b/devel/ustl/Makefile
index b8bf2a07713e..449d550dee43 100644
--- a/devel/ustl/Makefile
+++ b/devel/ustl/Makefile
@@ -28,6 +28,12 @@ ALL_TARGET= # empty
PLIST_FILES= lib/libustl.a
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} != "i386"
+BROKEN= "Does not compile on !i386"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s,/bin/bash,/bin/sh," ${WRKSRC}/configure
@${REINPLACE_CMD} -e "s|SIZE_MAX|UINT_MAX|" ${WRKSRC}/memblock.h
@@ -39,4 +45,4 @@ post-install:
@${FIND} ${PREFIX}/include/ustl* -type d | ${SORT} -r | \
${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>