aboutsummaryrefslogtreecommitdiff
path: root/devel/wftk
diff options
context:
space:
mode:
Diffstat (limited to 'devel/wftk')
-rw-r--r--devel/wftk/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/devel/wftk/Makefile b/devel/wftk/Makefile
index 15dace3f5a94..4411145bf83c 100644
--- a/devel/wftk/Makefile
+++ b/devel/wftk/Makefile
@@ -17,9 +17,11 @@ COMMENT= A Graphical User Interface library for C++
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
sigc.1:${PORTSDIR}/devel/libsigc++
+OPTIONS= SDL_MIXER "music and sound support" off
+
USE_FREETYPE= yes
USE_LIBTOOL= yes
-USE_SDL= yes
+USE_SDL= sdl
GNU_CONFIGURE= yes
USE_REINPLACE= yes
INSTALLS_SHLIB= yes
@@ -41,13 +43,6 @@ WITH_SDL_MIXER= yes
USE_SDL= mixer sdl
.endif
-pre-everything::
- @${ECHO} ""
- @${ECHO} "You may use the following build options:"
- @${ECHO} ""
- @${ECHO} " WITH_SDL_MIXER=yes Enable music and sound support"
- @${ECHO} ""
-
post-patch:
.for i in ${SDL11_FILES}
@${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/$i