aboutsummaryrefslogtreecommitdiff
path: root/devel/wftk
diff options
context:
space:
mode:
Diffstat (limited to 'devel/wftk')
-rw-r--r--devel/wftk/Makefile61
-rw-r--r--devel/wftk/distinfo2
-rw-r--r--devel/wftk/files/patch-uta::blitters.cc46
-rw-r--r--devel/wftk/files/patch-uta::painter.cc10
-rw-r--r--devel/wftk/pkg-descr6
-rw-r--r--devel/wftk/pkg-plist54
6 files changed, 0 insertions, 179 deletions
diff --git a/devel/wftk/Makefile b/devel/wftk/Makefile
deleted file mode 100644
index a9e0094ffd30..000000000000
--- a/devel/wftk/Makefile
+++ /dev/null
@@ -1,61 +0,0 @@
-# New ports collection makefile for: libuta
-# Date created: 29 March 2001
-# Whom: Oliver Lehmann <lehmann@ans-netz.de>
-#
-# $FreeBSD$
-#
-
-PORTNAME= libuta
-PORTVERSION= 0.4.4
-PORTREVISION= 4
-CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
-
-MAINTAINER= oliver@FreeBSD.org
-COMMENT= A Graphical User Interface library for C++
-
-LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
- sigc.1:${PORTSDIR}/devel/libsigc++
-
-OPTIONS= SDL_MIXER "music and sound support" off
-
-USE_FREETYPE= yes
-USE_INC_LIBTOOL_VER= 13
-USE_SDL= sdl
-GNU_CONFIGURE= yes
-USE_REINPLACE= yes
-INSTALLS_SHLIB= yes
-
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
-
-WANT_SDL= yes
-
-SDL11_FILES= configure uta/color.h uta/event.h uta/keysym.h uta/mutex.h \
- uta/pixelformat.h uta/rect.h uta/sge_blib.cc uta/sge_blib.h \
- uta/sge_draw.cc uta/sge_draw.h uta/sound.h uta/surface_io.cc \
- uta/surface.h uta/timer.cc
-
-.include <bsd.port.pre.mk>
-
-.if ${HAVE_SDL:Mmixer}!=""
-WITH_SDL_MIXER= yes
-.endif
-
-.if defined(WITH_SDL_MIXER)
-USE_SDL+= mixer
-.endif
-
-post-patch:
-.for i in ${SDL11_FILES}
- @${REINPLACE_CMD} -e 's|SDL/|SDL11/|' ${WRKSRC}/$i
-.endfor
-
-pre-configure:
- @${REINPLACE_CMD} -e '\
- s|<freetype/freetype.h>|<freetype1/freetype/freetype.h>|g; \
- s|-lpthread||g; \
- s|-lc_r|${PTHREAD_LIBS}|g' \
- ${WRKSRC}/configure ${WRKSRC}/uta/font.h
-
-.include <bsd.port.post.mk>
diff --git a/devel/wftk/distinfo b/devel/wftk/distinfo
deleted file mode 100644
index 1ec62e1a8c02..000000000000
--- a/devel/wftk/distinfo
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 (libuta-0.4.4.tar.gz) = 1326c9f4a9de768289b9cb5f18a54cdc
-SIZE (libuta-0.4.4.tar.gz) = 388720
diff --git a/devel/wftk/files/patch-uta::blitters.cc b/devel/wftk/files/patch-uta::blitters.cc
deleted file mode 100644
index 8aed5a1d7927..000000000000
--- a/devel/wftk/files/patch-uta::blitters.cc
+++ /dev/null
@@ -1,46 +0,0 @@
---- uta/blitters.cc.orig Sat Oct 12 23:11:07 2002
-+++ uta/blitters.cc Thu Aug 12 20:58:40 2004
-@@ -20,6 +20,7 @@
-
- #include "blitters.h"
- #include <painter.h>
-+#include <cassert>
-
- namespace uta {
-
-@@ -28,6 +29,8 @@
- #endif
- #if !defined(X86_ASSEMBLER)
-
-+using namespace std;
-+
- /** Apply const gamma value.
- Blit just copies alpha value of the source to the destination surface.
- */
-@@ -163,7 +166,7 @@
- only using the lower 16bits of result
- ... this is somehow dumb, but only executed once
- per scanline, so I do not care */
-- movd_r2m(mm1,(unsigned int*)dPtr);
-+ movd_r2m(mm1,*(mmx_t*)dPtr);
- sPtr += 4;
- dPtr += 4;
- }
-@@ -211,7 +214,7 @@
- only using the lower 16bits of result
- ... this is somehow dumb, but only executed once
- per scanline, so I do not care */
-- movd_r2m(mm1,(unsigned int*)dPtr);
-+ movd_r2m(mm1,*(mmx_t*)dPtr);
- sPtr += 4;
- dPtr += 4;
- }
-@@ -960,7 +963,7 @@
- only using the lower 16bits of result
- ... this is somehow dumb, but only executed once
- per scanline, so I do not care */
-- movd_r2m(mm1,(unsigned int*)dPtr);
-+ movd_r2m(mm1,*(mmx_t*)dPtr);
- sPtr += 4;
- dPtr += 4;
- }
diff --git a/devel/wftk/files/patch-uta::painter.cc b/devel/wftk/files/patch-uta::painter.cc
deleted file mode 100644
index 3f9f2390b022..000000000000
--- a/devel/wftk/files/patch-uta::painter.cc
+++ /dev/null
@@ -1,10 +0,0 @@
---- uta/painter.cc.orig Sat Jul 26 01:22:51 2003
-+++ uta/painter.cc Fri Jul 25 23:24:47 2003
-@@ -27,6 +27,7 @@
- #include "debug.h"
-
- #include <math.h>
-+#include <cassert>
-
- namespace uta {
-
diff --git a/devel/wftk/pkg-descr b/devel/wftk/pkg-descr
deleted file mode 100644
index 6333d6de5fb8..000000000000
--- a/devel/wftk/pkg-descr
+++ /dev/null
@@ -1,6 +0,0 @@
-libuta is a Graphical User Interface library for C++ that uses SDL
-as its output layer. It allows application and game programmers to
-put together portable graphical applications easily. libuta has a
-range of already implemented widgets and uses libsigc++ as a signal
-dispatching system. It also performs resource management and has a
-sound system.
diff --git a/devel/wftk/pkg-plist b/devel/wftk/pkg-plist
deleted file mode 100644
index 7752b4e5a07f..000000000000
--- a/devel/wftk/pkg-plist
+++ /dev/null
@@ -1,54 +0,0 @@
-bin/uta-config
-lib/libuta.so
-lib/libuta-0.4.so.2
-lib/libuta.a
-include/uta/debug.h
-include/uta/color.h
-include/uta/point.h
-include/uta/rect.h
-include/uta/keysym.h
-include/uta/event.h
-include/uta/shared.h
-include/uta/pixelformat.h
-include/uta/painter.h
-include/uta/progressdialog.h
-include/uta/logo.h
-include/uta/logo_data.h
-include/uta/terminal.h
-include/uta/directsurface.h
-include/uta/mutex.h
-include/uta/version.h
-include/uta/uta.h
-include/uta/timer.h
-include/uta/dialogbox.h
-include/uta/messagebox.h
-include/uta/questionbox.h
-include/uta/blitters.h
-include/uta/mmx.h
-include/uta/application.h
-include/uta/button.h
-include/uta/dialog.h
-include/uta/focus.h
-include/uta/font.h
-include/uta/label.h
-include/uta/lineedit.h
-include/uta/listbox.h
-include/uta/mixer.h
-include/uta/mouse.h
-include/uta/mouse_data.h
-include/uta/movie.h
-include/uta/multilineedit.h
-include/uta/music.h
-include/uta/pushbutton.h
-include/uta/resources.h
-include/uta/rootwindow.h
-include/uta/sample.h
-include/uta/screensurface.h
-include/uta/slider.h
-include/uta/sound.h
-include/uta/soundmapper.h
-include/uta/surface.h
-include/uta/togglebutton.h
-include/uta/widget.h
-share/aclocal/uta.m4
-@dirrm include/uta