aboutsummaryrefslogtreecommitdiff
path: root/devel/xeus/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/xeus/Makefile')
-rw-r--r--devel/xeus/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/devel/xeus/Makefile b/devel/xeus/Makefile
index ebcd15cea4fa..631b37530304 100644
--- a/devel/xeus/Makefile
+++ b/devel/xeus/Makefile
@@ -1,7 +1,8 @@
# $FreeBSD$
PORTNAME= xeus
-DISTVERSION= 0.23.10
+DISTVERSION= 0.23.14
+PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= yuri@FreeBSD.org
@@ -23,6 +24,10 @@ GH_ACCOUNT= jupyter-xeus
USE_LDCONFIG= yes
CMAKE_OFF= BUILD_STATIC_LIBS
-CMAKE_ON= DISABLE_ARCH_NATIVE
+
+OPTIONS_DEFINE= NATIVE
+NATIVE_DESC= Build with native optimizations (-march=native)
+NATIVE_CMAKE_ON= -DXEUS_DISABLE_ARCH_NATIVE=OFF
+NATIVE_CMAKE_OFF= -DXEUS_DISABLE_ARCH_NATIVE=ON
.include <bsd.port.mk>