aboutsummaryrefslogtreecommitdiff
path: root/devel/xparam/files/patch-examples__calculator__Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'devel/xparam/files/patch-examples__calculator__Makefile.in')
-rw-r--r--devel/xparam/files/patch-examples__calculator__Makefile.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/devel/xparam/files/patch-examples__calculator__Makefile.in b/devel/xparam/files/patch-examples__calculator__Makefile.in
new file mode 100644
index 000000000000..c9ce136e45fe
--- /dev/null
+++ b/devel/xparam/files/patch-examples__calculator__Makefile.in
@@ -0,0 +1,15 @@
+--- examples/calculator/Makefile.in.orig Sat Oct 26 09:45:35 2002
++++ examples/calculator/Makefile.in Sat Dec 21 14:10:40 2002
+@@ -17,10 +17,10 @@
+ $(CXX) -c -o $@ $<
+
+ sobj/mathfunc.so : $(SLOBJECTS)
+- libtool $(CXX) -shared $^ -lxparam -o $@
++ libtool --mode=link $(CXX) -shared $^ -lxparam -o $@
+
+ $(SLOBJECTS) : obj/%.lo : src/%.cpp include/mathfunc.h include/functions.h
+- libtool $(CXX) -c -o $@ $<
++ libtool --mode=compile $(CXX) -c -o $@ $<
+
+ clean :
+ -rm -f $(TARGETS) $(OBJECTS) $(SOBJECTS) $(SLOBJECTS)