aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/ups-debug/files/patch-configure48
-rw-r--r--devel/ups-debug/files/patch-ups+ao_pt_regs.c17
2 files changed, 65 insertions, 0 deletions
diff --git a/devel/ups-debug/files/patch-configure b/devel/ups-debug/files/patch-configure
new file mode 100644
index 000000000000..ef35aa6f368d
--- /dev/null
+++ b/devel/ups-debug/files/patch-configure
@@ -0,0 +1,48 @@
+--- configure.in.orig Mon Sep 30 20:26:28 2002
++++ configure.in Fri Nov 29 00:51:28 2002
+@@ -981,13 +981,13 @@
+ AC_CACHE_VAL(ups_cv_var_global_files,[
+ ups_cv_var_global_files=no
+ if test $ups_cv_var_global_files = no ; then
+- AC_EGREP_HEADER( __iob.*;, stdio.h, ups_cv_var_global_files=__iob)
++ AC_EGREP_HEADER( __iob\>.*;, stdio.h, ups_cv_var_global_files=__iob)
+ fi
+ if test $ups_cv_var_global_files = no ; then
+- AC_EGREP_HEADER( _iob.*;, stdio.h, ups_cv_var_global_files=_iob)
++ AC_EGREP_HEADER( _iob\>.*;, stdio.h, ups_cv_var_global_files=_iob)
+ fi
+ if test $ups_cv_var_global_files = no ; then
+- AC_EGREP_HEADER( __sF.*;, stdio.h, ups_cv_var_global_files=__sF)
++ AC_EGREP_HEADER( __sF\>.*;, stdio.h, ups_cv_var_global_files=__sF)
+ fi
+ ])
+ case "$ups_cv_var_global_files" in
+--- configure.orig Wed Oct 23 01:37:31 2002
++++ configure Fri Nov 29 00:51:12 2002
+@@ -6624,7 +6624,7 @@
+ #include <stdio.h>
+ EOF
+ if (eval "$ac_cpp conftest.$ac_ext") 2>&5 |
+- egrep "__iob.*;" >/dev/null 2>&1; then
++ egrep "__iob\>.*;" >/dev/null 2>&1; then
+ rm -rf conftest*
+ ups_cv_var_global_files=__iob
+ fi
+@@ -6638,7 +6638,7 @@
+ #include <stdio.h>
+ EOF
+ if (eval "$ac_cpp conftest.$ac_ext") 2>&5 |
+- egrep "_iob.*;" >/dev/null 2>&1; then
++ egrep "_iob\>.*;" >/dev/null 2>&1; then
+ rm -rf conftest*
+ ups_cv_var_global_files=_iob
+ fi
+@@ -6652,7 +6652,7 @@
+ #include <stdio.h>
+ EOF
+ if (eval "$ac_cpp conftest.$ac_ext") 2>&5 |
+- egrep "__sF.*;" >/dev/null 2>&1; then
++ egrep "__sF\>.*;" >/dev/null 2>&1; then
+ rm -rf conftest*
+ ups_cv_var_global_files=__sF
+ fi
diff --git a/devel/ups-debug/files/patch-ups+ao_pt_regs.c b/devel/ups-debug/files/patch-ups+ao_pt_regs.c
new file mode 100644
index 000000000000..8d288533746e
--- /dev/null
+++ b/devel/ups-debug/files/patch-ups+ao_pt_regs.c
@@ -0,0 +1,17 @@
+--- ups/ao_pt_regs.c.orig Wed Oct 23 01:07:46 2002
++++ ups/ao_pt_regs.c Fri Nov 29 01:01:58 2002
+@@ -495,9 +495,13 @@
+ e_ptrace(PTRACE_GETDREGS, ip->ip_pid, (char *)&pr->dbregs, 0);
+
+ /* FreeBSD : .../sys/i386/i386/machdep.c
+- * dr6 is status register, dr7 is control register.
++ * dr[6] is status register, dr[7] is control register.
+ */
++#if (defined __FreeBSD__) && __FreeBSD_version >= 500043
++ return (pr->dbregs.dr[6] & 0x0000000f);
++#else
+ return (pr->dbregs.dr6 & 0x0000000f);
++#endif
+ }
+
+ /*