aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-List-Permutor/Makefile21
-rw-r--r--devel/p5-List-Permutor/distinfo3
-rw-r--r--devel/p5-List-Permutor/pkg-descr2
-rw-r--r--devel/p5-List-Permutor/pkg-plist5
5 files changed, 32 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 82e130174bc4..c81981dfc37d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1138,6 +1138,7 @@
SUBDIR += p5-Linux-Pid
SUBDIR += p5-List-Cycle
SUBDIR += p5-List-Group
+ SUBDIR += p5-List-Permutor
SUBDIR += p5-Locale-Maketext
SUBDIR += p5-Locale-Maketext-Fuzzy
SUBDIR += p5-Locale-Maketext-Gettext
diff --git a/devel/p5-List-Permutor/Makefile b/devel/p5-List-Permutor/Makefile
new file mode 100644
index 000000000000..73b38801569b
--- /dev/null
+++ b/devel/p5-List-Permutor/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: List-Permutor
+# Date created: Wed Aug 9 2006
+# Whom: Anish Mistry <amistry@am-productions.biz>
+#
+# $FreeBSD$
+#
+
+PORTNAME= List-Permutor
+PORTVERSION= 0.022
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= amistry@am-productions.biz
+COMMENT= Alow you to process all possible permutations of a list
+
+PERL_CONFIGURE= yes
+
+MAN3= List::Permutor.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-List-Permutor/distinfo b/devel/p5-List-Permutor/distinfo
new file mode 100644
index 000000000000..14502370be17
--- /dev/null
+++ b/devel/p5-List-Permutor/distinfo
@@ -0,0 +1,3 @@
+MD5 (List-Permutor-0.022.tar.gz) = b5c0f922730b9493c7c1e0583a5c8f78
+SHA256 (List-Permutor-0.022.tar.gz) = d9089629c6a6f09000623c26877273bf053cddc600b1884a2ac67333084bbc4d
+SIZE (List-Permutor-0.022.tar.gz) = 2695
diff --git a/devel/p5-List-Permutor/pkg-descr b/devel/p5-List-Permutor/pkg-descr
new file mode 100644
index 000000000000..9fa47ba59724
--- /dev/null
+++ b/devel/p5-List-Permutor/pkg-descr
@@ -0,0 +1,2 @@
+The List::Permutor module is simple module that currently allows you to
+process all possible permutations of a list
diff --git a/devel/p5-List-Permutor/pkg-plist b/devel/p5-List-Permutor/pkg-plist
new file mode 100644
index 000000000000..9d6ace1315b6
--- /dev/null
+++ b/devel/p5-List-Permutor/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/List/Permutor.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/List/Permutor/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/List/Permutor
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/List
+@dirrmtry %%SITE_PERL%%/List