aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ultragetopt/Makefile26
-rw-r--r--devel/ultragetopt/distinfo2
-rw-r--r--devel/ultragetopt/pkg-descr7
4 files changed, 36 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a9423730ad63..de7b0538c065 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3970,6 +3970,7 @@
SUBDIR += ucommon
SUBDIR += ucpp
SUBDIR += udis86
+ SUBDIR += ultragetopt
SUBDIR += umem
SUBDIR += umlgraph
SUBDIR += universalindentgui
diff --git a/devel/ultragetopt/Makefile b/devel/ultragetopt/Makefile
new file mode 100644
index 000000000000..6196308b7152
--- /dev/null
+++ b/devel/ultragetopt/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: ultragetopt
+# Date created: 20 Mar 2012
+# Whom: Timothy Beyer <beyert@cs.ucr.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ultragetopt
+PORTVERSION= 0.6.0
+CATEGORIES= devel
+MASTER_SITES= http://kevinlocke.name/programs/ ${MASTER_SITE_LOCAL}
+
+MAINTAINER= beyert@cs.ucr.edu
+COMMENT= Versatile and customizable implementation of getopt()
+
+LICENSE= MIT
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+MAKE_ARGS= PREFIX="${PREFIX}"
+USE_LDCONFIG= yes
+PLIST_FILES= include/ultragetopt.h lib/libultragetopt.a \
+ lib/libultragetopt.la lib/libultragetopt.so \
+ lib/libultragetopt.so.0
+
+.include <bsd.port.mk>
diff --git a/devel/ultragetopt/distinfo b/devel/ultragetopt/distinfo
new file mode 100644
index 000000000000..7493101b5873
--- /dev/null
+++ b/devel/ultragetopt/distinfo
@@ -0,0 +1,2 @@
+SHA256 (ultragetopt-0.6.0.tar.gz) = d1fcddc07c04a1b5f0bb803eb9c3220ebc793a5b6674e9047217f09d152ea051
+SIZE (ultragetopt-0.6.0.tar.gz) = 243465
diff --git a/devel/ultragetopt/pkg-descr b/devel/ultragetopt/pkg-descr
new file mode 100644
index 000000000000..caf4fe18d7df
--- /dev/null
+++ b/devel/ultragetopt/pkg-descr
@@ -0,0 +1,7 @@
+UltraGetopt is a versatile and customizable implementation of getopt() with
+support for many common extensions, MS-DOS formatted option strings, and much
+more. It can function as a drop-in replacement for getopt() on systems with or
+without existing vendor-provided implementations and also as a separate
+co-existing function.
+
+WWW: http://kevinlocke.name/programs/ultragetopt.php