aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/apr/Makefile2
-rw-r--r--devel/apr0/Makefile2
-rw-r--r--devel/apr1/Makefile2
-rw-r--r--devel/apr2/Makefile2
-rw-r--r--devel/ctags/Makefile2
-rw-r--r--devel/cvs2svn/Makefile2
-rw-r--r--devel/gaul/Makefile2
-rw-r--r--devel/newt/Makefile2
-rw-r--r--devel/p5-B-Size/Makefile2
-rw-r--r--devel/p5-FreezeThaw/Makefile2
-rw-r--r--devel/p5-IPC-Run-SafeHandles/Makefile2
-rw-r--r--devel/p5-Tie-IxHash/Makefile2
-rw-r--r--devel/py-epsilon/Makefile2
-rw-r--r--devel/ruby-slang/Makefile2
-rw-r--r--devel/scons/Makefile2
-rw-r--r--devel/viewvc/Makefile2
16 files changed, 32 insertions, 0 deletions
diff --git a/devel/apr/Makefile b/devel/apr/Makefile
index 5fdf04581f80..7c2791c078f1 100644
--- a/devel/apr/Makefile
+++ b/devel/apr/Makefile
@@ -17,6 +17,8 @@ COMMENT= Apache Portability Library
LIB_DEPENDS+= expat.6:${PORTSDIR}/textproc/expat2
+MAKE_JOBS_SAFE= yes
+
OPTIONS= THREADS "Enable Threads in apr" on \
IPV6 "Enable IPV6 Support in apr" off \
GDBM "Enable GNU dbm support in apr-util" on \
diff --git a/devel/apr0/Makefile b/devel/apr0/Makefile
index 5fdf04581f80..7c2791c078f1 100644
--- a/devel/apr0/Makefile
+++ b/devel/apr0/Makefile
@@ -17,6 +17,8 @@ COMMENT= Apache Portability Library
LIB_DEPENDS+= expat.6:${PORTSDIR}/textproc/expat2
+MAKE_JOBS_SAFE= yes
+
OPTIONS= THREADS "Enable Threads in apr" on \
IPV6 "Enable IPV6 Support in apr" off \
GDBM "Enable GNU dbm support in apr-util" on \
diff --git a/devel/apr1/Makefile b/devel/apr1/Makefile
index 5fdf04581f80..7c2791c078f1 100644
--- a/devel/apr1/Makefile
+++ b/devel/apr1/Makefile
@@ -17,6 +17,8 @@ COMMENT= Apache Portability Library
LIB_DEPENDS+= expat.6:${PORTSDIR}/textproc/expat2
+MAKE_JOBS_SAFE= yes
+
OPTIONS= THREADS "Enable Threads in apr" on \
IPV6 "Enable IPV6 Support in apr" off \
GDBM "Enable GNU dbm support in apr-util" on \
diff --git a/devel/apr2/Makefile b/devel/apr2/Makefile
index 5fdf04581f80..7c2791c078f1 100644
--- a/devel/apr2/Makefile
+++ b/devel/apr2/Makefile
@@ -17,6 +17,8 @@ COMMENT= Apache Portability Library
LIB_DEPENDS+= expat.6:${PORTSDIR}/textproc/expat2
+MAKE_JOBS_SAFE= yes
+
OPTIONS= THREADS "Enable Threads in apr" on \
IPV6 "Enable IPV6 Support in apr" off \
GDBM "Enable GNU dbm support in apr-util" on \
diff --git a/devel/ctags/Makefile b/devel/ctags/Makefile
index 6019735c6d92..23645fd866d1 100644
--- a/devel/ctags/Makefile
+++ b/devel/ctags/Makefile
@@ -13,6 +13,8 @@ MASTER_SITES= SF
MAINTAINER= pgollucci@FreeBSD.org
COMMENT= A feature-filled tagfile generator for vi and emacs clones
+MAKE_JOBS_SAFE= yes
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-macro-patterns --with-readlib
diff --git a/devel/cvs2svn/Makefile b/devel/cvs2svn/Makefile
index 6ef4f8098867..43c297106591 100644
--- a/devel/cvs2svn/Makefile
+++ b/devel/cvs2svn/Makefile
@@ -33,6 +33,8 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/svn:${PORTSDIR}/devel/py-subversion
.if defined(WITH_GIT)
RUN_DEPENDS+= ${LOCALBASE}/bin/git:${PORTSDIR}/devel/git
+
+MAKE_JOBS_SAFE= yes
.endif
MAN1= cvs2svn.1
diff --git a/devel/gaul/Makefile b/devel/gaul/Makefile
index c6d52cb9aba2..a149175fe69f 100644
--- a/devel/gaul/Makefile
+++ b/devel/gaul/Makefile
@@ -18,6 +18,8 @@ COMMENT= Genetic Algorithm Utility Library
LIB_DEPENDS= slang.2:${PORTSDIR}/devel/libslang2
+MAKE_JOBS_SAFE= yes
+
USE_AUTOTOOLS= automake:19 libtool:15
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/devel/newt/Makefile b/devel/newt/Makefile
index 9172322d60ba..302990251dd0 100644
--- a/devel/newt/Makefile
+++ b/devel/newt/Makefile
@@ -42,6 +42,8 @@ PLIST_SUB+= PYTHONOPT="@comment "
.if defined(WITH_TCL)
TCLSUFFIX= -${TCL_NODOT}
LIB_DEPENDS+= ${TCL_NODOT}:${PORTSDIR}/lang/${TCL_NODOT}
+
+MAKE_JOBS_SAFE= yes
MAKE_ENV+= WITH_TCL=yes
PLIST_SUB+= TCLOPT=""
.else
diff --git a/devel/p5-B-Size/Makefile b/devel/p5-B-Size/Makefile
index d66d7aef4248..f2e8489657ff 100644
--- a/devel/p5-B-Size/Makefile
+++ b/devel/p5-B-Size/Makefile
@@ -14,6 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= pgollucci@FreeBSD.org
COMMENT= Tools to measure size of Perl OPs and [SAV]Vs
+MAKE_JOBS_SAFE= yes
+
PERL_CONFIGURE= yes
MAN3= B::Size.3 B::TerseSize.3
diff --git a/devel/p5-FreezeThaw/Makefile b/devel/p5-FreezeThaw/Makefile
index 0b6cf85a0a06..bc0b0a33f82b 100644
--- a/devel/p5-FreezeThaw/Makefile
+++ b/devel/p5-FreezeThaw/Makefile
@@ -14,6 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= pgollucci@FreeBSD.org
COMMENT= A module for converting Perl structures to strings and back
+MAKE_JOBS_SAFE= yes
+
PERL_CONFIGURE= YES
MAN3= FreezeThaw.3
diff --git a/devel/p5-IPC-Run-SafeHandles/Makefile b/devel/p5-IPC-Run-SafeHandles/Makefile
index 551b7268e470..9240fcb7c270 100644
--- a/devel/p5-IPC-Run-SafeHandles/Makefile
+++ b/devel/p5-IPC-Run-SafeHandles/Makefile
@@ -14,6 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= pgollucci@FreeBSD.org
COMMENT= IPC::Run::SafeHandles - Safe guarding for IPC::Run(3)
+MAKE_JOBS_SAFE= yes
+
PERL_CONFIGURE= yes
MAN3= IPC::Run::SafeHandles.3
diff --git a/devel/p5-Tie-IxHash/Makefile b/devel/p5-Tie-IxHash/Makefile
index 143bec19605c..7c4f70953d98 100644
--- a/devel/p5-Tie-IxHash/Makefile
+++ b/devel/p5-Tie-IxHash/Makefile
@@ -14,6 +14,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= pgollucci@FreeBSD.org
COMMENT= Perl module implementing ordered in-memory associative arrays
+MAKE_JOBS_SAFE= yes
+
PERL_CONFIGURE= yes
MAN3= Tie::IxHash.3
diff --git a/devel/py-epsilon/Makefile b/devel/py-epsilon/Makefile
index fa2aa44509fb..266a1ecd60fe 100644
--- a/devel/py-epsilon/Makefile
+++ b/devel/py-epsilon/Makefile
@@ -18,6 +18,8 @@ COMMENT= Epsilon is a set of Python utility modules used by DivMod projects
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/OpenSSL/__init__.py:${PORTSDIR}/security/py-openssl
+MAKE_JOBS_SAFE= yes
+
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= Epsilon
diff --git a/devel/ruby-slang/Makefile b/devel/ruby-slang/Makefile
index 4d75be3058c4..cd90923d5995 100644
--- a/devel/ruby-slang/Makefile
+++ b/devel/ruby-slang/Makefile
@@ -18,6 +18,8 @@ COMMENT= S-Lang extension module for Ruby
LIB_DEPENDS= slang.2:${PORTSDIR}/japanese/libslang
+MAKE_JOBS_SAFE= yes
+
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/devel/scons/Makefile b/devel/scons/Makefile
index ea267cbb9adc..9ed7f839f5b6 100644
--- a/devel/scons/Makefile
+++ b/devel/scons/Makefile
@@ -14,6 +14,8 @@ MASTER_SITES= SF
MAINTAINER= pgollucci@FreeBSD.org
COMMENT= A build tool alternative to make
+MAKE_JOBS_SAFE= yes
+
.if !defined (NO_INSTALL_MANPAGES)
MAN1= scons.1 sconsign.1 scons-time.1
.endif
diff --git a/devel/viewvc/Makefile b/devel/viewvc/Makefile
index c7b153d31225..31a16ae252d5 100644
--- a/devel/viewvc/Makefile
+++ b/devel/viewvc/Makefile
@@ -13,6 +13,8 @@ MASTER_SITES= http://viewvc.tigris.org/files/documents/3330/44050/
MAINTAINER= pgollucci@FreeBSD.org
COMMENT= Web-based Version Control Repository Browsing
+MAKE_JOBS_SAFE= yes
+
OPTIONS= SUBVERSION "use svn binding" on \
APACHE2 "use Apache as webserver" on \
LIGHTTPD "use Lighttp as webserver" off \