aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/jep/Makefile31
-rw-r--r--devel/jep/distinfo2
-rw-r--r--devel/jep/pkg-descr4
-rw-r--r--devel/jep/pkg-plist5
5 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 231554a563a6..05b83cfca0ca 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -373,6 +373,7 @@
SUBDIR += jam
SUBDIR += java-util-concurrent
SUBDIR += jclassinfo
+ SUBDIR += jep
SUBDIR += jrtplib
SUBDIR += jsap
SUBDIR += jude-community
diff --git a/devel/jep/Makefile b/devel/jep/Makefile
new file mode 100644
index 000000000000..3a0a6ab60f03
--- /dev/null
+++ b/devel/jep/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: jep
+# Date created: 2005-03-04
+# Whom: Choe, Cheng-Dae
+#
+# $FreeBSD$
+#
+
+PORTNAME= jep
+PORTVERSION= 1.1
+CATEGORIES= devel java python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= whitekid@gmail.com
+COMMENT= Java Embedded Python
+
+HAS_CONFIGURE= yes
+CONFIGURE_ENV= JAVA_HOME=${JAVA_HOME}
+CONFIGURE_ARGS= --prefix=${PREFIX} --exec-prefix=${PREFIX}
+USE_JAVA= yes
+JAVA_VERSION= 1.2+
+USE_PYTHON= yes
+USE_LIBTOOL_VER= 15
+INSTALLS_SHLIB= yes
+
+MAN1= jep.1
+
+post-install:
+ ${INSTALL_DATA} ${WRKSRC}/jep.jar ${JAVAJARDIR}
+
+.include <bsd.port.mk>
diff --git a/devel/jep/distinfo b/devel/jep/distinfo
new file mode 100644
index 000000000000..ce3d2e83f088
--- /dev/null
+++ b/devel/jep/distinfo
@@ -0,0 +1,2 @@
+MD5 (jep-1.1.tar.gz) = f8c33c8825be3f4e862e5ddb377a5d37
+SIZE (jep-1.1.tar.gz) = 575774
diff --git a/devel/jep/pkg-descr b/devel/jep/pkg-descr
new file mode 100644
index 000000000000..67649ee7cb84
--- /dev/null
+++ b/devel/jep/pkg-descr
@@ -0,0 +1,4 @@
+Jep embeds CPython in Java. It is safe to use in a heavily threaded
+environment, it is quite fast and its stability is a main feature and goal.
+
+WWW: http://jepp.sourceforge.net
diff --git a/devel/jep/pkg-plist b/devel/jep/pkg-plist
new file mode 100644
index 000000000000..18901151dff8
--- /dev/null
+++ b/devel/jep/pkg-plist
@@ -0,0 +1,5 @@
+@comment $FreeBSD$
+lib/libjep.a
+lib/libjep.so
+lib/libjep.so.1
+%%JAVAJARDIR%%/jep.jar