aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/strace/Makefile27
-rw-r--r--devel/strace/distinfo1
-rw-r--r--devel/strace/pkg-comment1
-rw-r--r--devel/strace/pkg-descr12
-rw-r--r--devel/strace/pkg-plist4
6 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 496a56829371..c51d4adf58f4 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -456,6 +456,7 @@
SUBDIR += st
SUBDIR += stlport
SUBDIR += str
+ SUBDIR += strace
SUBDIR += styx
SUBDIR += swarm
SUBDIR += swigruby
diff --git a/devel/strace/Makefile b/devel/strace/Makefile
new file mode 100644
index 000000000000..08db6dff258c
--- /dev/null
+++ b/devel/strace/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: strace
+# Date created: Tue May 15 22:29:27 MSD 2001
+# Whom: Alex Semenyaka <alexs@snark.rinet.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= strace
+PORTVERSION= 4.3
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= alexs@snark.rinet.ru
+
+GNU_CONFIGURE= yes
+
+MAN1= strace.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/strace ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/strace-graph ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/strace.1 ${PREFIX}/man/man1
+ -${MKDIR} ${PREFIX}/share/strace
+ ${INSTALL_DATA} ${WRKSRC}/xlate.el ${PREFIX}/share/strace
+
+.include <bsd.port.mk>
diff --git a/devel/strace/distinfo b/devel/strace/distinfo
new file mode 100644
index 000000000000..6ec455e735e2
--- /dev/null
+++ b/devel/strace/distinfo
@@ -0,0 +1 @@
+MD5 (strace-4.3.tar.gz) = 7374eb6a2abc45ece28bb192ee127c56
diff --git a/devel/strace/pkg-comment b/devel/strace/pkg-comment
new file mode 100644
index 000000000000..67f5fd8f06b5
--- /dev/null
+++ b/devel/strace/pkg-comment
@@ -0,0 +1 @@
+A portable process tracer
diff --git a/devel/strace/pkg-descr b/devel/strace/pkg-descr
new file mode 100644
index 000000000000..ddd5107b0a05
--- /dev/null
+++ b/devel/strace/pkg-descr
@@ -0,0 +1,12 @@
+Strace is a process tracer, i.e. a debugging tool that prints out
+a trace of all the system calls made and signals received by a
+process itself or a process and its descendants.
+
+Strace is similar to the native BSD ktrace/kdump pair of utilities,
+but strace's output style is more convenient in some cases or for
+some developers.
+
+WWW: http://www.liacs.nl/~wichert/strace/
+
+- Alex Semenyaka
+alexs@snark.rinet.ru
diff --git a/devel/strace/pkg-plist b/devel/strace/pkg-plist
new file mode 100644
index 000000000000..687009593c07
--- /dev/null
+++ b/devel/strace/pkg-plist
@@ -0,0 +1,4 @@
+bin/strace
+bin/strace-graph
+share/strace/xlate.el
+@dirrm share/strace