aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/arm-aout-binutils/Makefile22
-rw-r--r--devel/arm-aout-binutils/distinfo1
-rw-r--r--devel/arm-aout-binutils/files/patch-bfd-aout-arm.c19
-rw-r--r--devel/arm-aout-binutils/pkg-comment1
-rw-r--r--devel/arm-aout-binutils/pkg-descr10
-rw-r--r--devel/arm-aout-binutils/pkg-plist28
7 files changed, 82 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ac657535e069..44166d04fe5b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -11,6 +11,7 @@
SUBDIR += a2dev
SUBDIR += adabroker
SUBDIR += amulet
+ SUBDIR += arm-aout-binutils
SUBDIR += asis
SUBDIR += asl
SUBDIR += astyle
diff --git a/devel/arm-aout-binutils/Makefile b/devel/arm-aout-binutils/Makefile
new file mode 100644
index 000000000000..db21458b5fab
--- /dev/null
+++ b/devel/arm-aout-binutils/Makefile
@@ -0,0 +1,22 @@
+# ex:ts=8
+# New ports collection makefile for: armbinutils-2.9.1
+# Date created: 2 june 2000
+# Whom: Paul Becke <pbecke@javagear.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= arm-aout-binutils
+PORTVERSION= 2.9.1
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= binutils
+DISTNAME= binutils-2.9.1
+
+MAINTAINER= pbecke@javagear.com
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --target=arm-aout
+
+.include <bsd.port.mk>
diff --git a/devel/arm-aout-binutils/distinfo b/devel/arm-aout-binutils/distinfo
new file mode 100644
index 000000000000..d578549bfdfe
--- /dev/null
+++ b/devel/arm-aout-binutils/distinfo
@@ -0,0 +1 @@
+MD5 (binutils-2.9.1.tar.gz) = 8f9ad1a6e96742fd3069479171a63c22
diff --git a/devel/arm-aout-binutils/files/patch-bfd-aout-arm.c b/devel/arm-aout-binutils/files/patch-bfd-aout-arm.c
new file mode 100644
index 000000000000..e7a881622279
--- /dev/null
+++ b/devel/arm-aout-binutils/files/patch-bfd-aout-arm.c
@@ -0,0 +1,19 @@
+--- bfd/aout-arm.c.orig Mon Aug 21 10:22:41 2000
++++ bfd/aout-arm.c Mon Aug 21 10:23:42 2000
+@@ -20,13 +20,13 @@
+
+
+ #define N_TXTADDR(x) \
+- ((N_MAGIC(x) == NMAGIC) ? 0x8000 : \
++ ((N_MAGIC(x) == NMAGIC) ? 0x0000 : \
+ (N_MAGIC(x) != ZMAGIC) ? 0 : \
+ (N_SHARED_LIB(x)) ? ((x).a_entry & ~(TARGET_PAGE_SIZE - 1)) : \
+ TEXT_START_ADDR)
+
+-#define TEXT_START_ADDR 0x8000
+-#define TARGET_PAGE_SIZE 0x8000
++#define TEXT_START_ADDR 0x0000
++#define TARGET_PAGE_SIZE 0x1000
+ #define SEGMENT_SIZE TARGET_PAGE_SIZE
+ #define DEFAULT_ARCH bfd_arch_arm
+
diff --git a/devel/arm-aout-binutils/pkg-comment b/devel/arm-aout-binutils/pkg-comment
new file mode 100644
index 000000000000..ae4c6887554f
--- /dev/null
+++ b/devel/arm-aout-binutils/pkg-comment
@@ -0,0 +1 @@
+FSF Binutils for embedded ARM cross-development
diff --git a/devel/arm-aout-binutils/pkg-descr b/devel/arm-aout-binutils/pkg-descr
new file mode 100644
index 000000000000..480354c67a60
--- /dev/null
+++ b/devel/arm-aout-binutils/pkg-descr
@@ -0,0 +1,10 @@
+FSF binutils for embedded ARM cross-development
+
+This is used to generate code that is independent of any operating system.
+In particular, it is used to compile the kernel, since there is no operating
+system that it can depend on.
+
+devel/arm-aout-gcc295 uses this port as a dependency.
+--------------------------------------------------------------------------
+Paul Becke
+pbecke@javagear.com
diff --git a/devel/arm-aout-binutils/pkg-plist b/devel/arm-aout-binutils/pkg-plist
new file mode 100644
index 000000000000..ebed9aac1152
--- /dev/null
+++ b/devel/arm-aout-binutils/pkg-plist
@@ -0,0 +1,28 @@
+arm-aout/bin/ar
+arm-aout/bin/as
+arm-aout/bin/ld
+arm-aout/bin/nm
+arm-aout/bin/ranlib
+arm-aout/bin/strip
+arm-aout/lib/ldscripts/armaoutl.x
+arm-aout/lib/ldscripts/armaoutl.xbn
+arm-aout/lib/ldscripts/armaoutl.xn
+arm-aout/lib/ldscripts/armaoutl.xr
+arm-aout/lib/ldscripts/armaoutl.xu
+bin/arm-aout-ld
+bin/arm-aout-gasp
+bin/arm-aout-as
+bin/arm-aout-nm
+bin/arm-aout-strip
+bin/arm-aout-addr2line
+bin/arm-aout-objcopy
+bin/arm-aout-c++filt
+bin/arm-aout-ranlib
+bin/arm-aout-ar
+bin/arm-aout-strings
+bin/arm-aout-objdump
+bin/arm-aout-size
+@dirrm arm-aout/bin
+@dirrm arm-aout/lib/ldscripts
+@dirrm arm-aout/lib
+@dirrm arm-aout