aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-fileutils/Makefile41
-rw-r--r--devel/ruby-fileutils/distinfo1
-rw-r--r--devel/ruby-fileutils/pkg-comment1
-rw-r--r--devel/ruby-fileutils/pkg-descr3
-rw-r--r--devel/ruby-fileutils/pkg-plist5
6 files changed, 52 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 512580fe58e9..9460bce033ec 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -479,6 +479,7 @@
SUBDIR += ruby-dialogs
SUBDIR += ruby-dl
SUBDIR += ruby-filelock
+ SUBDIR += ruby-fileutils
SUBDIR += ruby-flex_rb
SUBDIR += ruby-fnmatch
SUBDIR += ruby-gemfinder
diff --git a/devel/ruby-fileutils/Makefile b/devel/ruby-fileutils/Makefile
new file mode 100644
index 000000000000..1e05fa5a0476
--- /dev/null
+++ b/devel/ruby-fileutils/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: Ruby-fileutils
+# Date created: 8 September 2001
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fileutils
+PORTVERSION= 0.0.0
+CATEGORIES= devel ruby
+MASTER_SITES= http://www.loveruby.net/archive/
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+USE_RUBY= yes
+USE_RUBY_SETUP= yes
+RUBY_SETUP= install.rb
+.if !defined(NOPORTDOCS)
+USE_RUBY_RD= yes
+.endif
+
+DOCS_JA= doc-ja.rd doc-ja.html
+
+post-build:
+.if !defined(NOPORTDOCS)
+ @cd ${WRKSRC}; \
+ ${RUBY_RD} doc-ja.rd > doc-ja.html
+.endif
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}/ja
+.for f in ${DOCS_JA}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/ja/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-fileutils/distinfo b/devel/ruby-fileutils/distinfo
new file mode 100644
index 000000000000..6a9ffe376d31
--- /dev/null
+++ b/devel/ruby-fileutils/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/fileutils.tar.gz) = 972f027068f53a31213b96a78e2917af
diff --git a/devel/ruby-fileutils/pkg-comment b/devel/ruby-fileutils/pkg-comment
new file mode 100644
index 000000000000..298af01f2fb8
--- /dev/null
+++ b/devel/ruby-fileutils/pkg-comment
@@ -0,0 +1 @@
+A file & directory manipulation library for Ruby
diff --git a/devel/ruby-fileutils/pkg-descr b/devel/ruby-fileutils/pkg-descr
new file mode 100644
index 000000000000..2a1c0699fe12
--- /dev/null
+++ b/devel/ruby-fileutils/pkg-descr
@@ -0,0 +1,3 @@
+This is a file & directory manipulation library for Ruby.
+
+Author: Minero Aoki <aamine@loveruby.net>
diff --git a/devel/ruby-fileutils/pkg-plist b/devel/ruby-fileutils/pkg-plist
new file mode 100644
index 000000000000..09cf773017de
--- /dev/null
+++ b/devel/ruby-fileutils/pkg-plist
@@ -0,0 +1,5 @@
+%%RUBY_SITELIBDIR%%/fileutils.rb
+%%PORTDOCS%%%%RUBY_DOCDIR%%/fileutils/ja/doc-ja.html
+%%PORTDOCS%%%%RUBY_DOCDIR%%/fileutils/ja/doc-ja.rd
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/fileutils/ja
+%%PORTDOCS%%@dirrm %%RUBY_DOCDIR%%/fileutils