aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/m17n-lib/Makefile53
-rw-r--r--devel/m17n-lib/distinfo2
-rw-r--r--devel/m17n-lib/pkg-descr23
-rw-r--r--devel/m17n-lib/pkg-plist31
5 files changed, 110 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 7500808d55b4..1c718449ea5a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -470,6 +470,7 @@
SUBDIR += log4cpp
SUBDIR += lwp
SUBDIR += m17n-db
+ SUBDIR += m17n-lib
SUBDIR += m4
SUBDIR += m6811-binutils
SUBDIR += m6811-gcc
diff --git a/devel/m17n-lib/Makefile b/devel/m17n-lib/Makefile
new file mode 100644
index 000000000000..dff395310085
--- /dev/null
+++ b/devel/m17n-lib/Makefile
@@ -0,0 +1,53 @@
+# New ports collection makefile for: m17n-lib
+# Date created: 29 May 2004
+# Whom: Kimura Fuyuki <fuyuki@hadaly.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= m17n-lib
+PORTVERSION= 1.0.2
+CATEGORIES= devel
+MASTER_SITES= http://www.m17n.org/m17n-lib/download/
+
+MAINTAINER= fuyuki@hadaly.org
+COMMENT= A library for the multilingual text handling
+
+LIB_DEPENDS= fribidi.0:${PORTSDIR}/converters/fribidi \
+ otf.0:${PORTSDIR}/print/libotf
+BUILD_DEPENDS= ${LOCALBASE}/share/m17n/mdb.dir:${PORTSDIR}/devel/m17n-db
+RUN_DEPENDS= ${LOCALBASE}/share/m17n/mdb.dir:${PORTSDIR}/devel/m17n-db
+
+USE_REINPLACE= yes
+USE_XLIB= yes
+USE_GNOME= libxml2
+USE_LIBTOOL_VER= 15
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${X11BASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+USE_GMAKE= yes
+MAKE_ARGS= libm17n_la_LDFLAGS=
+INSTALLS_SHLIB= yes
+
+OPTIONS= ANTHY "With Anthy support" off \
+ ISPELL "With Ispell support" off
+
+.include <bsd.port.pre.mk>
+
+.ifdef WITH_ANTHY
+LIB_DEPENDS+= anthy.0:${PORTSDIR}/japanese/anthy
+.else
+CONFIGURE_ENV+= ac_cv_lib_anthydic_anthy_init_sessions=no
+.endif
+
+.ifdef WITH_ISPELL
+BUILD_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
+RUN_DEPENDS+= ispell:${PORTSDIR}/textproc/ispell
+.else
+CONFIGURE_ENV+= HAVE_ISPELL=no
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|/usr/include/libxml2|${LOCALBASE}/include/libxml2|' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>
diff --git a/devel/m17n-lib/distinfo b/devel/m17n-lib/distinfo
new file mode 100644
index 000000000000..c50b240c9b01
--- /dev/null
+++ b/devel/m17n-lib/distinfo
@@ -0,0 +1,2 @@
+MD5 (m17n-lib-1.0.2.tar.gz) = 6e2d5088d666fca4ed06357000385932
+SIZE (m17n-lib-1.0.2.tar.gz) = 478985
diff --git a/devel/m17n-lib/pkg-descr b/devel/m17n-lib/pkg-descr
new file mode 100644
index 000000000000..2f8bd991d204
--- /dev/null
+++ b/devel/m17n-lib/pkg-descr
@@ -0,0 +1,23 @@
+The m17n library provides following facilities to handle multilingual
+text.
+
+ * M-text: A data structure for a multilingual text. It is
+ basically a string but with attributes called text property, and
+ is designed to substitute for the C string. It is the most
+ important object of the m17n library.
+
+ * Functions for creating and processing M-texts.
+
+ * Functions for converting M-texts from/to strings encoded in
+ various existing formats.
+
+ * A huge character space, which contains all the Unicode
+ characters and more non-Unicode characters.
+
+ * Chartable: A data structure that contains per-character
+ information efficiently.
+
+ * Functions for inputting and displaying M-text on a window
+ system.
+
+WWW: http://www.m17n.org/m17n-lib/
diff --git a/devel/m17n-lib/pkg-plist b/devel/m17n-lib/pkg-plist
new file mode 100644
index 000000000000..1605d27f6f37
--- /dev/null
+++ b/devel/m17n-lib/pkg-plist
@@ -0,0 +1,31 @@
+bin/m17n-config
+bin/mconv
+bin/mdate
+bin/mdump
+bin/medit
+bin/mview
+include/m17n-X.h
+include/m17n-core.h
+include/m17n-gui.h
+include/m17n-misc.h
+include/m17n.h
+lib/libm17n-X.a
+lib/libm17n-X.la
+lib/libm17n-X.so
+lib/libm17n-X.so.0
+lib/libm17n-core.a
+lib/libm17n-core.la
+lib/libm17n-core.so
+lib/libm17n-core.so.0
+lib/libm17n.a
+lib/libm17n.la
+lib/libm17n.so
+lib/libm17n.so.0
+lib/libmimx-anthy.a
+lib/libmimx-anthy.la
+lib/libmimx-anthy.so
+lib/libmimx-anthy.so.0
+lib/libmimx-ispell.a
+lib/libmimx-ispell.la
+lib/libmimx-ispell.so
+lib/libmimx-ispell.so.0