aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/mingw32-pthreads/Makefile36
-rw-r--r--devel/mingw32-pthreads/distinfo3
-rw-r--r--devel/mingw32-pthreads/pkg-descr5
-rw-r--r--devel/mingw32-pthreads/pkg-plist6
5 files changed, 51 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 40fafa94e21f..e065ccb26c8a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -615,6 +615,7 @@
SUBDIR += mingw32-binutils
SUBDIR += mingw32-gcc
SUBDIR += mingw32-pdcurses
+ SUBDIR += mingw32-pthreads
SUBDIR += mips-rtems-binutils
SUBDIR += mips-rtems-g77
SUBDIR += mips-rtems-gcc
diff --git a/devel/mingw32-pthreads/Makefile b/devel/mingw32-pthreads/Makefile
new file mode 100644
index 000000000000..0f058bd458c2
--- /dev/null
+++ b/devel/mingw32-pthreads/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: mingw32-pthreads
+# Date created: 28 April 2006
+# Whom: Ed Schouten <ed@fxq.nl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pthreads
+PORTVERSION= 2.7.0
+CATEGORIES= devel
+MASTER_SITES= ftp://sources.redhat.com/pub/${PORTNAME}-win32/
+PKGNAMEPREFIX= mingw32-
+DISTNAME= ${PORTNAME}-w32-${PORTVERSION:S/./-/g}-release
+
+MAINTAINER= ed@fxq.nl
+COMMENT= POSIX threads library for Windows compiled with MinGW32
+
+BUILD_DEPENDS= ${PKGNAMEPREFIX}gcc:${PORTSDIR}/devel/${PKGNAMEPREFIX}gcc \
+ mingwm10.dll:${PORTSDIR}/devel/mingw32-bin-msvcrt
+
+USE_GMAKE= yes
+
+do-build:
+ @${GMAKE} -C ${WRKSRC} MAKE=${GMAKE} CROSS=${PKGNAMEPREFIX} GC
+
+do-install:
+.for f in pthread.h sched.h semaphore.h
+ ${INSTALL_DATA} ${WRKSRC}/$f ${PREFIX}/mingw32/include/$f
+.endfor
+
+.for f in libpthreadGC2.a pthreadGC2.dll
+ ${INSTALL_DATA} ${WRKSRC}/$f ${PREFIX}/mingw32/lib/$f
+.endfor
+ ${LN} -sf libpthreadGC2.a ${PREFIX}/mingw32/lib/libpthread.a
+
+.include <bsd.port.mk>
diff --git a/devel/mingw32-pthreads/distinfo b/devel/mingw32-pthreads/distinfo
new file mode 100644
index 000000000000..dac0d9f337d3
--- /dev/null
+++ b/devel/mingw32-pthreads/distinfo
@@ -0,0 +1,3 @@
+MD5 (pthreads-w32-2-7-0-release.tar.gz) = e2a5cd5672bfd987abda6a4195925eb9
+SHA256 (pthreads-w32-2-7-0-release.tar.gz) = 11b736a1e33e67fddc5efba5dd412028914a63f887d0e175e6927eeeb1292b9d
+SIZE (pthreads-w32-2-7-0-release.tar.gz) = 375000
diff --git a/devel/mingw32-pthreads/pkg-descr b/devel/mingw32-pthreads/pkg-descr
new file mode 100644
index 000000000000..f8b2719c6551
--- /dev/null
+++ b/devel/mingw32-pthreads/pkg-descr
@@ -0,0 +1,5 @@
+pthreads-win32 is a pthreads implementation for Microsoft Windows. It
+can be compiled with MSVC, Borland and GCC. This port compiles it using
+MinGW32.
+
+WWW: http://sourceware.org/pthreads-win32/
diff --git a/devel/mingw32-pthreads/pkg-plist b/devel/mingw32-pthreads/pkg-plist
new file mode 100644
index 000000000000..3185c3243e35
--- /dev/null
+++ b/devel/mingw32-pthreads/pkg-plist
@@ -0,0 +1,6 @@
+mingw32/include/pthread.h
+mingw32/include/sched.h
+mingw32/include/semaphore.h
+mingw32/lib/libpthread.a
+mingw32/lib/libpthreadGC2.a
+mingw32/lib/pthreadGC2.dll