aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/bullet/Makefile1
-rw-r--r--devel/clanlib/Makefile4
-rw-r--r--devel/glui/Makefile2
-rw-r--r--devel/libpciaccess/Makefile23
-rw-r--r--devel/libpciaccess/distinfo3
-rw-r--r--devel/libpciaccess/pkg-descr6
-rw-r--r--devel/libpciaccess/pkg-plist6
-rw-r--r--devel/m17n-lib/Makefile1
-rw-r--r--devel/ois/Makefile2
-rw-r--r--devel/pdcurses-the/Makefile4
-rw-r--r--devel/pdcurses/Makefile4
-rw-r--r--devel/plan9port/Makefile3
-rw-r--r--devel/simgear/Makefile1
-rw-r--r--devel/t1lib/Makefile1
-rw-r--r--devel/xorg-macros/Makefile5
-rw-r--r--devel/xorg-macros/distinfo6
17 files changed, 58 insertions, 15 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 051adf71b8b8..cf1c3d7b8328 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -692,6 +692,7 @@
SUBDIR += libowfat
SUBDIR += libpasori
SUBDIR += libpci
+ SUBDIR += libpciaccess
SUBDIR += libpdel
SUBDIR += libpeak
SUBDIR += libphish
diff --git a/devel/bullet/Makefile b/devel/bullet/Makefile
index cea090960ddf..df72b3e7ea50 100644
--- a/devel/bullet/Makefile
+++ b/devel/bullet/Makefile
@@ -7,6 +7,7 @@
PORTNAME= bullet
PORTVERSION= 2.73
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
DISTNAME= ${PORTNAME}-${PORTVERSION:S/$/-sp1/}
diff --git a/devel/clanlib/Makefile b/devel/clanlib/Makefile
index d512e82d40ab..a37373b1a71c 100644
--- a/devel/clanlib/Makefile
+++ b/devel/clanlib/Makefile
@@ -8,7 +8,7 @@
PORTNAME= clanlib
PORTVERSION= 0.8.1
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= http://www.clanlib.org/download/releases-0.8/ \
@@ -33,7 +33,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --disable-clanJavaScript --disable-docs
USE_GMAKE= yes
-USE_XORG= x11
+USE_XORG= x11 xmu xi
USE_GNOME= gnomehack gnometarget pkgconfig
USE_LDCONFIG= yes
USE_SDL= gfx
diff --git a/devel/glui/Makefile b/devel/glui/Makefile
index ee508df9d92f..3c13a139646c 100644
--- a/devel/glui/Makefile
+++ b/devel/glui/Makefile
@@ -7,7 +7,7 @@
PORTNAME= glui
PORTVERSION= 2.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= devel graphics
MASTER_SITES= http://www.cs.unc.edu/~rademach/glui/src/release/
DISTNAME= glui_v2_1_beta
diff --git a/devel/libpciaccess/Makefile b/devel/libpciaccess/Makefile
new file mode 100644
index 000000000000..f637194f14e6
--- /dev/null
+++ b/devel/libpciaccess/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: libpciaccess
+# Date Created: May 11 2008
+# Whom: Florent Thoumie <flz@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libpciaccess
+PORTVERSION= 0.10.5
+CATEGORIES= devel
+
+MAINTAINER= x11@FreeBSD.org
+COMMENT= Generic PCI access library
+
+BUILD_DEPENDS= ${LOCALBASE}/share/pciids/pci.ids:${PORTSDIR}/misc/pciids
+# XXX - Is it a runtime dep too?
+RUN_DEPENDS= ${LOCALBASE}/share/pciids/pci.ids:${PORTSDIR}/misc/pciids
+
+CONFIGURE_ARGS+= --with-pciids-path=${LOCALBASE}/share/pciids
+
+XORG_CAT= lib
+
+.include <bsd.port.mk>
diff --git a/devel/libpciaccess/distinfo b/devel/libpciaccess/distinfo
new file mode 100644
index 000000000000..e7bf98247e1b
--- /dev/null
+++ b/devel/libpciaccess/distinfo
@@ -0,0 +1,3 @@
+MD5 (xorg/lib/libpciaccess-0.10.5.tar.bz2) = 617bebf31e5685c83f935009aeae5f38
+SHA256 (xorg/lib/libpciaccess-0.10.5.tar.bz2) = b6c5765a3994e59053cb3b46741b858bb56ea868baa5c48fba7e5c36ca4ae95d
+SIZE (xorg/lib/libpciaccess-0.10.5.tar.bz2) = 260817
diff --git a/devel/libpciaccess/pkg-descr b/devel/libpciaccess/pkg-descr
new file mode 100644
index 000000000000..77dbb5584df9
--- /dev/null
+++ b/devel/libpciaccess/pkg-descr
@@ -0,0 +1,6 @@
+This package contains the pciaccess library.
+
+WWW: http://www.freedesktop.org/Software/xlibs
+
+- Florent Thoumie
+flz@FreeBSD.org
diff --git a/devel/libpciaccess/pkg-plist b/devel/libpciaccess/pkg-plist
new file mode 100644
index 000000000000..4fe963b655ee
--- /dev/null
+++ b/devel/libpciaccess/pkg-plist
@@ -0,0 +1,6 @@
+include/pciaccess.h
+lib/libpciaccess.a
+lib/libpciaccess.la
+lib/libpciaccess.so
+lib/libpciaccess.so.0
+libdata/pkgconfig/pciaccess.pc
diff --git a/devel/m17n-lib/Makefile b/devel/m17n-lib/Makefile
index 6f3f8e0b8ad5..49b83fc60fc2 100644
--- a/devel/m17n-lib/Makefile
+++ b/devel/m17n-lib/Makefile
@@ -7,6 +7,7 @@
PORTNAME= m17n-lib
PORTVERSION= 1.5.2
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://www.m17n.org/m17n-lib-download/ \
http://anthesphoria.net/FreeBSD/ports/distfiles/
diff --git a/devel/ois/Makefile b/devel/ois/Makefile
index 83dfd037815f..88acd860e979 100644
--- a/devel/ois/Makefile
+++ b/devel/ois/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ois
PORTVERSION= 1.2.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= SF
MASTER_SITE_SUBDIR= wgois
diff --git a/devel/pdcurses-the/Makefile b/devel/pdcurses-the/Makefile
index f6d7fa784042..1c7788000e12 100644
--- a/devel/pdcurses-the/Makefile
+++ b/devel/pdcurses-the/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pdcurses
PORTVERSION= 3.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= SF
DISTNAME= PDCurses-${PORTVERSION}
@@ -16,7 +16,7 @@ MAINTAINER= alepulver@FreeBSD.org
COMMENT= Curses library implementation for Win32, DOS, OS/2 and X11
USE_LDCONFIG= yes
-USE_XORG= x11 xext sm ice xt xaw8
+USE_XORG= x11 xext sm ice xt xaw
GNU_CONFIGURE= yes
OPTIONS= DEBUG "Enable debugging support" off \
diff --git a/devel/pdcurses/Makefile b/devel/pdcurses/Makefile
index f6d7fa784042..1c7788000e12 100644
--- a/devel/pdcurses/Makefile
+++ b/devel/pdcurses/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pdcurses
PORTVERSION= 3.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= SF
DISTNAME= PDCurses-${PORTVERSION}
@@ -16,7 +16,7 @@ MAINTAINER= alepulver@FreeBSD.org
COMMENT= Curses library implementation for Win32, DOS, OS/2 and X11
USE_LDCONFIG= yes
-USE_XORG= x11 xext sm ice xt xaw8
+USE_XORG= x11 xext sm ice xt xaw
GNU_CONFIGURE= yes
OPTIONS= DEBUG "Enable debugging support" off \
diff --git a/devel/plan9port/Makefile b/devel/plan9port/Makefile
index c706d721f180..ca87a48c3b31 100644
--- a/devel/plan9port/Makefile
+++ b/devel/plan9port/Makefile
@@ -7,6 +7,7 @@
PORTNAME= plan9port
PORTVERSION= 20080909
+PORTREVISION= 1
CATEGORIES= devel plan9
MASTER_SITES= http://swtch.com/plan9port/ \
ftp://quenix2.dyndns.org/FreeBSD/ports/distfiles/
@@ -15,7 +16,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= serge.gagnon.1@ulaval.ca
COMMENT= Port of the bulk of the Plan9 software build environment to Unix
-USE_XORG= x11 xt xi xaw6 xaw7 xaw8
+USE_XORG= x11 xt xi xaw
USE_PERL5_BUILD=YES
WRKSRC= ${WRKDIR}/plan9
PLIST= ${WRKDIR}/.PLIST
diff --git a/devel/simgear/Makefile b/devel/simgear/Makefile
index 68f881658530..2ffe29f37d50 100644
--- a/devel/simgear/Makefile
+++ b/devel/simgear/Makefile
@@ -7,6 +7,7 @@
PORTNAME= SimGear
PORTVERSION= 1.9.0
+PORTREVISION= 1
CATEGORIES= devel games
MASTER_SITES= ftp://ftp.de.simgear.org/pub/simgear/Source/ \
ftp://ftp.simgear.org/pub/simgear/Source/
diff --git a/devel/t1lib/Makefile b/devel/t1lib/Makefile
index 06aea59f3736..b067b766a01b 100644
--- a/devel/t1lib/Makefile
+++ b/devel/t1lib/Makefile
@@ -8,6 +8,7 @@
PORTNAME= t1lib
PORTVERSION= 5.1.2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_SUNSITE}
diff --git a/devel/xorg-macros/Makefile b/devel/xorg-macros/Makefile
index bebaf71d52ba..89c4e3eccf9c 100644
--- a/devel/xorg-macros/Makefile
+++ b/devel/xorg-macros/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= xorg-macros
-PORTVERSION= 1.1.5
+PORTVERSION= 1.2.1
CATEGORIES= devel x11
DISTNAME= util-macros-$(PORTVERSION)
@@ -15,7 +15,6 @@ COMMENT= X.Org development aclocal macros
XORG_CAT= util
-PLIST_FILES= share/aclocal/xorgversion.m4 \
- share/aclocal/xorg-macros.m4
+PLIST_FILES= share/aclocal/xorg-macros.m4
.include <bsd.port.mk>
diff --git a/devel/xorg-macros/distinfo b/devel/xorg-macros/distinfo
index 9ceb0078fd5c..0d06bd097628 100644
--- a/devel/xorg-macros/distinfo
+++ b/devel/xorg-macros/distinfo
@@ -1,3 +1,3 @@
-MD5 (xorg/util/util-macros-1.1.5.tar.bz2) = 51952682d8b42aeda3af5cee0133ce2c
-SHA256 (xorg/util/util-macros-1.1.5.tar.bz2) = 75939790e16b8bcc122e83f3f060d6f000ed1a98e97b4972fac0903142f5651b
-SIZE (xorg/util/util-macros-1.1.5.tar.bz2) = 47165
+MD5 (xorg/util/util-macros-1.2.1.tar.bz2) = dc7ddaf9bea8b341510efe4dac125af4
+SHA256 (xorg/util/util-macros-1.2.1.tar.bz2) = 2863ce6c25a40a3c5d6f31721d496a8a8d5e99bb646e73b990d727623a208878
+SIZE (xorg/util/util-macros-1.2.1.tar.bz2) = 48602