aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/flowdesigner/Makefile10
-rw-r--r--devel/g2c/Makefile10
-rw-r--r--devel/guiloader-c++/Makefile9
-rw-r--r--devel/guiloader/Makefile9
-rw-r--r--devel/libopensync022/Makefile9
-rw-r--r--devel/libsigcx/Makefile10
-rw-r--r--devel/pharmacy/Makefile9
-rw-r--r--devel/preps-gui/Makefile9
-rw-r--r--devel/regexxer/Makefile9
9 files changed, 27 insertions, 57 deletions
diff --git a/devel/flowdesigner/Makefile b/devel/flowdesigner/Makefile
index 816ea7bb7f20..984bddea2abf 100644
--- a/devel/flowdesigner/Makefile
+++ b/devel/flowdesigner/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: flowdesigner
-# Date created: Apr 14, 2004
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= flowdesigner
PORTVERSION= 0.9.1
@@ -19,7 +14,8 @@ COMMENT= A free (GPL) "data flow oriented" development environment
LIB_DEPENDS= speex.1:${PORTSDIR}/audio/speex \
fftw.2:${PORTSDIR}/math/fftw
-USE_GNOME= gnomehack libgnomeui libxml2
+USES= pathfix
+USE_GNOME= libgnomeui libxml2
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
LIBTOOLFILES= ${CONFIGURE_SCRIPT} FuzzyEngine/configure \
diff --git a/devel/g2c/Makefile b/devel/g2c/Makefile
index b29cbee7dbdc..6adede963e7b 100644
--- a/devel/g2c/Makefile
+++ b/devel/g2c/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: g2c
-# Date created: Mar 21, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= g2c
PORTVERSION= 0.4
@@ -16,7 +11,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Glade to C translator
PLIST_FILES= bin/g2c
-USE_GNOME= gtk12 gnomehack libxml orbit
+USES= pathfix
+USE_GNOME= gtk12 libxml orbit
WANT_GNOME= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
diff --git a/devel/guiloader-c++/Makefile b/devel/guiloader-c++/Makefile
index d6de0a49064c..d1845f2894b7 100644
--- a/devel/guiloader-c++/Makefile
+++ b/devel/guiloader-c++/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: guiloader-c++
-# Date created: 11 May 2007
-# Whom: Yinghong Liu <relaxbsd@gmail.com>
-#
+# Created by: Yinghong Liu <relaxbsd@gmail.com>
# $FreeBSD$
-#
PORTNAME= guiloader-c++
PORTVERSION= 2.19.0
@@ -20,7 +16,8 @@ LIB_DEPENDS= guiloader.1:${PORTSDIR}/devel/guiloader \
PROJECTHOST= nothing-personal
USE_BZIP2= yes
-USE_GNOME= gnomehack gtk20
+USES= pathfix
+USE_GNOME= gtk20
USE_GETTEXT= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-hidden-visibility
diff --git a/devel/guiloader/Makefile b/devel/guiloader/Makefile
index f0b604fe8bed..e488765ad623 100644
--- a/devel/guiloader/Makefile
+++ b/devel/guiloader/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: guiloader
-# Date created: 11 May 2007
-# Whom: Yinghong Liu <relaxbsd@gmail.com>
-#
+# Created by: Yinghong Liu <relaxbsd@gmail.com>
# $FreeBSD$
-#
PORTNAME= guiloader
PORTVERSION= 2.19.0
@@ -16,7 +12,8 @@ COMMENT= A high-performance and compact GuiXml loader library
PROJECTHOST= nothing-personal
USE_BZIP2= yes
-USE_GNOME= gnomehack gtk20
+USES= pathfix
+USE_GNOME= gtk20
USE_GETTEXT= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
diff --git a/devel/libopensync022/Makefile b/devel/libopensync022/Makefile
index 7efc8660c7ee..c1501a691499 100644
--- a/devel/libopensync022/Makefile
+++ b/devel/libopensync022/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: libopensync
-# Date created: 2005-06-19
-# Whom: Michael Johnson <ahze@FreeBSD.org>
-#
+# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= libopensync
PORTVERSION= 0.22
@@ -22,7 +18,8 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_PYTHON= yes
-USE_GNOME= gnomehack glib20 libxml2
+USES= pathfix
+USE_GNOME= glib20 libxml2
USE_LDCONFIG= yes
CONFLICTS= libopensync-0.[3-9]*
diff --git a/devel/libsigcx/Makefile b/devel/libsigcx/Makefile
index cbf42416df60..0082d2b59994 100644
--- a/devel/libsigcx/Makefile
+++ b/devel/libsigcx/Makefile
@@ -1,10 +1,5 @@
-# ex:ts=8
-# Ports collection makefile for: libsigcx
-# Date created: Apr 6, 2003
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= libsigcx
PORTVERSION= 0.6.6
@@ -18,7 +13,8 @@ COMMENT= An extension of libSigC++
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
LIB_DEPENDS= sigc-1.2.5:${PORTSDIR}/devel/libsigc++12
-USE_GNOME= gnomehack gtk20
+USES= pathfix
+USE_GNOME= gtk20
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ENV= ac_cv_path_DOXYGEN=""
diff --git a/devel/pharmacy/Makefile b/devel/pharmacy/Makefile
index 47d2eb0aa0fa..fa3e12676a2c 100644
--- a/devel/pharmacy/Makefile
+++ b/devel/pharmacy/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pharmacy
-# Date created: 02 October 1999
-# Whom: Chris D. Faulhaber <jedgar@fxp.org>
-#
+# Created by: Chris D. Faulhaber <jedgar@fxp.org>
# $FreeBSD$
-#
PORTNAME= pharmacy
PORTVERSION= 0.3
@@ -15,7 +11,8 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= GNOME frontend for CVS
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack gnomelibs
+USES= pathfix
+USE_GNOME= gnomeprefix gnomelibs
USE_GETTEXT= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CPPCFLAGS="-I${LOCALBASE}/include" \
diff --git a/devel/preps-gui/Makefile b/devel/preps-gui/Makefile
index a59d1d12ed80..5a17fd1b2dfe 100644
--- a/devel/preps-gui/Makefile
+++ b/devel/preps-gui/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: preps-gui
-# Date created: Fri Mar 19 14:27:30 EET 2004
-# Whom: shadow@psoft.net
-#
+# Created by: shadow@psoft.net
# $FreeBSD$
-#
PORTNAME= preps
PORTVERSION= 2.0.4
@@ -20,7 +16,8 @@ COMMENT= Problem reporting system
RUN_DEPENDS= prepsdb_tool:${PORTSDIR}/devel/prepstools
USE_GMAKE= yes
-USE_GNOME= gnomehack gnomeprefix gtk20 gconf2 libgnomeui
+USES= pathfix
+USE_GNOME= gnomeprefix gtk20 gconf2 libgnomeui
USE_PGSQL= yes
INSTALLS_OMF= yes
GCONF_SCHEMAS= preps.schema
diff --git a/devel/regexxer/Makefile b/devel/regexxer/Makefile
index 7f64c07313d5..89d4627b3bc3 100644
--- a/devel/regexxer/Makefile
+++ b/devel/regexxer/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: regexxer
-# Date created: 15 February 2003
-# Whom: Rui Lopes <rui@ruilopes.com>
-#
+# Created by: Rui Lopes <rui@ruilopes.com>
# $FreeBSD$
-#
PORTNAME= regexxer
PORTVERSION= 0.9
@@ -21,7 +17,8 @@ LIB_DEPENDS= gconfmm-2.6:${PORTSDIR}/devel/gconfmm26 \
USE_GETTEXT= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack gnomeprefix intltool intlhack
+USES= pathfix
+USE_GNOME= gnomeprefix intltool intlhack
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib