aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/libpthread-stubs/Makefile10
-rw-r--r--devel/libpthread-stubs/distinfo6
-rw-r--r--devel/libpthread-stubs/files/patch-Makefile.in26
3 files changed, 21 insertions, 21 deletions
diff --git a/devel/libpthread-stubs/Makefile b/devel/libpthread-stubs/Makefile
index 0cebe8a3daf2..9775387b1fd0 100644
--- a/devel/libpthread-stubs/Makefile
+++ b/devel/libpthread-stubs/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= libpthread-stubs
-PORTVERSION= 0.1
+PORTVERSION= 0.3
CATEGORIES= devel
MASTER_SITES= http://xcb.freedesktop.org/dist/
@@ -20,4 +20,10 @@ USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 700000
+CONFIGURE_ENV+= LDFLAGS=-lpthread
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/libpthread-stubs/distinfo b/devel/libpthread-stubs/distinfo
index 499ac2def0a0..96327446371f 100644
--- a/devel/libpthread-stubs/distinfo
+++ b/devel/libpthread-stubs/distinfo
@@ -1,3 +1,3 @@
-MD5 (libpthread-stubs-0.1.tar.bz2) = 774eabaf33440d534efe108ef9130a7d
-SHA256 (libpthread-stubs-0.1.tar.bz2) = 004dae11e11598584939d66d26a5ab9b48d08a00ca2d00ae8d38ee3ac7a15d65
-SIZE (libpthread-stubs-0.1.tar.bz2) = 194060
+MD5 (libpthread-stubs-0.3.tar.bz2) = e8fa31b42e13f87e8f5a7a2b731db7ee
+SHA256 (libpthread-stubs-0.3.tar.bz2) = 35b6d54e3cc6f3ba28061da81af64b9a92b7b757319098172488a660e3d87299
+SIZE (libpthread-stubs-0.3.tar.bz2) = 203468
diff --git a/devel/libpthread-stubs/files/patch-Makefile.in b/devel/libpthread-stubs/files/patch-Makefile.in
index 746576b1fdea..0aed1ffa5f32 100644
--- a/devel/libpthread-stubs/files/patch-Makefile.in
+++ b/devel/libpthread-stubs/files/patch-Makefile.in
@@ -1,6 +1,9 @@
---- Makefile.in.orig Fri Feb 9 01:16:19 2007
-+++ Makefile.in Fri Feb 9 01:17:05 2007
-@@ -62,9 +62,9 @@
+
+$FreeBSD$
+
+--- Makefile.in.orig
++++ Makefile.in
+@@ -75,9 +75,9 @@
LTLIBRARIES = $(lib_LTLIBRARIES)
libpthread_stubs_la_LIBADD =
am__libpthread_stubs_la_SOURCES_DIST = stubs.c
@@ -9,21 +12,12 @@
libpthread_stubs_la_OBJECTS = $(am_libpthread_stubs_la_OBJECTS)
-@BUILD_LIB_TRUE@am_libpthread_stubs_la_rpath = -rpath $(libdir)
+am_libpthread_stubs_la_rpath = -rpath $(libdir)
- DEFAULT_INCLUDES = -I. -I$(srcdir) -I.
+ DEFAULT_INCLUDES = -I.@am__isrc@
depcomp = $(SHELL) $(top_srcdir)/depcomp
am__depfiles_maybe = depfiles
-@@ -102,8 +102,6 @@
- AUTOHEADER = @AUTOHEADER@
- AUTOMAKE = @AUTOMAKE@
- AWK = @AWK@
--BUILD_LIB_FALSE = @BUILD_LIB_FALSE@
--BUILD_LIB_TRUE = @BUILD_LIB_TRUE@
- CC = @CC@
- CCDEPMODE = @CCDEPMODE@
- CFLAGS = @CFLAGS@
-@@ -199,8 +197,8 @@
- target_alias = @target_alias@
- pkgconfigdir = $(libdir)/pkgconfig
+@@ -221,8 +221,8 @@
+ top_srcdir = @top_srcdir@
+ pkgconfigdir = $(prefix)/libdata/pkgconfig
pkgconfig_DATA = pthread-stubs.pc
-@BUILD_LIB_TRUE@lib_LTLIBRARIES = libpthread-stubs.la
-@BUILD_LIB_TRUE@libpthread_stubs_la_SOURCES = stubs.c