aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/ChipmunkPhysics/Makefile3
-rw-r--r--devel/adacurses/Makefile3
-rw-r--r--devel/afay/Makefile3
-rw-r--r--devel/alabastra/Makefile3
-rw-r--r--devel/arduino/Makefile3
-rw-r--r--devel/bullet/Makefile3
-rw-r--r--devel/cdk/Makefile3
-rw-r--r--devel/clanlib/Makefile3
-rw-r--r--devel/clanlib1/Makefile3
-rw-r--r--devel/clanlib22/Makefile3
-rw-r--r--devel/coccinelle/Makefile3
-rw-r--r--devel/cons-test/Makefile3
-rw-r--r--devel/cons/Makefile3
-rw-r--r--devel/edb/Makefile3
-rw-r--r--devel/elfsh/Makefile3
-rw-r--r--devel/generate/Makefile3
-rw-r--r--devel/glui/Makefile3
-rw-r--r--devel/kaptain/Makefile3
-rw-r--r--devel/libarena/Makefile3
-rw-r--r--devel/libmcs/Makefile3
-rw-r--r--devel/libphk/Makefile3
-rw-r--r--devel/lion/Makefile3
-rw-r--r--devel/lxr/Makefile3
-rw-r--r--devel/mkcmd/Makefile3
-rw-r--r--devel/p5-Cdk/Makefile3
-rw-r--r--devel/p5-Config-Perl-V/Makefile3
-rw-r--r--devel/p5-Curses/Makefile3
-rw-r--r--devel/p5-Data-Diver/Makefile3
-rw-r--r--devel/p5-Data-Peek/Makefile3
-rw-r--r--devel/p5-DateTime-Format-Duration/Makefile3
-rw-r--r--devel/p5-IO-Pager/Makefile3
-rw-r--r--devel/p5-Memoize/Makefile3
-rw-r--r--devel/p5-SVN-ACL/Makefile3
-rw-r--r--devel/p5-Set-Array/Makefile3
-rw-r--r--devel/p5-Tree-Binary/Makefile3
-rw-r--r--devel/p5-Tree-DAG_Node/Makefile3
-rw-r--r--devel/p5-Tree-Simple/Makefile3
-rw-r--r--devel/p5-VCS-CVS/Makefile3
-rw-r--r--devel/pecl-spl_types/Makefile3
-rw-r--r--devel/py-generate/Makefile3
-rw-r--r--devel/qprog/Makefile3
-rw-r--r--devel/re2/Makefile3
-rw-r--r--devel/tbb/Makefile3
-rw-r--r--devel/tpasm/Makefile3
44 files changed, 44 insertions, 88 deletions
diff --git a/devel/ChipmunkPhysics/Makefile b/devel/ChipmunkPhysics/Makefile
index 5d88c3772c42..bd0d3017e147 100644
--- a/devel/ChipmunkPhysics/Makefile
+++ b/devel/ChipmunkPhysics/Makefile
@@ -9,14 +9,13 @@ MASTER_SITES= http://chipmunk-physics.net/release/Chipmunk-6.x/ \
http://files.slembcke.net/chipmunk/release/Chipmunk-6.x/ \
http://files.libsiege.org/chipmunk/
DISTNAME= Chipmunk-${PORTVERSION}
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@stdrand.com
COMMENT= 2D physics engine written in C
LICENSE= MIT
-USES= cmake
+USES= cmake tar:tgz
USE_LDCONFIG= yes
PLIST_SUB= VERSION=${PORTVERSION}
diff --git a/devel/adacurses/Makefile b/devel/adacurses/Makefile
index 00a59c14f9bf..6f8dbcf8189a 100644
--- a/devel/adacurses/Makefile
+++ b/devel/adacurses/Makefile
@@ -7,14 +7,13 @@ PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ftp://invisible-island.net/AdaCurses/
DISTNAME= AdaCurses-${PORTVERSION}
-EXTRACT_SUFX= .tgz
MAINTAINER= marino@FreeBSD.org
COMMENT= Ada95 bindings for ncurses
LICENSE= MIT
-USES= ada gmake ncurses:port
+USES= ada gmake ncurses:port tar:tgz
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-ada-include=${PREFIX}/include/adacurses \
--with-ada-objects=${PREFIX}/lib/adacurses \
diff --git a/devel/afay/Makefile b/devel/afay/Makefile
index de525d0920dd..ad0bb9a28c71 100644
--- a/devel/afay/Makefile
+++ b/devel/afay/Makefile
@@ -7,14 +7,13 @@ PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://thiberlog.free.fr/src/
DISTNAME= ${PORTNAME}_thiberlog_${PORTVERSION}
-EXTRACT_SUFX= .tgz
MAINTAINER= marino@FreeBSD.org
COMMENT= Improved aflex and ayacc Ada 95 scanner and parser generators
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
-USES= ada
+USES= ada tar:tgz
NO_WRKSUBDIR= yes
OPTIONS_DEFINE= DOCS EXAMPLES
diff --git a/devel/alabastra/Makefile b/devel/alabastra/Makefile
index 545a5687ae4e..6047ade65c8e 100644
--- a/devel/alabastra/Makefile
+++ b/devel/alabastra/Makefile
@@ -7,7 +7,6 @@ PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= SF
DISTNAME= Alabastra-${PORTVERSION}
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= C++ editor written with Qt 4
@@ -16,7 +15,7 @@ LICENSE= GPLv2 # (or later)
WRKSRC= ${WRKDIR}/${DISTNAME}
-USES= qmake gmake
+USES= qmake gmake tar:tgz
USE_QT4= gui xml \
moc_build rcc_build uic_build \
iconengines_run
diff --git a/devel/arduino/Makefile b/devel/arduino/Makefile
index baa124c2c6e2..eed40a212be4 100644
--- a/devel/arduino/Makefile
+++ b/devel/arduino/Makefile
@@ -8,7 +8,6 @@ PORTEPOCH= 1
CATEGORIES= devel java lang
MASTER_SITES= GOOGLE_CODE
DISTNAME= ${PORTNAME}-${PORTVERSION}-linux32
-EXTRACT_SUFX= .tgz
MAINTAINER= leres@ee.lbl.gov
COMMENT= Open-source electronics prototyping platform
@@ -18,7 +17,7 @@ RUN_DEPENDS= ${JAVA_HOME}/jre/lib/ext/RXTXcomm.jar:${PORTSDIR}/comms/rxtx \
${LOCALBASE}/avr/include/avr/io.h:${PORTSDIR}/devel/avr-libc
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USES= dos2unix
+USES= dos2unix tar:tgz
DOS2UNIX_REGEX= .*\(\.\(c|cpp|h|hex|html|ino|lst|txt\)|Makefile\)
USE_JAVA= 1.6+
diff --git a/devel/bullet/Makefile b/devel/bullet/Makefile
index 6ac28174a302..c5a21d7d690e 100644
--- a/devel/bullet/Makefile
+++ b/devel/bullet/Makefile
@@ -7,7 +7,6 @@ CATEGORIES= devel
PORTREVISION= 1
MASTER_SITES= GOOGLE_CODE
DISTNAME= ${PORTNAME}-${PORTVERSION}-${SVN_COMMIT}
-EXTRACT_SUFX= .tgz
MAINTAINER= acm@FreeBSD.org
COMMENT= 3D collision detection and rigid body dynamics library
@@ -17,7 +16,7 @@ LICENSE= ZLIB
USE_GL= gl glu glut
USE_XORG= x11
-USES= cmake
+USES= cmake tar:tgz
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -pthread
diff --git a/devel/cdk/Makefile b/devel/cdk/Makefile
index 2ca2eb30a973..c4974ca6e819 100644
--- a/devel/cdk/Makefile
+++ b/devel/cdk/Makefile
@@ -8,14 +8,13 @@ PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= ftp://invisible-island.net/cdk/
DISTNAME= ${PORTNAME}-${PORTVERSION:R}-${PORTVERSION:E}
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Curses Development Kit for speedy development of full screen programs
LICENSE= BSD
-USES= ncurses gmake
+USES= ncurses gmake tar:tgz
GNU_CONFIGURE= yes
PORTDOCS= COPYING EXPANDING INSTALL NOTES README TODO
MAKE_JOBS_UNSAFE= yes
diff --git a/devel/clanlib/Makefile b/devel/clanlib/Makefile
index cbd628e64608..f23d9cbab66f 100644
--- a/devel/clanlib/Makefile
+++ b/devel/clanlib/Makefile
@@ -8,7 +8,6 @@ PORTEPOCH= 1
CATEGORIES= devel
MASTER_SITES= http://www.clanlib.org/download/releases-2.0/
DISTNAME= ClanLib-${PORTVERSION}
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Cross-platform game SDK
@@ -25,7 +24,7 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
USE_GCC= yes
USE_XORG= x11
-USES= gmake pathfix pkgconfig
+USES= gmake pathfix pkgconfig tar:tgz
USE_LDCONFIG= yes
USE_GL= yes
USE_SQLITE= yes
diff --git a/devel/clanlib1/Makefile b/devel/clanlib1/Makefile
index ab229a773029..aa368caefdd9 100644
--- a/devel/clanlib1/Makefile
+++ b/devel/clanlib1/Makefile
@@ -8,7 +8,6 @@ CATEGORIES= devel
MASTER_SITES= http://www.clanlib.org/download/releases-1.0/
DISTNAME= ClanLib-${PORTVERSION}
PKGNAMESUFFIX= 1
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Cross-platform game SDK
@@ -20,7 +19,7 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
libmikmod.so:${PORTSDIR}/audio/libmikmod \
libvorbis.so:${PORTSDIR}/audio/libvorbis
-USES= gmake libtool pathfix pkgconfig
+USES= gmake libtool pathfix pkgconfig tar:tgz
USE_XORG= x11 xi
USE_LDCONFIG= yes
USE_SDL= gfx
diff --git a/devel/clanlib22/Makefile b/devel/clanlib22/Makefile
index 366ffeefe75c..7f53317e77e9 100644
--- a/devel/clanlib22/Makefile
+++ b/devel/clanlib22/Makefile
@@ -8,7 +8,6 @@ CATEGORIES= devel
MASTER_SITES= http://www.clanlib.org/download/releases-2.0/
DISTNAME= ClanLib-${PORTVERSION}
PKGNAMESUFFIX= 22
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Cross-platform game SDK
@@ -23,7 +22,7 @@ LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
libpcre.so:${PORTSDIR}/devel/pcre
USE_XORG= x11
-USES= gmake pathfix pkgconfig
+USES= gmake pathfix pkgconfig tar:tgz
USE_LDCONFIG= yes
USE_GL= yes
USE_SQLITE= yes
diff --git a/devel/coccinelle/Makefile b/devel/coccinelle/Makefile
index dcd55b8a505c..07bd3c25c302 100644
--- a/devel/coccinelle/Makefile
+++ b/devel/coccinelle/Makefile
@@ -5,7 +5,6 @@ PORTNAME= coccinelle
DISTVERSION= 1.0.0-rc19
CATEGORIES= devel
MASTER_SITES= http://coccinelle.lip6.fr/distrib/
-EXTRACT_SUFX= .tgz
MAINTAINER= avg@icyb.net.ua
COMMENT= Program matching and transformation engine
@@ -14,7 +13,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libpcre.so:${PORTSDIR}/devel/pcre
-USES= gmake perl5 pkgconfig:build
+USES= gmake perl5 pkgconfig:build tar:tgz
GNU_CONFIGURE= yes
USE_PERL5= build
USE_PYTHON= yes
diff --git a/devel/cons-test/Makefile b/devel/cons-test/Makefile
index 482cd04b75c4..449d1cc07809 100644
--- a/devel/cons-test/Makefile
+++ b/devel/cons-test/Makefile
@@ -9,7 +9,6 @@ MASTER_SITES= http://www.dsmit.com/cons/stable/ \
http://www.gnu.org/software/cons/stable/ \
ftp://ftp.gnu.org/pub/old-gnu/cons/ \
http://www.baldmt.com/cons/stable/
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Test bed for `Cons' development
@@ -22,7 +21,7 @@ RUN_DEPENDS= ${LOCALBASE}/bin/cons:${PORTSDIR}/devel/cons
WRKSRC= ${WRKDIR}/cons-${PORTVERSION}/test
NO_BUILD= yes
-USES= perl5
+USES= perl5 tar:tgz
PLIST_SUB= CONS_VER="${PORTVERSION}" CONS_TEST="${CONS_TEST}"
DOCSDIR= ${PREFIX}/share/doc/${PORTNAME:S/-test//}-${PORTVERSION}/test
diff --git a/devel/cons/Makefile b/devel/cons/Makefile
index 46d59333217c..9155a4b99b41 100644
--- a/devel/cons/Makefile
+++ b/devel/cons/Makefile
@@ -9,12 +9,11 @@ MASTER_SITES= http://www.dsmit.com/cons/stable/ \
http://www.gnu.org/software/cons/stable/ \
ftp://ftp.gnu.org/pub/gnu/cons/ \
http://www.baldmt.com/cons/stable/
-EXTRACT_SUFX= .tgz
MAINTAINER= rv@gnu.org
COMMENT= Perl-based Make Replacement
-USES= perl5
+USES= perl5 tar:tgz
NO_BUILD= yes
PLIST_SUB= CONS_VER=${PORTVERSION}
diff --git a/devel/edb/Makefile b/devel/edb/Makefile
index ee8114c88b10..9613694af5a0 100644
--- a/devel/edb/Makefile
+++ b/devel/edb/Makefile
@@ -6,7 +6,6 @@ PORTREVISION= 3
CATEGORIES= devel
MASTER_SITES= http://codef00.com/projects/
DISTNAME= debugger-${PORTVERSION}
-EXTRACT_SUFX= .tgz
MAINTAINER= itechbear@gmail.com
COMMENT= Cross-platform x86/x86-64 debugger based on Qt 4
@@ -15,7 +14,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs
-USES= qmake
+USES= qmake tar:tgz
USE_QT4= gui network xml moc_build rcc_build uic_build
QMAKE_ARGS= DEFAULT_PLUGIN_PATH="${PREFIX}/libexec/${PORTNAME}"
diff --git a/devel/elfsh/Makefile b/devel/elfsh/Makefile
index d36d5fc27520..2fffc5b4318b 100644
--- a/devel/elfsh/Makefile
+++ b/devel/elfsh/Makefile
@@ -7,12 +7,11 @@ PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://elfsh.asgardlabs.org/files/
DISTNAME= elfsh-0.51b3-portable
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Attractive toolkit for the analysis of ELF object files
-USES= gmake readline
+USES= gmake readline tar:tgz
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
diff --git a/devel/generate/Makefile b/devel/generate/Makefile
index 2cfab7b0c06b..f841ccc8f487 100644
--- a/devel/generate/Makefile
+++ b/devel/generate/Makefile
@@ -5,12 +5,11 @@ PORTNAME= generate
PORTVERSION= 2.8
CATEGORIES= devel
MASTER_SITES= http://www.druid.net/darcy/
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple text pre-processor
-USES= gmake
+USES= gmake tar:tgz
MAKE_ARGS= BINDIR=${STAGEDIR}${PREFIX}/bin \
MANDIR=${STAGEDIR}${PREFIX}/man
diff --git a/devel/glui/Makefile b/devel/glui/Makefile
index 6f8557fad63d..8cfc55a72eab 100644
--- a/devel/glui/Makefile
+++ b/devel/glui/Makefile
@@ -6,12 +6,11 @@ PORTVERSION= 2.36
PORTREVISION= 2
CATEGORIES= devel graphics
MASTER_SITES= SF/${PORTNAME}/Source/${PORTVERSION}
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= GLUT-based C++ user interface library
-USES= gmake
+USES= gmake tar:tgz
USE_GL= glut
USE_XORG= xmu xext x11 xi
USE_LDCONFIG= yes
diff --git a/devel/kaptain/Makefile b/devel/kaptain/Makefile
index 800ec829807c..a20ccefb99c9 100644
--- a/devel/kaptain/Makefile
+++ b/devel/kaptain/Makefile
@@ -5,7 +5,6 @@ PORTNAME= kaptain
PORTVERSION= 0.73
CATEGORIES= devel
MASTER_SITES= SF
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Tool for building/running Qt GUIs for command line programs
@@ -14,7 +13,7 @@ LICENSE= GPLv2 # (or later)
OPTIONS_DEFINE= DOCS EXAMPLES
-USES= qmake
+USES= qmake tar:tgz
USE_QT4= qt3support moc_build
INFO= kaptain
diff --git a/devel/libarena/Makefile b/devel/libarena/Makefile
index 05a80972b741..e69b792bd788 100644
--- a/devel/libarena/Makefile
+++ b/devel/libarena/Makefile
@@ -5,14 +5,13 @@ PORTNAME= libarena
PORTVERSION= 0.3.6
CATEGORIES= devel
MASTER_SITES= http://www.25thandclement.com/~william/projects/releases/
-EXTRACT_SUFX= .tgz
MAINTAINER= rodrigo@FreeBSD.org
COMMENT= Custom Memory Allocator Interface
LICENSE= MIT
-USES= gmake
+USES= gmake tar:tgz
PLIST_FILES= include/arena/align.h \
include/arena/arena.h \
diff --git a/devel/libmcs/Makefile b/devel/libmcs/Makefile
index f0d8a97d45a0..db64a8614488 100644
--- a/devel/libmcs/Makefile
+++ b/devel/libmcs/Makefile
@@ -6,7 +6,6 @@ PORTVERSION= 0.7.2
PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= http://distfiles.atheme.org/
-EXTRACT_SUFX= .tgz
MAINTAINER= oliver@FreeBSD.org
COMMENT= BSD licenced configuration database system
@@ -18,7 +17,7 @@ OPTIONS_DEFAULT= GCONF
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USES= gmake pkgconfig
+USES= gmake pkgconfig tar:tgz
.include <bsd.port.options.mk>
diff --git a/devel/libphk/Makefile b/devel/libphk/Makefile
index fa3cd816024d..5a017f09184c 100644
--- a/devel/libphk/Makefile
+++ b/devel/libphk/Makefile
@@ -9,12 +9,11 @@ MASTER_SITES= http://phk.freebsd.dk/phkrel/ \
${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR=mat
DISTNAME= Libphk.${PORTVERSION:C/0.3.//}
-EXTRACT_SUFX= .tgz
MAINTAINER= perl@FreeBSD.org
COMMENT= PHK's utilities functions
-USES= uidfix
+USES= uidfix tar:tgz
WRKSRC= ${WRKDIR}/Libphk
diff --git a/devel/lion/Makefile b/devel/lion/Makefile
index 10d7c4bccffe..4d53a481a348 100644
--- a/devel/lion/Makefile
+++ b/devel/lion/Makefile
@@ -5,14 +5,13 @@ PORTNAME= lion
DISTVERSION= 20060630
CATEGORIES= devel net
MASTER_SITES= http://www.lundman.net/ftp/
-EXTRACT_SUFX= .tgz
MAINTAINER= molterSPAM@gufiSPAM.org
COMMENT= Multi-platform, event-driven, simple networking library
# TODO
# add support for SSL/TLS/OpenSSL
-USES= gmake
+USES= gmake tar:tgz
WRKSRC= ${WRKDIR}/${PORTNAME}
ALL_TARGET= default
diff --git a/devel/lxr/Makefile b/devel/lxr/Makefile
index 74c665ecee3f..a15acfe4cd8e 100644
--- a/devel/lxr/Makefile
+++ b/devel/lxr/Makefile
@@ -5,7 +5,6 @@ PORTNAME= lxr
PORTVERSION= 0.10.2
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/stable/${PORTNAME}-${PORTVERSION}
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Source code indexer and cross-referencer
@@ -16,7 +15,7 @@ BUILD_DEPENDS= exctags:${PORTSDIR}/devel/ctags \
PATCH_STRIP= -p1
-USES= perl5
+USES= perl5 tar:tgz
NO_BUILD= yes
OPTIONS_DEFINE= DOCS
diff --git a/devel/mkcmd/Makefile b/devel/mkcmd/Makefile
index 2b0df021ac36..a028e540696a 100644
--- a/devel/mkcmd/Makefile
+++ b/devel/mkcmd/Makefile
@@ -8,7 +8,6 @@ MASTER_SITES= ftp://ftp.physics.purdue.edu/pub/pundits/ \
http://www.komquats.com/distfiles/ \
http://people.freebsd.org/~cy/distfiles/
-EXTRACT_SUFX= .tgz
MAINTAINER= cy@FreeBSD.org
COMMENT= Command-line parser and manual page generator
@@ -17,7 +16,7 @@ BUILD_DEPENDS= makeme:${PORTSDIR}/devel/msrc0
MAKE_FLAGS=
MAKEFILE=
-USES= desthack
+USES= desthack tar:tgz
post-patch:
.for f in bin/mkcmd/machine.h bin/mkcmd/mkcmd.man lib/mkcmd/mkcmd.man
diff --git a/devel/p5-Cdk/Makefile b/devel/p5-Cdk/Makefile
index dd2f5e014d49..dd9b3f6fa9cb 100644
--- a/devel/p5-Cdk/Makefile
+++ b/devel/p5-Cdk/Makefile
@@ -7,7 +7,6 @@ CATEGORIES= devel perl5
MASTER_SITES= ftp://dickey.his.com/cdk/
PKGNAMEPREFIX= p5-
DISTNAME= cdk-perl-${PORTVERSION:C,^[0-9]\.,,}
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl5 module for Curses Development Kit
@@ -16,7 +15,7 @@ LICENSE= BSD4CLAUSE
LIB_DEPENDS= libcdk.so:${PORTSDIR}/devel/cdk
-USES= perl5
+USES= perl5 tar:tgz
GNU_CONFIGURE= yes
INSTALL_TARGET= pure_install
diff --git a/devel/p5-Config-Perl-V/Makefile b/devel/p5-Config-Perl-V/Makefile
index 7ea2ff9da855..70b4034e58a8 100644
--- a/devel/p5-Config-Perl-V/Makefile
+++ b/devel/p5-Config-Perl-V/Makefile
@@ -7,7 +7,6 @@ CATEGORIES= devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:HMBRAND
PKGNAMEPREFIX= p5-
-EXTRACT_SUFX= .tgz
MAINTAINER= swills@FreeBSD.org
COMMENT= Structured data retrieval of perl -V output
@@ -15,7 +14,7 @@ COMMENT= Structured data retrieval of perl -V output
BUILD_DEPENDS= p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= perl5
+USES= perl5 tar:tgz
USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/devel/p5-Curses/Makefile b/devel/p5-Curses/Makefile
index 8c87581763dc..bad45eb3c35a 100644
--- a/devel/p5-Curses/Makefile
+++ b/devel/p5-Curses/Makefile
@@ -6,7 +6,6 @@ PORTVERSION= 1.31
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-EXTRACT_SUFX= .tgz
MAINTAINER= perl@FreeBSD.org
COMMENT= Perl5 module for terminal screen handling and optimization
@@ -14,7 +13,7 @@ COMMENT= Perl5 module for terminal screen handling and optimization
OPTIONS_DEFINE= NCURSESW
NCURSESW_DESC= Wide-character-capable support by ncursesw library
-USES= perl5
+USES= perl5 tar:tgz
USE_PERL5= configure
CONFIGURE_ARGS= PANELS MENUS FORMS
CONFIGURE_ENV= CURSES_CFLAGS="-I${WRKSRC}/usr/include/ncurses"
diff --git a/devel/p5-Data-Diver/Makefile b/devel/p5-Data-Diver/Makefile
index c3675e2aae3f..8135a7096a08 100644
--- a/devel/p5-Data-Diver/Makefile
+++ b/devel/p5-Data-Diver/Makefile
@@ -6,12 +6,11 @@ PORTVERSION= 1.0101
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-EXTRACT_SUFX= .tgz
MAINTAINER= perl@FreeBSD.org
COMMENT= Simple, ad-hoc access to elements of deeply nested structures
-USES= perl5
+USES= perl5 tar:tgz
USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/devel/p5-Data-Peek/Makefile b/devel/p5-Data-Peek/Makefile
index 807951e5a542..f774e81001bd 100644
--- a/devel/p5-Data-Peek/Makefile
+++ b/devel/p5-Data-Peek/Makefile
@@ -6,7 +6,6 @@ PORTVERSION= 0.40
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-EXTRACT_SUFX= .tgz
MAINTAINER= perl@FreeBSD.org
COMMENT= Collection of low-level debug facilities
@@ -16,7 +15,7 @@ LICENSE_COMB= dual
TEST_DEPENDS= p5-Test-NoWarnings>=0:${PORTSDIR}/devel/p5-Test-NoWarnings
-USES= perl5
+USES= perl5 tar:tgz
USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/devel/p5-DateTime-Format-Duration/Makefile b/devel/p5-DateTime-Format-Duration/Makefile
index 81e4ee77d747..a5533f964dbb 100644
--- a/devel/p5-DateTime-Format-Duration/Makefile
+++ b/devel/p5-DateTime-Format-Duration/Makefile
@@ -6,7 +6,6 @@ PORTVERSION= 1.03a
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-EXTRACT_SUFX= .tgz
MAINTAINER= perl@FreeBSD.org
COMMENT= Format and parse DateTime::Durations
@@ -16,7 +15,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
WRKSRC= ${WRKDIR}/${DISTNAME:C/a$//}
-USES= perl5
+USES= perl5 tar:tgz
USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/devel/p5-IO-Pager/Makefile b/devel/p5-IO-Pager/Makefile
index cbe82f2dcacb..04844b727329 100644
--- a/devel/p5-IO-Pager/Makefile
+++ b/devel/p5-IO-Pager/Makefile
@@ -6,12 +6,11 @@ PORTVERSION= 0.31
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-EXTRACT_SUFX= .tgz
MAINTAINER= rafan@FreeBSD.org
COMMENT= Select a pager, optionally pipe it output if destination is a TTY
-USES= perl5
+USES= perl5 tar:tgz
USE_PERL5= configure
regression-test:
diff --git a/devel/p5-Memoize/Makefile b/devel/p5-Memoize/Makefile
index b6673c941593..e7ee2d29738d 100644
--- a/devel/p5-Memoize/Makefile
+++ b/devel/p5-Memoize/Makefile
@@ -6,12 +6,11 @@ CATEGORIES= devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:MJD
PKGNAMEPREFIX= p5-
-EXTRACT_SUFX= .tgz
MAINTAINER= tobez@FreeBSD.org
COMMENT= Transparently speed up perl functions by caching return values
-USES= perl5
+USES= perl5 tar:tgz
USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/devel/p5-SVN-ACL/Makefile b/devel/p5-SVN-ACL/Makefile
index 7f71a65c09a6..bbe0bf1a8414 100644
--- a/devel/p5-SVN-ACL/Makefile
+++ b/devel/p5-SVN-ACL/Makefile
@@ -7,7 +7,6 @@ PORTREVISION= 5
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-EXTRACT_SUFX= .tgz
MAINTAINER= perl@FreeBSD.org
COMMENT= Simple ACL frontend for subversion
@@ -16,7 +15,7 @@ BUILD_DEPENDS= p5-subversion>=0:${PORTSDIR}/devel/p5-subversion \
p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= perl5
+USES= perl5 tar:tgz
USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/devel/p5-Set-Array/Makefile b/devel/p5-Set-Array/Makefile
index f623f6d12415..5c5494054eab 100644
--- a/devel/p5-Set-Array/Makefile
+++ b/devel/p5-Set-Array/Makefile
@@ -7,7 +7,6 @@ CATEGORIES= devel perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:RSAVAGE
PKGNAMEPREFIX= p5-
-EXTRACT_SUFX= .tgz
MAINTAINER= perl@FreeBSD.org
COMMENT= Arrays as objects with set operations
@@ -20,7 +19,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
TEST_DEPENDS= p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep \
p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod
-USES= perl5
+USES= perl5 tar:tgz
USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/devel/p5-Tree-Binary/Makefile b/devel/p5-Tree-Binary/Makefile
index 399b493611f1..ea6294e84737 100644
--- a/devel/p5-Tree-Binary/Makefile
+++ b/devel/p5-Tree-Binary/Makefile
@@ -6,7 +6,6 @@ PORTVERSION= 1.05
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-EXTRACT_SUFX= .tgz
MAINTAINER= wen@FreeBSD.org
COMMENT= Object Oriented Binary Tree for Perl
@@ -16,7 +15,7 @@ LICENSE_COMB= dual
TEST_DEPENDS= p5-Test-Exception>=0:${PORTSDIR}/devel/p5-Test-Exception
-USES= perl5
+USES= perl5 tar:tgz
USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/devel/p5-Tree-DAG_Node/Makefile b/devel/p5-Tree-DAG_Node/Makefile
index a7d4fdc496fc..42e5feb3ce13 100644
--- a/devel/p5-Tree-DAG_Node/Makefile
+++ b/devel/p5-Tree-DAG_Node/Makefile
@@ -6,7 +6,6 @@ PORTVERSION= 1.22
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-EXTRACT_SUFX= .tgz
MAINTAINER= perl@FreeBSD.org
COMMENT= Super class for representing nodes in a tree
@@ -17,7 +16,7 @@ BUILD_DEPENDS= p5-File-Slurp-Tiny>=0.003:${PORTSDIR}/devel/p5-File-Slurp-Tiny \
p5-File-Temp>=0.23.01:${PORTSDIR}/devel/p5-File-Temp
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= perl5
+USES= perl5 tar:tgz
USE_PERL5= configure
.include <bsd.port.pre.mk>
diff --git a/devel/p5-Tree-Simple/Makefile b/devel/p5-Tree-Simple/Makefile
index 258dc8108b7a..9b0180e03b83 100644
--- a/devel/p5-Tree-Simple/Makefile
+++ b/devel/p5-Tree-Simple/Makefile
@@ -6,7 +6,6 @@ PORTVERSION= 1.23
CATEGORIES= devel perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
-EXTRACT_SUFX= .tgz
MAINTAINER= demon@FreeBSD.org
COMMENT= Simple tree object
@@ -16,7 +15,7 @@ LICENSE_COMB= dual
TEST_DEPENDS= p5-Test-Exception>=0.15:${PORTSDIR}/devel/p5-Test-Exception
-USES= perl5
+USES= perl5 tar:tgz
USE_PERL5= configure
.include <bsd.port.mk>
diff --git a/devel/p5-VCS-CVS/Makefile b/devel/p5-VCS-CVS/Makefile
index 32feac6cee71..1eaeb09e674f 100644
--- a/devel/p5-VCS-CVS/Makefile
+++ b/devel/p5-VCS-CVS/Makefile
@@ -7,14 +7,13 @@ CATEGORIES= devel perl5
MASTER_SITES= http://savage.net.au/Perl-modules/ \
http://tolid.eu.org/VCSCVS/
PKGNAMEPREFIX= p5-
-EXTRACT_SUFX= .tgz
MAINTAINER= tolid@plab.ku.dk
COMMENT= Perl module that provides a simple interface to CVS
BUILD_DEPENDS= p5-Test-Pod>=0:${PORTSDIR}/devel/p5-Test-Pod
-USES= perl5
+USES= perl5 tar:tgz
USE_PERL5= modbuild
.include <bsd.port.mk>
diff --git a/devel/pecl-spl_types/Makefile b/devel/pecl-spl_types/Makefile
index 25afe67b26de..a3bde29893f3 100644
--- a/devel/pecl-spl_types/Makefile
+++ b/devel/pecl-spl_types/Makefile
@@ -7,7 +7,6 @@ CATEGORIES= devel pear
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
DISTNAME= SPL_Types-${PORTVERSION}
-EXTRACT_SUFX= .tgz
DIST_SUBDIR= PECL
MAINTAINER= 5u623l20@gmail.com
@@ -22,7 +21,7 @@ RE2C_RUN_DEPENDS= re2c:${PORTSDIR}/devel/re2c
USE_PHP= spl
#USE_PHP_BUILD= yes
USE_PHPEXT= yes
-USES= tar:tgz
+USES= tar:tgz tar:tgz
CONFIGURE_ARGS= --enable-spl-types
CFLAGS+= -I${LOCALBASE}/include
diff --git a/devel/py-generate/Makefile b/devel/py-generate/Makefile
index a3548c5d632b..6793782845b4 100644
--- a/devel/py-generate/Makefile
+++ b/devel/py-generate/Makefile
@@ -8,12 +8,11 @@ CATEGORIES= devel python
MASTER_SITES= ftp://ftp.druid.net/pub/distrib/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= generate-${PORTVERSION}
-EXTRACT_SUFX= .tgz
MAINTAINER= darcy@druid.net
COMMENT= Python module to implement generate
-USES= gmake
+USES= gmake tar:tgz
USE_PYTHON= yes
USE_PYDISTUTILS= yes
diff --git a/devel/qprog/Makefile b/devel/qprog/Makefile
index 54ef53ab3142..7b21e8aea8f4 100644
--- a/devel/qprog/Makefile
+++ b/devel/qprog/Makefile
@@ -7,12 +7,11 @@ PORTREVISION= 4
CATEGORIES= devel
MASTER_SITES= http://bfoz.net/projects/${PORTNAME}/release/
DISTNAME= QProg_${PORTVERSION}
-EXTRACT_SUFX= .tgz
MAINTAINER= bfoz@bfoz.net
COMMENT= Cross-platform software for the DIY line of PIC programmers
-USES= qmake
+USES= qmake tar:tgz
USE_QT4= moc_build gui network
WRKSRC= ${WRKDIR}/QProg
diff --git a/devel/re2/Makefile b/devel/re2/Makefile
index 263542d48b24..4e5275a7594a 100644
--- a/devel/re2/Makefile
+++ b/devel/re2/Makefile
@@ -5,7 +5,6 @@ PORTNAME= re2
PORTVERSION= 20140304
CATEGORIES= devel
MASTER_SITES= GOOGLE_CODE
-EXTRACT_SUFX= .tgz
MAINTAINER= jlaffaye@FreeBSD.org
COMMENT= Fast C++ regex library
@@ -14,7 +13,7 @@ LICENSE= BSD3CLAUSE
MAKE_ARGS= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" prefix=${PREFIX}
USE_LDCONFIG= yes
-USES= compiler:c++11-lang gmake
+USES= compiler:c++11-lang gmake tar:tgz
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/devel/tbb/Makefile b/devel/tbb/Makefile
index e609ca70431c..91f341cec1bf 100644
--- a/devel/tbb/Makefile
+++ b/devel/tbb/Makefile
@@ -7,7 +7,6 @@ CATEGORIES= devel
MASTER_SITES= http://threadingbuildingblocks.org/sites/default/files/software_releases/source/ \
LOCAL/martymac
DISTNAME= ${PORTNAME}${PORTVERSION:R:S/.//g}_20131118oss_src
-EXTRACT_SUFX= .tgz
MAINTAINER= martymac@FreeBSD.org
COMMENT= Library that provides thread building blocks
@@ -18,7 +17,7 @@ ONLY_FOR_ARCHS= amd64 i386 ia64
ONLY_FOR_ARCHS_REASON= has not been ported to this platform
USE_LDCONFIG= yes
-USES= compiler gmake
+USES= compiler gmake tar:tgz
ALL_TARGET= default
WRKSRC= ${WRKDIR}/${DISTNAME:S/_src//}
diff --git a/devel/tpasm/Makefile b/devel/tpasm/Makefile
index f84c1b46a52b..b27a1cc2c9bf 100644
--- a/devel/tpasm/Makefile
+++ b/devel/tpasm/Makefile
@@ -6,14 +6,13 @@ PORTVERSION= 1.8
CATEGORIES= devel
MASTER_SITES= ftp://ftp.ct0.com/pub/
DISTNAME= ${PORTNAME}${PORTVERSION}
-EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Cross-assembler for variety of microprocessors and controllers
LICENSE= GPLv2
-USES= gmake
+USES= gmake tar:tgz
PORTDOCS= CONVERSION_C166.TXT MANUAL.TXT README*.TXT
PORTEXAMPLES= *