aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/libassa/Makefile8
-rw-r--r--devel/libformat/Makefile8
2 files changed, 14 insertions, 2 deletions
diff --git a/devel/libassa/Makefile b/devel/libassa/Makefile
index f709136d50a9..5d025a37e5d6 100644
--- a/devel/libassa/Makefile
+++ b/devel/libassa/Makefile
@@ -19,4 +19,10 @@ USE_GNOME= gnomehack
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile with gcc 3.4.2"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/libformat/Makefile b/devel/libformat/Makefile
index 7619fca4c69f..c6d62db989ea 100644
--- a/devel/libformat/Makefile
+++ b/devel/libformat/Makefile
@@ -18,6 +18,12 @@ COMMENT= C++ library that supports printf style like format printing
MAKEFILE= ${FILESDIR}/Makefile.lib
INSTALLS_SHLIB= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502126
+BROKEN= "Does not compile with gcc 3.4.2"
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
@@ -26,4 +32,4 @@ post-install:
.endfor
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>