aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/apr/Makefile13
-rw-r--r--devel/apr0/Makefile13
-rw-r--r--devel/apr1/Makefile13
-rw-r--r--devel/apr2/Makefile13
-rw-r--r--devel/automake17/Makefile5
-rw-r--r--devel/avr-gcc-3/Makefile2
-rw-r--r--devel/avr-gcc/Makefile2
-rw-r--r--devel/cvsnt/Makefile3
-rw-r--r--devel/cvsutils/Makefile1
-rw-r--r--devel/fam/Makefile1
-rw-r--r--devel/gcvs/Makefile6
-rw-r--r--devel/gnulibiberty/Makefile2
-rw-r--r--devel/i386-rtems-g77/Makefile7
-rw-r--r--devel/i386-rtems-gcc/Makefile7
-rw-r--r--devel/i386-rtems-objc/Makefile7
-rw-r--r--devel/kdevelop/Makefile9
-rw-r--r--devel/kdevelop/files/patch-Makefile.in36
-rw-r--r--devel/korelib/Makefile3
-rw-r--r--devel/libbfd/Makefile2
-rw-r--r--devel/libdsp/Makefile4
-rw-r--r--devel/m6811-gcc/Makefile2
-rw-r--r--devel/mingw-gcc/Makefile4
-rw-r--r--devel/shapelib/Makefile4
-rw-r--r--devel/swig13/Makefile3
-rw-r--r--devel/swig20/Makefile3
-rw-r--r--devel/sysconftool/Makefile1
-rw-r--r--devel/umbrello/Makefile5
27 files changed, 95 insertions, 76 deletions
diff --git a/devel/apr/Makefile b/devel/apr/Makefile
index 568b308a26a2..acf2479c9074 100644
--- a/devel/apr/Makefile
+++ b/devel/apr/Makefile
@@ -28,13 +28,12 @@ COMMENT= The Apache Group's Portability Library
LIB_DEPENDS+= expat.5:${PORTSDIR}/textproc/expat2
-USE_ICONV= yes
+USE_ICONV= yes
+USE_AUTOMAKE_VER= 17
USE_AUTOCONF_VER= 257
+WANT_LIBTOOL_VER= 15
USE_PERL5= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER= 15
-LIBTOOLFILES= # none
-USE_AUTOMAKE_VER= 17
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}
@@ -78,7 +77,7 @@ PKGNAMESUFFIX= -db4
.endif
.endif
-LIBTOOL_M4=${LOCALBASE}/share/aclocal/libtool${USE_LIBTOOL_VER}.m4
+LIBTOOL_M4=${LOCALBASE}/share/aclocal/libtool${LIBTOOL_VERSION}.m4
pre-extract:
@${ECHO_MSG} ""
@@ -124,11 +123,11 @@ pre-configure:
${DO_NADA}
run-autotools:
- cd ${WRKDIR}/apr-${PORTVERSION}; ${SETENV} ${SCRIPTS_ENV} AUTOCONF=${AUTOCONF} AUTOHEADER=${AUTOHEADER} LIBTOOL_M4=${LIBTOOL_M4} ${SH} ./buildconf
+ cd ${WRKDIR}/apr-${PORTVERSION}; ${SETENV} ${SCRIPTS_ENV} LIBTOOL_M4=${LIBTOOL_M4} ${SH} ./buildconf
cd ${WRKDIR}/apr-util-${PORTVERSION} ; \
${RM} -fr xml/expat
cd ${WRKDIR}/apr-util-${PORTVERSION} ; \
- ${SETENV} ${SCRIPTS_EV} AUTOCONF=${AUTOCONF} AUTOHEADER=${AUTOHEADER} LIBTOOL_M4=${LIBTOOL_M4} ${SH} ./buildconf \
+ ${SETENV} ${SCRIPTS_ENV} LIBTOOL_M4=${LIBTOOL_M4} ${SH} ./buildconf \
--with-apr=../apr-${PORTVERSION}
cd ${WRKDIR}/apr-${PORTVERSION}; \
${SETENV} ${SCRIPTS_ENV} ${SH} ./configure ${CONFIGURE_ARGS}
diff --git a/devel/apr0/Makefile b/devel/apr0/Makefile
index 568b308a26a2..acf2479c9074 100644
--- a/devel/apr0/Makefile
+++ b/devel/apr0/Makefile
@@ -28,13 +28,12 @@ COMMENT= The Apache Group's Portability Library
LIB_DEPENDS+= expat.5:${PORTSDIR}/textproc/expat2
-USE_ICONV= yes
+USE_ICONV= yes
+USE_AUTOMAKE_VER= 17
USE_AUTOCONF_VER= 257
+WANT_LIBTOOL_VER= 15
USE_PERL5= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER= 15
-LIBTOOLFILES= # none
-USE_AUTOMAKE_VER= 17
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}
@@ -78,7 +77,7 @@ PKGNAMESUFFIX= -db4
.endif
.endif
-LIBTOOL_M4=${LOCALBASE}/share/aclocal/libtool${USE_LIBTOOL_VER}.m4
+LIBTOOL_M4=${LOCALBASE}/share/aclocal/libtool${LIBTOOL_VERSION}.m4
pre-extract:
@${ECHO_MSG} ""
@@ -124,11 +123,11 @@ pre-configure:
${DO_NADA}
run-autotools:
- cd ${WRKDIR}/apr-${PORTVERSION}; ${SETENV} ${SCRIPTS_ENV} AUTOCONF=${AUTOCONF} AUTOHEADER=${AUTOHEADER} LIBTOOL_M4=${LIBTOOL_M4} ${SH} ./buildconf
+ cd ${WRKDIR}/apr-${PORTVERSION}; ${SETENV} ${SCRIPTS_ENV} LIBTOOL_M4=${LIBTOOL_M4} ${SH} ./buildconf
cd ${WRKDIR}/apr-util-${PORTVERSION} ; \
${RM} -fr xml/expat
cd ${WRKDIR}/apr-util-${PORTVERSION} ; \
- ${SETENV} ${SCRIPTS_EV} AUTOCONF=${AUTOCONF} AUTOHEADER=${AUTOHEADER} LIBTOOL_M4=${LIBTOOL_M4} ${SH} ./buildconf \
+ ${SETENV} ${SCRIPTS_ENV} LIBTOOL_M4=${LIBTOOL_M4} ${SH} ./buildconf \
--with-apr=../apr-${PORTVERSION}
cd ${WRKDIR}/apr-${PORTVERSION}; \
${SETENV} ${SCRIPTS_ENV} ${SH} ./configure ${CONFIGURE_ARGS}
diff --git a/devel/apr1/Makefile b/devel/apr1/Makefile
index 568b308a26a2..acf2479c9074 100644
--- a/devel/apr1/Makefile
+++ b/devel/apr1/Makefile
@@ -28,13 +28,12 @@ COMMENT= The Apache Group's Portability Library
LIB_DEPENDS+= expat.5:${PORTSDIR}/textproc/expat2
-USE_ICONV= yes
+USE_ICONV= yes
+USE_AUTOMAKE_VER= 17
USE_AUTOCONF_VER= 257
+WANT_LIBTOOL_VER= 15
USE_PERL5= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER= 15
-LIBTOOLFILES= # none
-USE_AUTOMAKE_VER= 17
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}
@@ -78,7 +77,7 @@ PKGNAMESUFFIX= -db4
.endif
.endif
-LIBTOOL_M4=${LOCALBASE}/share/aclocal/libtool${USE_LIBTOOL_VER}.m4
+LIBTOOL_M4=${LOCALBASE}/share/aclocal/libtool${LIBTOOL_VERSION}.m4
pre-extract:
@${ECHO_MSG} ""
@@ -124,11 +123,11 @@ pre-configure:
${DO_NADA}
run-autotools:
- cd ${WRKDIR}/apr-${PORTVERSION}; ${SETENV} ${SCRIPTS_ENV} AUTOCONF=${AUTOCONF} AUTOHEADER=${AUTOHEADER} LIBTOOL_M4=${LIBTOOL_M4} ${SH} ./buildconf
+ cd ${WRKDIR}/apr-${PORTVERSION}; ${SETENV} ${SCRIPTS_ENV} LIBTOOL_M4=${LIBTOOL_M4} ${SH} ./buildconf
cd ${WRKDIR}/apr-util-${PORTVERSION} ; \
${RM} -fr xml/expat
cd ${WRKDIR}/apr-util-${PORTVERSION} ; \
- ${SETENV} ${SCRIPTS_EV} AUTOCONF=${AUTOCONF} AUTOHEADER=${AUTOHEADER} LIBTOOL_M4=${LIBTOOL_M4} ${SH} ./buildconf \
+ ${SETENV} ${SCRIPTS_ENV} LIBTOOL_M4=${LIBTOOL_M4} ${SH} ./buildconf \
--with-apr=../apr-${PORTVERSION}
cd ${WRKDIR}/apr-${PORTVERSION}; \
${SETENV} ${SCRIPTS_ENV} ${SH} ./configure ${CONFIGURE_ARGS}
diff --git a/devel/apr2/Makefile b/devel/apr2/Makefile
index 568b308a26a2..acf2479c9074 100644
--- a/devel/apr2/Makefile
+++ b/devel/apr2/Makefile
@@ -28,13 +28,12 @@ COMMENT= The Apache Group's Portability Library
LIB_DEPENDS+= expat.5:${PORTSDIR}/textproc/expat2
-USE_ICONV= yes
+USE_ICONV= yes
+USE_AUTOMAKE_VER= 17
USE_AUTOCONF_VER= 257
+WANT_LIBTOOL_VER= 15
USE_PERL5= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER= 15
-LIBTOOLFILES= # none
-USE_AUTOMAKE_VER= 17
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
WRKSRC= ${WRKDIR}
@@ -78,7 +77,7 @@ PKGNAMESUFFIX= -db4
.endif
.endif
-LIBTOOL_M4=${LOCALBASE}/share/aclocal/libtool${USE_LIBTOOL_VER}.m4
+LIBTOOL_M4=${LOCALBASE}/share/aclocal/libtool${LIBTOOL_VERSION}.m4
pre-extract:
@${ECHO_MSG} ""
@@ -124,11 +123,11 @@ pre-configure:
${DO_NADA}
run-autotools:
- cd ${WRKDIR}/apr-${PORTVERSION}; ${SETENV} ${SCRIPTS_ENV} AUTOCONF=${AUTOCONF} AUTOHEADER=${AUTOHEADER} LIBTOOL_M4=${LIBTOOL_M4} ${SH} ./buildconf
+ cd ${WRKDIR}/apr-${PORTVERSION}; ${SETENV} ${SCRIPTS_ENV} LIBTOOL_M4=${LIBTOOL_M4} ${SH} ./buildconf
cd ${WRKDIR}/apr-util-${PORTVERSION} ; \
${RM} -fr xml/expat
cd ${WRKDIR}/apr-util-${PORTVERSION} ; \
- ${SETENV} ${SCRIPTS_EV} AUTOCONF=${AUTOCONF} AUTOHEADER=${AUTOHEADER} LIBTOOL_M4=${LIBTOOL_M4} ${SH} ./buildconf \
+ ${SETENV} ${SCRIPTS_ENV} LIBTOOL_M4=${LIBTOOL_M4} ${SH} ./buildconf \
--with-apr=../apr-${PORTVERSION}
cd ${WRKDIR}/apr-${PORTVERSION}; \
${SETENV} ${SCRIPTS_ENV} ${SH} ./configure ${CONFIGURE_ARGS}
diff --git a/devel/automake17/Makefile b/devel/automake17/Makefile
index 87b410486cd0..703cb52ef499 100644
--- a/devel/automake17/Makefile
+++ b/devel/automake17/Makefile
@@ -19,9 +19,8 @@ COMMENT= GNU Standards-compliant Makefile generator (version 1.7)
DEPRECATED= Please use devel/automake18 instead
EXPIRATION_DATE=31st December 2004
-BUILD_DEPENDS= autoconf257:${PORTSDIR}/devel/autoconf257
-RUN_DEPENDS= autoconf257:${PORTSDIR}/devel/autoconf257
-
+WANT_AUTOCONF_VER=257
+WANT_AUTOCONF_RUN=yes
BUILD_VERSION= 17
PLIST_SUB= BUILD_VERSION=${BUILD_VERSION}
LATEST_LINK= automake${BUILD_VERSION}
diff --git a/devel/avr-gcc-3/Makefile b/devel/avr-gcc-3/Makefile
index 93a410f28d9c..d2e1affe3059 100644
--- a/devel/avr-gcc-3/Makefile
+++ b/devel/avr-gcc-3/Makefile
@@ -28,11 +28,11 @@ RUN_DEPENDS= avr-as:${PORTSDIR}/devel/avr-binutils \
WRKSRC= ${WRKDIR}/gcc-${PORTVERSION}
+USE_AUTOHEADER_VER= 213
USE_PERL5_BUILD= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_BISON= yes
-USE_AUTOHEADER= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --target=avr --disable-nls
diff --git a/devel/avr-gcc/Makefile b/devel/avr-gcc/Makefile
index 93a410f28d9c..d2e1affe3059 100644
--- a/devel/avr-gcc/Makefile
+++ b/devel/avr-gcc/Makefile
@@ -28,11 +28,11 @@ RUN_DEPENDS= avr-as:${PORTSDIR}/devel/avr-binutils \
WRKSRC= ${WRKDIR}/gcc-${PORTVERSION}
+USE_AUTOHEADER_VER= 213
USE_PERL5_BUILD= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_BISON= yes
-USE_AUTOHEADER= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --target=avr --disable-nls
diff --git a/devel/cvsnt/Makefile b/devel/cvsnt/Makefile
index 1f8c7135a8e6..2f5681b69f4e 100644
--- a/devel/cvsnt/Makefile
+++ b/devel/cvsnt/Makefile
@@ -14,8 +14,7 @@ MASTER_SITES= http://www.cvsnt.org/archive/ \
MAINTAINER= fjoe@FreeBSD.org
COMMENT= CVS clone
-LIB_DEPENDS= ltdl.4:${PORTSDIR}/devel/libltdl
-
+USE_LIBLTDL= yes
USE_LIBTOOL_VER= 13
CONFIGURE_ARGS= --enable-fork
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/devel/cvsutils/Makefile b/devel/cvsutils/Makefile
index b07422202cd8..91b8f0e7ab9f 100644
--- a/devel/cvsutils/Makefile
+++ b/devel/cvsutils/Makefile
@@ -20,6 +20,7 @@ USE_PERL5= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
USE_AUTOMAKE_VER=15
+USE_AUTOCONF_VER=253
AUTOMAKE_ARGS= --add-missing
MAN1= cvsutils.1
diff --git a/devel/fam/Makefile b/devel/fam/Makefile
index 0ad8ed14c3c0..b33ecddb54f4 100644
--- a/devel/fam/Makefile
+++ b/devel/fam/Makefile
@@ -21,6 +21,7 @@ COMMENT= A file alteration monitor
CFLAGS+= -Wno-deprecated
USE_AUTOMAKE_VER=15
+USE_AUTOCONF_VER=253
USE_LIBTOOL_VER=13
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
USE_GMAKE= yes
diff --git a/devel/gcvs/Makefile b/devel/gcvs/Makefile
index 9a905e84fc57..06835cdb5b52 100644
--- a/devel/gcvs/Makefile
+++ b/devel/gcvs/Makefile
@@ -16,8 +16,6 @@ MASTER_SITE_SUBDIR= cvsgui
MAINTAINER= dinoex@FreeBSD.org
COMMENT= High-end interface client for CVS
-BUILD_DEPENDS+= autoconf213:${PORTSDIR}/devel/autoconf213
-BUILD_DEPENDS+= automake14:${PORTSDIR}/devel/automake14
BUILD_DEPENDS+= wish8.4:${PORTSDIR}/x11-toolkits/tk84
RUN_DEPENDS+= wish8.4:${PORTSDIR}/x11-toolkits/tk84
@@ -33,7 +31,7 @@ CONFIGURE_SCRIPT= make_configure
MAN1= cvs.1
MAN5= cvs.5
MAN8= cvsbug.8
-#USE_AUTOMAKE_VER= 14
-#USE_AUTOCONF_VER= 213
+WANT_AUTOMAKE_VER= 14
+WANT_AUTOCONF_VER= 213
.include <bsd.port.mk>
diff --git a/devel/gnulibiberty/Makefile b/devel/gnulibiberty/Makefile
index a94600dfd61e..ed957f7c0cd9 100644
--- a/devel/gnulibiberty/Makefile
+++ b/devel/gnulibiberty/Makefile
@@ -20,7 +20,7 @@ WRKSRC= ${WRKDIR}/binutils-${PORTVERSION}/libiberty
USE_BZIP2= yes
USE_GMAKE= yes
CONFIGURE_ARGS= --enable-install-libiberty
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
CONFLICTS= freelibiberty-*
diff --git a/devel/i386-rtems-g77/Makefile b/devel/i386-rtems-g77/Makefile
index af6aed8c7f18..18bd299194ed 100644
--- a/devel/i386-rtems-g77/Makefile
+++ b/devel/i386-rtems-g77/Makefile
@@ -33,14 +33,11 @@ PLIST_SUB+= "GCCVERSION=${GCCVERSION}"
NEWLIBNAME= newlib-1.11.0
PLIST= ${PKGDIR}/pkg-plist.${LCLTARGET}
-# autoheader is used by the port but autoconf is not, setting USE_AUTOCONF
-# will break the port. Since USE_AUTOHEADER sets USE_AUTOCONF, this is
-# likely to break the port also.
-BUILD_DEPENDS= autoheader:${PORTSDIR}/devel/autoconf \
- ${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc
+BUILD_DEPENDS= ${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc
RUN_DEPENDS= ${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc
PKGNAMEPREFIX= ${LCLTARGET}-
+WANT_AUTOHEADER_VER=253
USE_GMAKE= yes
GNU_CONFIGURE= yes
ALL_TARGET= all info
diff --git a/devel/i386-rtems-gcc/Makefile b/devel/i386-rtems-gcc/Makefile
index 221514f930db..a06f2a2815f6 100644
--- a/devel/i386-rtems-gcc/Makefile
+++ b/devel/i386-rtems-gcc/Makefile
@@ -39,16 +39,13 @@ NEWLIBNAME= newlib-1.11.0
PLIST= ${PKGDIR}/pkg-plist.${LCLTARGET}
USE_GETTEXT= yes
-# autoheader is used by the port but autoconf is not, setting USE_AUTOCONF
-# will break the port. Since USE_AUTOHEADER sets USE_AUTOCONF, this is
-# likely to break the port also.
-BUILD_DEPENDS= autoheader:${PORTSDIR}/devel/autoconf \
- ${LCLTARGET}-as:${PORTSDIR}/devel/${LCLTARGET}-binutils \
+BUILD_DEPENDS= ${LCLTARGET}-as:${PORTSDIR}/devel/${LCLTARGET}-binutils \
${LCLTARGET}-ld:${PORTSDIR}/devel/${LCLTARGET}-binutils
RUN_DEPENDS= ${LCLTARGET}-as:${PORTSDIR}/devel/${LCLTARGET}-binutils \
${LCLTARGET}-ld:${PORTSDIR}/devel/${LCLTARGET}-binutils
PKGNAMEPREFIX= ${LCLTARGET}-
+WANT_AUTOHEADER_VER=253
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_REINPLACE= yes
diff --git a/devel/i386-rtems-objc/Makefile b/devel/i386-rtems-objc/Makefile
index 30e7184f1d6a..443ff0544084 100644
--- a/devel/i386-rtems-objc/Makefile
+++ b/devel/i386-rtems-objc/Makefile
@@ -33,14 +33,11 @@ PLIST_SUB+= "GCCVERSION=${GCCVERSION}"
NEWLIBNAME= newlib-1.11.0
PLIST= ${PKGDIR}/pkg-plist.${LCLTARGET}
-# autoheader is used by the port but autoconf is not, setting USE_AUTOCONF
-# will break the port. Since USE_AUTOHEADER sets USE_AUTOCONF, this is
-# likely to break the port also.
-BUILD_DEPENDS= autoheader:${PORTSDIR}/devel/autoconf \
- ${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc
+BUILD_DEPENDS= ${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc
RUN_DEPENDS= ${LCLTARGET}-gcc:${PORTSDIR}/devel/${LCLTARGET}-gcc
PKGNAMEPREFIX= ${LCLTARGET}-
+WANT_AUTOHEADER_VER=253
USE_GMAKE= yes
GNU_CONFIGURE= yes
ALL_TARGET= all info
diff --git a/devel/kdevelop/Makefile b/devel/kdevelop/Makefile
index c640c462e4ac..3198c9f9999c 100644
--- a/devel/kdevelop/Makefile
+++ b/devel/kdevelop/Makefile
@@ -20,9 +20,7 @@ BUILD_DEPENDS= cervisia:${PORTSDIR}/devel/kdesdk3 \
msgfmt:${PORTSDIR}/devel/gettext
LIB_DEPENDS= db4:${PORTSDIR}/databases/db4
RUN_DEPENDS= extractrc:${PORTSDIR}/devel/kdesdk3 \
- gmake:${PORTSDIR}/devel/gmake \
- autoconf257:${PORTSDIR}/devel/autoconf257 \
- automake17:${PORTSDIR}/devel/automake17
+ gmake:${PORTSDIR}/devel/gmake
.if defined(WITH_OPTIONAL_DEPENDS)
RUN_DEPENDS+= kiconedit:${PORTSDIR}/graphics/kdegraphics3 \
ark:${PORTSDIR}/misc/kdeutils3 \
@@ -31,6 +29,11 @@ RUN_DEPENDS+= kiconedit:${PORTSDIR}/graphics/kdegraphics3 \
.endif
# KDE_DISTNAME= ${PORTNAME}-${PORTVERSION}_for_KDE_3.1
+
+WANT_AUTOMAKE_VER= 17
+WANT_AUTOMAKE_RUN= yes
+WANT_AUTOCONF_VER= 257
+WANT_AUTOCONF_RUN= yes
USE_KDELIBS_VER=3
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/devel/kdevelop/files/patch-Makefile.in b/devel/kdevelop/files/patch-Makefile.in
new file mode 100644
index 000000000000..b450b6cdc97b
--- /dev/null
+++ b/devel/kdevelop/files/patch-Makefile.in
@@ -0,0 +1,36 @@
+--- Makefile.in.orig Mon Apr 5 14:57:43 2004
++++ Makefile.in Sun May 30 18:49:05 2004
+@@ -418,28 +418,2 @@
+ $(srcdir)/Makefile.in: $(srcdir)/Makefile.am $(srcdir)/admin/deps.am $(srcdir)/Doxyfile.am $(am__configure_deps)
+-#>- @for dep in $?; do \
+-#>- case '$(am__configure_deps)' in \
+-#>- *$$dep*) \
+-#>- echo ' cd $(srcdir) && $(AUTOMAKE) --foreign '; \
+-#>- cd $(srcdir) && $(AUTOMAKE) --foreign \
+-#>- && exit 0; \
+-#>- exit 1;; \
+-#>- esac; \
+-#>- done; \
+-#>- echo ' cd $(top_srcdir) && $(AUTOMAKE) --foreign Makefile'; \
+-#>- cd $(top_srcdir) && \
+-#>- $(AUTOMAKE) --foreign Makefile
+-#>+ 14
+- @for dep in $?; do \
+- case '$(am__configure_deps)' in \
+- *$$dep*) \
+- echo ' cd $(srcdir) && $(AUTOMAKE) --foreign '; \
+- ( \
+- cd $(srcdir) && $(AUTOMAKE) --foreign \
+- ) || exit 1; echo ' cd $(top_srcdir) && perl admin/am_edit '; cd $(top_srcdir) && perl admin/am_edit && exit 0; \
+- exit 1;; \
+- esac; \
+- done; \
+- echo ' cd $(top_srcdir) && $(AUTOMAKE) --foreign Makefile'; \
+- cd $(top_srcdir) && \
+- $(AUTOMAKE) --foreign Makefile
+ cd $(top_srcdir) && perl admin/am_edit Makefile.in
+@@ -1182,4 +1156,2 @@
+ \
+- cd $(srcdir) && $(AUTOMAKE) --foreign \
+-
+ cd $(top_srcdir) && perl admin/am_edit Makefile.in
diff --git a/devel/korelib/Makefile b/devel/korelib/Makefile
index 2199e172f1fd..5088df3a45f1 100644
--- a/devel/korelib/Makefile
+++ b/devel/korelib/Makefile
@@ -16,7 +16,8 @@ COMMENT= A cross-platform C++ library for developing modular applications
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_AUTOMAKE_VER= 14
+USE_AUTOMAKE_VER=14
+USE_AUTOCONF_VER=213
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
INSTALLS_SHLIB= yes
diff --git a/devel/libbfd/Makefile b/devel/libbfd/Makefile
index 576d68cbdea3..6ac4e291f7c0 100644
--- a/devel/libbfd/Makefile
+++ b/devel/libbfd/Makefile
@@ -27,7 +27,7 @@ CONFIGURE_ARGS= --enable-install-libbfd \
CONFIGURE_ARGS+= --host=x86_64-portbld-freebsd${OSREL}
.endif
-USE_LIBTOOL= yes
+USE_LIBTOOL_VER=13
INFO= bfd
diff --git a/devel/libdsp/Makefile b/devel/libdsp/Makefile
index 41f6022b62be..387e848d59eb 100644
--- a/devel/libdsp/Makefile
+++ b/devel/libdsp/Makefile
@@ -19,8 +19,7 @@ COMMENT= C++ class library of common digital signal processing functions
WRKSRC= ${WRKDIR}/libdsp-src/${PORTNAME:S/dsp/DSP/}-${PORTVERSION}
-USE_LIBTOOL_VER= 13
-LIBTOOLFILES= # none
+WANT_LIBTOOL_VER=13
USE_GMAKE= yes
MAKE_ENV= CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" MKDIR="${MKDIR}" \
INLINE_VER="${INLINE_VER}"
@@ -29,7 +28,6 @@ INSTALLS_SHLIB= yes
INLINE_VER= 1.2.5
-# There's no configure script, but we need libtool to build
do-configure:
@${DO_NADA}
diff --git a/devel/m6811-gcc/Makefile b/devel/m6811-gcc/Makefile
index 27e49fa66db3..34dbee10e0db 100644
--- a/devel/m6811-gcc/Makefile
+++ b/devel/m6811-gcc/Makefile
@@ -21,7 +21,6 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= The gcc-2.95.2 cross-compiler for the 6811
BUILD_DEPENDS= ${LOCALBASE}/bin/m6811-elf-as:${PORTSDIR}/devel/${PKGNAMEPREFIX}binutils
-BUILD_DEPENDS+= autoconf:${PORTSDIR}/devel/autoconf
# Configuration alpha-unknown-freebsdelf not supported
# Configuration sparc64-unknown-freebsdelf not supported
@@ -29,6 +28,7 @@ BUILD_DEPENDS+= autoconf:${PORTSDIR}/devel/autoconf
ONLY_FOR_ARCHS= i386
MANUAL_PACKAGE_BUILD= Path problem to autoheader on bento
+WANT_AUTOCONF_VER=253
USE_GMAKE= yes
HAS_CONFIGURE= yes
.if defined(_CPUCFLAGS) && !empty(_CPUCFLAGS)
diff --git a/devel/mingw-gcc/Makefile b/devel/mingw-gcc/Makefile
index 9b64351b03a6..08f93aae83d1 100644
--- a/devel/mingw-gcc/Makefile
+++ b/devel/mingw-gcc/Makefile
@@ -19,13 +19,13 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= FSF gcc-2.95.3 for Windows cross-development
BUILD_DEPENDS= ${LOCALBASE}/i386-mingw32msvc/bin/as:${PORTSDIR}/devel/mingw-binutils \
- ${LOCALBASE}/bin/mingwm10.dll:${PORTSDIR}/devel/mingw-bin-msvcrt \
- autoheader:${PORTSDIR}/devel/autoconf
+ ${LOCALBASE}/bin/mingwm10.dll:${PORTSDIR}/devel/mingw-bin-msvcrt
RUN_DEPENDS= ${LOCALBASE}/i386-mingw32msvc/bin/as:${PORTSDIR}/devel/mingw-binutils \
${LOCALBASE}/bin/mingwm10.dll:${PORTSDIR}/devel/mingw-bin-msvcrt
WRKSRC= ${WRKDIR}/gcc-${PORTVERSION}-20010828
+WANT_AUTOCONF_VER=253
USE_GMAKE= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
diff --git a/devel/shapelib/Makefile b/devel/shapelib/Makefile
index 0b62a58aaad5..1bd2cda08911 100644
--- a/devel/shapelib/Makefile
+++ b/devel/shapelib/Makefile
@@ -13,12 +13,10 @@ MASTER_SITES= http://shapelib.maptools.org/dl/
MAINTAINER= ports@FreeBSD.org
COMMENT= C API for reading and writing ArcView Shapefiles
-USE_LIBTOOL_VER= 13
-LIBTOOLFILES= # none
+WANT_LIBTOOL_VER=13
ALL_TARGET= lib
INSTALLS_SHLIB= yes
-# no configure script, but we need the libtool environment
do-configure:
@${CP} ${LIBTOOL} ${WRKSRC}
diff --git a/devel/swig13/Makefile b/devel/swig13/Makefile
index 3f97e744bfbc..064f85288911 100644
--- a/devel/swig13/Makefile
+++ b/devel/swig13/Makefile
@@ -14,8 +14,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= knu@FreeBSD.org
COMMENT= Simplified Wrapper and Interface Generator
-BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
-
+WANT_AUTOCONF_VER=253
VER= ${PORTVERSION:R}
# Supported languages: guile perl php4 python ruby tcl ocaml pike java
diff --git a/devel/swig20/Makefile b/devel/swig20/Makefile
index 3f97e744bfbc..064f85288911 100644
--- a/devel/swig20/Makefile
+++ b/devel/swig20/Makefile
@@ -14,8 +14,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= knu@FreeBSD.org
COMMENT= Simplified Wrapper and Interface Generator
-BUILD_DEPENDS= autoconf:${PORTSDIR}/devel/autoconf
-
+WANT_AUTOCONF_VER=253
VER= ${PORTVERSION:R}
# Supported languages: guile perl php4 python ruby tcl ocaml pike java
diff --git a/devel/sysconftool/Makefile b/devel/sysconftool/Makefile
index afd9ed708205..9e3a4ae0169a 100644
--- a/devel/sysconftool/Makefile
+++ b/devel/sysconftool/Makefile
@@ -17,6 +17,7 @@ COMMENT= Helps to install application configuration files
USE_BZIP2= yes
USE_PERL5= yes
USE_AUTOMAKE_VER= 15
+USE_AUTOCONF_VER= 253
MAN1= sysconftool.1 sysconftoolcheck.1
MAN7= sysconftool.7
diff --git a/devel/umbrello/Makefile b/devel/umbrello/Makefile
index 8a634e7d9ccd..a38f9a763ca9 100644
--- a/devel/umbrello/Makefile
+++ b/devel/umbrello/Makefile
@@ -17,9 +17,8 @@ COMMENT= UML Modeller
CONFLICTS= kdesdk-3.[2-].*
-BUILD_DEPENDS= autoconf213:${PORTSDIR}/devel/autoconf213 \
- automake14:${PORTSDIR}/devel/automake14
-
+WANT_AUTOMAKE_VER=14
+WANT_AUTOCONF_VER=213
USE_KDELIBS_VER=3
GNU_CONFIGURE= yes
USE_GMAKE= yes