aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-Mock-LWP/Makefile26
-rw-r--r--devel/p5-Test-Mock-LWP/distinfo3
-rw-r--r--devel/p5-Test-Mock-LWP/pkg-descr4
-rw-r--r--devel/p5-Test-Mock-LWP/pkg-plist11
5 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 79c5a4c0ce6b..3b4a360ad401 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1837,6 +1837,7 @@
SUBDIR += p5-Test-LongString
SUBDIR += p5-Test-Manifest
SUBDIR += p5-Test-Memory-Cycle
+ SUBDIR += p5-Test-Mock-LWP
SUBDIR += p5-Test-MockModule
SUBDIR += p5-Test-MockObject
SUBDIR += p5-Test-MockRandom
diff --git a/devel/p5-Test-Mock-LWP/Makefile b/devel/p5-Test-Mock-LWP/Makefile
new file mode 100644
index 000000000000..528354f826d6
--- /dev/null
+++ b/devel/p5-Test-Mock-LWP/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Test-Mock-LWP
+# Date created: 2009-03-13
+# Whom: TAKAHASHI Kaoru <kaoru@kaisei.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-Mock-LWP
+PORTVERSION= 0.05
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kaoru@kaisei.org
+COMMENT= Easy mocking of LWP packages
+
+RUN_DEPENDS= p5-Test-MockObject>=1.08:${PORTSDIR}/devel/p5-Test-MockObject
+
+PERL_CONFIGURE= 5.6.2+
+
+MAN3= Test::Mock::HTTP::Request.3 \
+ Test::Mock::HTTP::Response.3 \
+ Test::Mock::LWP::UserAgent.3 \
+ Test::Mock::LWP.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-Mock-LWP/distinfo b/devel/p5-Test-Mock-LWP/distinfo
new file mode 100644
index 000000000000..99b4e5f2b032
--- /dev/null
+++ b/devel/p5-Test-Mock-LWP/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-Mock-LWP-0.05.tar.gz) = 2496324cd4474966269847836770b7a0
+SHA256 (Test-Mock-LWP-0.05.tar.gz) = 61d70611e0d22cad29300433cbbe1aebdac2121d849b228016504afe5043590d
+SIZE (Test-Mock-LWP-0.05.tar.gz) = 19384
diff --git a/devel/p5-Test-Mock-LWP/pkg-descr b/devel/p5-Test-Mock-LWP/pkg-descr
new file mode 100644
index 000000000000..17880d2e46d8
--- /dev/null
+++ b/devel/p5-Test-Mock-LWP/pkg-descr
@@ -0,0 +1,4 @@
+Test::Mock::LWP provides easy mocking of LWP packages:
+HTTP::Request, HTTP::Response, LWP and LWP::UserAgent.
+
+WWW: http://search.cpan.org/dist/Test-Mock-LWP/
diff --git a/devel/p5-Test-Mock-LWP/pkg-plist b/devel/p5-Test-Mock-LWP/pkg-plist
new file mode 100644
index 000000000000..6dde0c0f06e4
--- /dev/null
+++ b/devel/p5-Test-Mock-LWP/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Mock/LWP/.packlist
+%%SITE_PERL%%/Test/Mock/HTTP/Request.pm
+%%SITE_PERL%%/Test/Mock/HTTP/Response.pm
+%%SITE_PERL%%/Test/Mock/LWP/UserAgent.pm
+%%SITE_PERL%%/Test/Mock/LWP.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/Mock/LWP
+@dirrmtry %%SITE_PERL%%/mach/auto/Test/Mock
+@dirrmtry %%SITE_PERL%%/Test/Mock/LWP
+@dirrmtry %%SITE_PERL%%/Test/Mock/HTTP
+@dirrmtry %%SITE_PERL%%/Test/Mock