aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Log-Trace/Makefile23
-rw-r--r--devel/p5-Log-Trace/distinfo3
-rw-r--r--devel/p5-Log-Trace/pkg-descr3
-rw-r--r--devel/p5-Log-Trace/pkg-plist7
5 files changed, 37 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 81f9c9ab8114..04cde53adc8f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1287,6 +1287,7 @@
SUBDIR += p5-Log-Message
SUBDIR += p5-Log-Message-Simple
SUBDIR += p5-Log-Simple
+ SUBDIR += p5-Log-Trace
SUBDIR += p5-Log-TraceMessages
SUBDIR += p5-Logfile-Rotate
SUBDIR += p5-Luka
diff --git a/devel/p5-Log-Trace/Makefile b/devel/p5-Log-Trace/Makefile
new file mode 100644
index 000000000000..64f6005f9448
--- /dev/null
+++ b/devel/p5-Log-Trace/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: devel/p5-Log-Trace
+# Date created: 27 May 2007
+# Whom: Lars Thegler <lth@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Log-Trace
+PORTVERSION= 1.070
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Log
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lth@FreeBSD.org
+COMMENT= Provides a unified approach to tracing
+
+PERL_CONFIGURE= yes
+
+MAN3= Log::Trace.3 \
+ Log::Trace::Manual.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Log-Trace/distinfo b/devel/p5-Log-Trace/distinfo
new file mode 100644
index 000000000000..6c94568c485c
--- /dev/null
+++ b/devel/p5-Log-Trace/distinfo
@@ -0,0 +1,3 @@
+MD5 (Log-Trace-1.070.tar.gz) = 773aefa7539b1857edb3e225cfbc4a22
+SHA256 (Log-Trace-1.070.tar.gz) = 9ecb8258ef30c2f24deff4917240d0fe73242da5b2192402f79815b092ed36e3
+SIZE (Log-Trace-1.070.tar.gz) = 25548
diff --git a/devel/p5-Log-Trace/pkg-descr b/devel/p5-Log-Trace/pkg-descr
new file mode 100644
index 000000000000..f3930ec1c0e2
--- /dev/null
+++ b/devel/p5-Log-Trace/pkg-descr
@@ -0,0 +1,3 @@
+A module to provide a unified approach to tracing.
+
+WWW: http://search.cpan.org/dist/Log-Trace/
diff --git a/devel/p5-Log-Trace/pkg-plist b/devel/p5-Log-Trace/pkg-plist
new file mode 100644
index 000000000000..2226eb5aebde
--- /dev/null
+++ b/devel/p5-Log-Trace/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/Log/Trace.pm
+%%SITE_PERL%%/Log/Trace/Manual.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Trace/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log/Trace
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Log
+@dirrmtry %%SITE_PERL%%/Log/Trace
+@dirrmtry %%SITE_PERL%%/Log