aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/apr1/Makefile3
-rw-r--r--devel/apr2/Makefile3
-rw-r--r--devel/asmutils/Makefile6
-rw-r--r--devel/ccrtp/Makefile2
-rw-r--r--devel/google-perftools/Makefile4
-rw-r--r--devel/ifd-test/Makefile2
-rw-r--r--devel/libgutenfetch/Makefile2
-rw-r--r--devel/libunicode/Makefile2
-rw-r--r--devel/libzvbi/Makefile4
-rw-r--r--devel/nspr/Makefile4
-rw-r--r--devel/pypersrc/Makefile8
-rw-r--r--devel/srecord/Makefile2
12 files changed, 21 insertions, 21 deletions
diff --git a/devel/apr1/Makefile b/devel/apr1/Makefile
index 17f6b0f55cb0..8a3c30f0582b 100644
--- a/devel/apr1/Makefile
+++ b/devel/apr1/Makefile
@@ -114,9 +114,8 @@ APU_CONF_ARGS+= --without-freetds
APU_EXTRAS= yes
USE_MYSQL= yes
APU_CONF_ARGS+= --with-mysql=${LOCALBASE}
-CONFIGURE_ENV+= LIBS="${LIBS}"
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/mysql -DHAVE_MYSQL_H
-LDFLAGS+= -L${LOCALBASE}/lib/mysql
+LIBS+= -L${LOCALBASE}/lib/mysql
.else
APU_CONF_ARGS+= --without-mysql
.endif
diff --git a/devel/apr2/Makefile b/devel/apr2/Makefile
index 911c941c0888..69bfd1fe64f2 100644
--- a/devel/apr2/Makefile
+++ b/devel/apr2/Makefile
@@ -134,9 +134,8 @@ EXTRAS= yes
PLIST_SUB+= MYSQL=""
USE_MYSQL= YES
CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}
-CONFIGURE_ENV+= LIBS="${LIBS}"
CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/mysql -DHAVE_MYSQL_H
-LDFLAGS+= -L${LOCALBASE}/lib/mysql
+LIBS+= -L${LOCALBASE}/lib/mysql
. if defined(PKGNAMESUFFIX)
PKGNAMESUFFIX:= ${PKGNAMESUFFIX}-mysql${MYSQL_VER}
. else
diff --git a/devel/asmutils/Makefile b/devel/asmutils/Makefile
index 5480aca455c5..0bce9d524f5c 100644
--- a/devel/asmutils/Makefile
+++ b/devel/asmutils/Makefile
@@ -34,10 +34,10 @@ BINS= bonus/asmutils basename cal cat chmod chown chroot cmp cp \
LINKS= arch cpuspeed domainname false halt inflate kldstat kldunload \
mkfifo more poweroff regs rmdir size sln todos umount usleep
-LIBS= libc.so.0 libcrypto.so.0 libm.so.0
+LIBRARIES= libc.so.0 libcrypto.so.0 libm.so.0
PLIST_FILES= ${BINS:S/^/bin\/asmutils\//:S/bonus\///} \
- ${LINKS:S/^/bin\/asmutils\//} ${LIBS:S/^/lib\/asmutils\//}
+ ${LINKS:S/^/bin\/asmutils\//} ${LIBRARIES:S/^/lib\/asmutils\//}
PLIST_DIRS= bin/asmutils lib/asmutils
PORTDOCS= *
@@ -53,7 +53,7 @@ do-install:
.for bin in ${BINS}
${INSTALL_PROGRAM} ${WRKSRC}/src/${bin} ${PREFIX}/bin/asmutils
.endfor
-.for lib in ${LIBS}
+.for lib in ${LIBRARIES}
${INSTALL_PROGRAM} ${WRKSRC}/lib/${lib} ${PREFIX}/lib/asmutils
.endfor
(cd ${PREFIX}/bin/asmutils && \
diff --git a/devel/ccrtp/Makefile b/devel/ccrtp/Makefile
index 2e71b558b253..1962e333f950 100644
--- a/devel/ccrtp/Makefile
+++ b/devel/ccrtp/Makefile
@@ -17,8 +17,8 @@ GNU_CONFIGURE= yes
USES= gmake gettext iconv pkgconfig
USE_LDCONFIG= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -pthread"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
INFO= ccrtp
post-patch:
diff --git a/devel/google-perftools/Makefile b/devel/google-perftools/Makefile
index d6d33d4ad6b1..76261cdea0f4 100644
--- a/devel/google-perftools/Makefile
+++ b/devel/google-perftools/Makefile
@@ -29,9 +29,7 @@ USE_LDCONFIG= yes
USES= compiler
CPPFLAGS+= -I${LOCALBASE}/include
-LIBS+= -lexecinfo
-LDFLAGS+= -L${LOCALBASE}/lib
-CONFIGURE_ARGS+=LIBS="${LIBS}"
+LIBS+= -L${LOCALBASE}/lib -lexecinfo
.include <bsd.port.pre.mk>
diff --git a/devel/ifd-test/Makefile b/devel/ifd-test/Makefile
index e09b97e4b2b5..7330efb63395 100644
--- a/devel/ifd-test/Makefile
+++ b/devel/ifd-test/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= pcsclite.1:${PORTSDIR}/devel/pcsc-lite
USES= gmake
NOMAN=
PLIST_FILES= sbin/ifdtest
-MAKE_ENV= LIBS="-L${PREFIX}/lib -lpcsclite"
+LIBS+= -L${LOCALBASE}/lib -lpcsclite
post-patch:
${REINPLACE_CMD} -e "s,LPSTR,LPTSTR,g; s,LPCSTR,LPCTSTR,g; \
diff --git a/devel/libgutenfetch/Makefile b/devel/libgutenfetch/Makefile
index 9e2be41fd499..f755191facd1 100644
--- a/devel/libgutenfetch/Makefile
+++ b/devel/libgutenfetch/Makefile
@@ -14,8 +14,8 @@ LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
USES= gmake
USE_BZIP2= yes
diff --git a/devel/libunicode/Makefile b/devel/libunicode/Makefile
index 054949dff861..05f269771912 100644
--- a/devel/libunicode/Makefile
+++ b/devel/libunicode/Makefile
@@ -19,8 +19,8 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
CONFIGURE_ARGS= --localstatedir=${PREFIX}/share \
--datadir=${PREFIX}/share
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
.include <bsd.port.mk>
diff --git a/devel/libzvbi/Makefile b/devel/libzvbi/Makefile
index 2293362b6f5d..60c1272fe17f 100644
--- a/devel/libzvbi/Makefile
+++ b/devel/libzvbi/Makefile
@@ -18,8 +18,8 @@ USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib -L/usr/lib"
-CFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
post-patch:
@${REINPLACE_CMD} -e 's|#cpu (\([^)]*\))|defined(__\1__)|g' \
diff --git a/devel/nspr/Makefile b/devel/nspr/Makefile
index 2a48ba7bcba8..e139e24e4cf0 100644
--- a/devel/nspr/Makefile
+++ b/devel/nspr/Makefile
@@ -19,7 +19,7 @@ CONFIGURE_ARGS= --srcdir=${WRKSRC:H}
MAKE_ENV= DIST=${WRKSRC}/dist
-LIBS= libnspr4.so.1 libplc4.so.1 libplds4.so.1
+LIBRARIES= libnspr4.so.1 libplc4.so.1 libplds4.so.1
.include <bsd.port.pre.mk>
@@ -44,7 +44,7 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/config/nspr-config ${STAGEDIR}${PREFIX}/bin
${MKDIR} ${STAGEDIR}${PREFIX}/libdata/pkgconfig
${INSTALL_DATA} ${WRKSRC}/config/nspr.pc ${STAGEDIR}${PREFIX}/libdata/pkgconfig
-.for lib in ${LIBS}
+.for lib in ${LIBRARIES}
.if defined(STRIP) && ${STRIP} != ""
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${lib}
.endif
diff --git a/devel/pypersrc/Makefile b/devel/pypersrc/Makefile
index a7e28152e292..b8efd89763aa 100644
--- a/devel/pypersrc/Makefile
+++ b/devel/pypersrc/Makefile
@@ -19,8 +19,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
WRKSRC= ${WRKDIR}/${PORTNAME}
-USES+= gmake
-USE_BZIP2= yes
+USES= gmake tar:bzip2
USE_PYTHON= yes
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configure.sh
@@ -39,6 +38,11 @@ post-patch:
${REINPLACE_CMD} -e 's|g++|${CXX}|g' ${WRKSRC}/tests/GNUmakefile
@${REINPLACE_CMD} -e 's|tolower|::tolower|' ${WRKSRC}/src/cc/utils_string.hh
+post-configure:
+ @(cd ${WRKSRC}/src/ctags-5.5.4 && ${SETENV} CC="${CC}" CPP="${CPP}" \
+ CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" \
+ ${CONFIGURE_ENV} ./configure)
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/out/pypersrc ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/out/pypersrc.py ${STAGEDIR}${PREFIX}/bin
diff --git a/devel/srecord/Makefile b/devel/srecord/Makefile
index 54c4e2d69b91..2682773ddb06 100644
--- a/devel/srecord/Makefile
+++ b/devel/srecord/Makefile
@@ -14,8 +14,8 @@ BUILD_DEPENDS= ${LOCALBASE}/include/boost/shared_ptr.hpp:${PORTSDIR}/devel/boost
LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib"
CPPFLAGS+= -I${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/lib
MAKE_JOBS_UNSAFE= yes
USE_AUTOTOOLS= libtool