aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/ngpt/Makefile3
-rw-r--r--devel/ppl/Makefile14
-rw-r--r--devel/ppl/files/patch-ltmain.sh15
-rw-r--r--devel/ppl/pkg-plist2
4 files changed, 9 insertions, 25 deletions
diff --git a/devel/ngpt/Makefile b/devel/ngpt/Makefile
index 46952d276a00..6b7f7f99288a 100644
--- a/devel/ngpt/Makefile
+++ b/devel/ngpt/Makefile
@@ -23,4 +23,7 @@ USE_GMAKE= yes
ONLY_FOR_ARCHS= amd64 i386
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/ltconfig
+
.include <bsd.port.mk>
diff --git a/devel/ppl/Makefile b/devel/ppl/Makefile
index 1df22dea4b9d..41c51272c0d5 100644
--- a/devel/ppl/Makefile
+++ b/devel/ppl/Makefile
@@ -8,7 +8,7 @@
PORTNAME= ppl
PORTVERSION= 0.6.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel
MASTER_SITES= ftp://ftp.cs.unipr.it/pub/ppl/releases/%SUBDIR%/ \
http://www.cs.unipr.it/ppl/Download/ftp/releases/%SUBDIR%/
@@ -21,7 +21,8 @@ LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
USE_GMAKE= yes
USE_GNOME= gnometarget
-GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
+LIBTOOLFILES= configure Watchdog/configure
CONFIGURE_ARGS= --disable-debugging \
--enable-optimization \
--with-cflags="${CFLAGS}" \
@@ -31,11 +32,4 @@ CONFIGURE_ARGS= --disable-debugging \
USE_LDCONFIG= yes
PORTDOCS= *
-.include <bsd.port.pre.mk>
-
-# ppl needs gcc > 3.1, with libgmp4 compiled with the same gcc version
-.if ${OSVERSION} < 500035
-IGNORE= "Does not build with older versions of FreeBSD"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/ppl/files/patch-ltmain.sh b/devel/ppl/files/patch-ltmain.sh
deleted file mode 100644
index bcd97fabe24a..000000000000
--- a/devel/ppl/files/patch-ltmain.sh
+++ /dev/null
@@ -1,15 +0,0 @@
---- ltmain.sh.orig Mon Jul 1 23:54:06 2002
-+++ ltmain.sh Mon Nov 11 22:34:15 2002
-@@ -4772,10 +4772,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/devel/ppl/pkg-plist b/devel/ppl/pkg-plist
index a2b13429d105..0adafae82ace 100644
--- a/devel/ppl/pkg-plist
+++ b/devel/ppl/pkg-plist
@@ -3,9 +3,11 @@ include/ppl.hh
include/ppl_c.h
include/pwl.hh
lib/libppl.a
+lib/libppl.la
lib/libppl.so
lib/libppl.so.3
lib/libppl_c.a
+lib/libppl_c.la
lib/libppl_c.so
lib/libppl_c.so.1
lib/libpwl.a