aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/cc65/Makefile10
-rw-r--r--devel/entity/Makefile4
-rw-r--r--devel/spin/Makefile2
3 files changed, 8 insertions, 8 deletions
diff --git a/devel/cc65/Makefile b/devel/cc65/Makefile
index 4ff18e2cd910..0b2209ed9889 100644
--- a/devel/cc65/Makefile
+++ b/devel/cc65/Makefile
@@ -34,7 +34,7 @@ WRKSRC= ${WRKDIR}/cc65-${PORTVERSION}
DEVNULL= ${__empty_string_for_portlint}/dev/null
# These doc files can be compiled using the textproc/sgmltools port
-DOCFILES!= ls ${WRKSRC}/doc 2> ${DEVNULL} | \
+DOCFILES!= ${LS} ${WRKSRC}/doc 2> ${DEVNULL} | \
${SED} -E -e 's/^/doc\//' && ${ECHO_CMD} announce.txt
BINFILES= \
@@ -43,14 +43,14 @@ BINFILES= \
BINSCRIPTS= src/ca65html/ca65html
-ASMINCFILES!= ls ${WRKSRC}/asminc 2> ${DEVNULL} | ${EGREP} '\.inc' || true
+ASMINCFILES!= ${LS} ${WRKSRC}/asminc 2> ${DEVNULL} | ${EGREP} '\.inc' || true
-CC65LIBFILES!= ls ${WRKSRC}/libsrc/ 2> ${DEVNULL} | ${EGREP} '\.(o|lib)' \
+CC65LIBFILES!= ${LS} ${WRKSRC}/libsrc/ 2> ${DEVNULL} | ${EGREP} '\.(o|lib)' \
|| true
-CC65EMDFILES!= ls ${WRKSRC}/libsrc/ 2> ${DEVNULL} | ${EGREP} '\.emd' || true
+CC65EMDFILES!= ${LS} ${WRKSRC}/libsrc/ 2> ${DEVNULL} | ${EGREP} '\.emd' || true
-CC65TGIFILES!= ls ${WRKSRC}/libsrc/ 2> ${DEVNULL} | ${EGREP} '\.tgi' || true
+CC65TGIFILES!= ${LS} ${WRKSRC}/libsrc/ 2> ${DEVNULL} | ${EGREP} '\.tgi' || true
do-build:
cd ${WRKSRC}/src && ${SETENV} ${MAKE_ENV} ${GMAKE} -ef make/gcc.mak
diff --git a/devel/entity/Makefile b/devel/entity/Makefile
index b1fbaf8e32b9..509a05ead704 100644
--- a/devel/entity/Makefile
+++ b/devel/entity/Makefile
@@ -28,7 +28,7 @@ MAN1= entity.1
post-install:
${LDCONFIG} -m ${PREFIX}/lib/entity/clib ${PREFIX}/lib
${MKDIR} ${PREFIX}/share/entity
- cd ${WRKSRC}/apps && \
- ${PAX} -r -w `ls | ${GREP} -v Makefile` ${PREFIX}/share/entity
+ cd ${WRKSRC}/apps && ${PAX} -r -w `${LS} | \
+ ${GREP} -v Makefile` ${PREFIX}/share/entity
.include <bsd.port.mk>
diff --git a/devel/spin/Makefile b/devel/spin/Makefile
index 19ceca608f53..f231a1a48b41 100644
--- a/devel/spin/Makefile
+++ b/devel/spin/Makefile
@@ -37,7 +37,7 @@ post-extract:
@cd ${WRKDIR}/Test && ${SH} ${WRKDIR}/Test/examples
post-patch:
- @WISH=`(cd ${LOCALBASE}/bin ; ls wish8* ) | tail -1` ; \
+ @WISH=`(cd ${LOCALBASE}/bin ; ${LS} wish8* ) | tail -1` ; \
if [ -z "$$WISH" ] ; then WISH=wish8.0 ; fi ; \
${REINPLACE_CMD} \
-e "s|%%LOCALBASE%%|${LOCALBASE}|g;" \