aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/antlr/Makefile1
-rw-r--r--devel/astyle/Makefile1
-rw-r--r--devel/bglibs/Makefile1
-rw-r--r--devel/byaccj/Makefile2
-rw-r--r--devel/dia2code/Makefile1
-rw-r--r--devel/glib-java/Makefile1
-rw-r--r--devel/glibmm/Makefile1
-rw-r--r--devel/gnome-vfsmm/Makefile1
-rw-r--r--devel/gpsim/Makefile1
-rw-r--r--devel/guichan/Makefile1
-rw-r--r--devel/guikachu/Makefile1
-rw-r--r--devel/hapy/Makefile1
-rw-r--r--devel/lasi/Makefile1
-rw-r--r--devel/libgconf-java/Makefile1
-rw-r--r--devel/libglade-java/Makefile1
-rw-r--r--devel/libol/Makefile1
-rw-r--r--devel/libphish/Makefile1
-rw-r--r--devel/libs11n/Makefile1
-rw-r--r--devel/libsigc++20/Makefile1
-rw-r--r--devel/libuninum/Makefile1
-rw-r--r--devel/loki/Makefile1
-rw-r--r--devel/mq4cpp/Makefile1
-rw-r--r--devel/open-beagle/Makefile1
-rw-r--r--devel/protobuf/Makefile1
-rw-r--r--devel/py-ocempgui/Makefile1
-rw-r--r--devel/qmake4/Makefile4
-rw-r--r--devel/xfc/Makefile1
-rw-r--r--devel/xlslib/Makefile1
28 files changed, 0 insertions, 32 deletions
diff --git a/devel/antlr/Makefile b/devel/antlr/Makefile
index ff715c29688c..30ac442ee509 100644
--- a/devel/antlr/Makefile
+++ b/devel/antlr/Makefile
@@ -18,7 +18,6 @@ RUN_DEPENDS= java:${PORTSDIR}/java/javavmwrapper
CONFLICTS= pccts-[0-9]*
-USE_GCC= 3.2+
USE_GMAKE= yes
USE_JAVA= yes
JAVA_VERSION= 1.4+
diff --git a/devel/astyle/Makefile b/devel/astyle/Makefile
index 7d3ea257416e..0e602a61368a 100644
--- a/devel/astyle/Makefile
+++ b/devel/astyle/Makefile
@@ -19,7 +19,6 @@ ALL_TARGET= astyle
CFLAGS+= -W -Wall -fno-rtti -fno-exceptions
LDFLAGS+= -s
MAKE_ARGS+= CFLAGS="${CFLAGS}"
-USE_GCC= 3.3+
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/astyle/build
diff --git a/devel/bglibs/Makefile b/devel/bglibs/Makefile
index 02b16023c780..7e9e55cc422d 100644
--- a/devel/bglibs/Makefile
+++ b/devel/bglibs/Makefile
@@ -15,7 +15,6 @@ COMMENT= One stop library package by Bruce Guenter
NOT_FOR_ARCHS= alpha
-USE_GCC= 3.2+
USE_PERL5= yes
USE_AUTOTOOLS= libtool:15:env
LDFLAGS?= -s
diff --git a/devel/byaccj/Makefile b/devel/byaccj/Makefile
index 9a79380165c2..9c4b64295669 100644
--- a/devel/byaccj/Makefile
+++ b/devel/byaccj/Makefile
@@ -18,8 +18,6 @@ COMMENT= A java extension of BSD YACC-compatible parser generator
PLIST_FILES= bin/byaccj
WRKSRC= ${WRKDIR}/${DISTNAME}/src
-USE_GCC= 3.4+
-
post-patch:
@${REINPLACE_CMD} -e 's#<malloc.h>#<stdlib.h>#' ${WRKSRC}/defs.h ${WRKSRC}/*c
diff --git a/devel/dia2code/Makefile b/devel/dia2code/Makefile
index 9ee36754ba5d..6b1e1973f0ac 100644
--- a/devel/dia2code/Makefile
+++ b/devel/dia2code/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= A small utility used to generate code from a Dia diagram
USE_GNOME= gnometarget libxml2
-USE_GCC= 3.4+
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/devel/glib-java/Makefile b/devel/glib-java/Makefile
index 90203640192b..dc741d28b5f5 100644
--- a/devel/glib-java/Makefile
+++ b/devel/glib-java/Makefile
@@ -23,7 +23,6 @@ GNU_CONFIGURE= yes
USE_JAVA= yes
JAVA_VERSION= 1.2+
JAVA_OS= native
-USE_GCC= 3.4+
USE_GNOME= gnomehack glib20
CONFIGURE_ARGS= --without-gcj-compile --with-jardir=${JAVAJARDIR}
CONFIGURE_ENV= CPPFLAGS="-I${JAVA_HOME}/include -I${JAVA_HOME}/include/freebsd"
diff --git a/devel/glibmm/Makefile b/devel/glibmm/Makefile
index 5d2b139ccc7a..cea3e3382df6 100644
--- a/devel/glibmm/Makefile
+++ b/devel/glibmm/Makefile
@@ -28,7 +28,6 @@ LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_GMAKE= yes
-USE_GCC= 3.4+
USE_GNOME= gnomehack gnometarget glib20
USE_PERL5= yes
GNU_CONFIGURE= yes
diff --git a/devel/gnome-vfsmm/Makefile b/devel/gnome-vfsmm/Makefile
index 1b397731c3e5..e9a6928b6669 100644
--- a/devel/gnome-vfsmm/Makefile
+++ b/devel/gnome-vfsmm/Makefile
@@ -21,7 +21,6 @@ LIB_DEPENDS= glibmm-2.4.1:${PORTSDIR}/devel/glibmm
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_BZIP2= yes
-USE_GCC= 3.4+
USE_GMAKE= yes
USE_GNOME= gnomehack gnomevfs2
GNU_CONFIGURE= yes
diff --git a/devel/gpsim/Makefile b/devel/gpsim/Makefile
index 62581ca7b84e..058f86d7a005 100644
--- a/devel/gpsim/Makefile
+++ b/devel/gpsim/Makefile
@@ -21,7 +21,6 @@ RUN_DEPENDS= gpasm:${PORTSDIR}/devel/gputils
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
-USE_GCC= 3.4+
USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
diff --git a/devel/guichan/Makefile b/devel/guichan/Makefile
index e3e6d9b25a44..923f383cec9b 100644
--- a/devel/guichan/Makefile
+++ b/devel/guichan/Makefile
@@ -16,7 +16,6 @@ COMMENT= A small, efficient C++ GUI library designed for games
USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
-USE_GCC= 3.2+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/devel/guikachu/Makefile b/devel/guikachu/Makefile
index 6dff87f0218f..fe8bf7bc4ea9 100644
--- a/devel/guikachu/Makefile
+++ b/devel/guikachu/Makefile
@@ -19,7 +19,6 @@ LIB_DEPENDS= gnomeuimm-2.6.1:${PORTSDIR}/x11-toolkits/libgnomeuimm26 \
gnomevfsmm-2.6.1:${PORTSDIR}/devel/gnome-vfsmm
USE_GMAKE= yes
-USE_GCC= 3.4+
USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/devel/hapy/Makefile b/devel/hapy/Makefile
index b63ab5f4d4f8..ab17b6dac7ba 100644
--- a/devel/hapy/Makefile
+++ b/devel/hapy/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= rousskov@measurement-factory.com
COMMENT= A runtime parser generator
GNU_CONFIGURE= yes
-USE_GCC= 3.4+
post-build:
@${ECHO_MSG} "Consider running 'make check' before 'make install'"
diff --git a/devel/lasi/Makefile b/devel/lasi/Makefile
index 7f896b4821e4..f761e17208c7 100644
--- a/devel/lasi/Makefile
+++ b/devel/lasi/Makefile
@@ -14,7 +14,6 @@ MASTER_SITES= http://www.unifont.org/lasi/download/
MAINTAINER= lme@FreeBSD.org
COMMENT= C++ stream output interface for creating Postscript documents
-USE_GCC= 3.2+
USE_GNOME= pango pkgconfig
USE_AUTOTOOLS= libltdl:15
GNU_CONFIGURE= yes
diff --git a/devel/libgconf-java/Makefile b/devel/libgconf-java/Makefile
index 6373a7f2e0ec..b5ee73176093 100644
--- a/devel/libgconf-java/Makefile
+++ b/devel/libgconf-java/Makefile
@@ -26,7 +26,6 @@ GNU_CONFIGURE= yes
USE_JAVA= yes
JAVA_VERSION= 1.2+
JAVA_OS= native
-USE_GCC= 3.4+
USE_GNOME= gnomehack gconf2
CONFIGURE_ARGS= --without-gcj-compile --with-jardir=${JAVAJARDIR}
CONFIGURE_ENV= CPPFLAGS="-I${JAVA_HOME}/include -I${JAVA_HOME}/include/freebsd"
diff --git a/devel/libglade-java/Makefile b/devel/libglade-java/Makefile
index 6e06a041880a..2361bd0d9c7e 100644
--- a/devel/libglade-java/Makefile
+++ b/devel/libglade-java/Makefile
@@ -27,7 +27,6 @@ USE_GMAKE= yes
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
USE_JAVA= yes
-USE_GCC= 3.4+
JAVA_VERSION= 1.2+
JAVA_OS= native
USE_GNOME= gnomehack libglade2
diff --git a/devel/libol/Makefile b/devel/libol/Makefile
index 98303f4e0856..63c45100cea3 100644
--- a/devel/libol/Makefile
+++ b/devel/libol/Makefile
@@ -16,6 +16,5 @@ COMMENT= Library needed by syslog-ng
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-USE_GCC= 3.3+
.include <bsd.port.mk>
diff --git a/devel/libphish/Makefile b/devel/libphish/Makefile
index 571b979ca8ee..6748fd3f2fac 100644
--- a/devel/libphish/Makefile
+++ b/devel/libphish/Makefile
@@ -19,7 +19,6 @@ BUILD_DEPENDS= xmlwf:${PORTSDIR}/textproc/expat2
USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_LDCONFIG= yes
-USE_GCC= 3.2+
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/devel/libs11n/Makefile b/devel/libs11n/Makefile
index 2e218bdde427..33b6c77ace99 100644
--- a/devel/libs11n/Makefile
+++ b/devel/libs11n/Makefile
@@ -18,7 +18,6 @@ COMMENT= A C++ library for easily serializing a wide variety of objects
WRKSRC= ${WRKDIR}/${DISTNAME}/src
USE_ZIP= yes
-USE_GCC= 3.2+
USE_LDCONFIG= yes
post-extract:
diff --git a/devel/libsigc++20/Makefile b/devel/libsigc++20/Makefile
index 79b894f2775f..ca28244f9bc6 100644
--- a/devel/libsigc++20/Makefile
+++ b/devel/libsigc++20/Makefile
@@ -19,7 +19,6 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
-USE_GCC= 3.4+
USE_GMAKE= yes
LATEST_LINK= libsigc++20
USE_LDCONFIG= yes
diff --git a/devel/libuninum/Makefile b/devel/libuninum/Makefile
index 0f9184aca925..ed7de6c273d0 100644
--- a/devel/libuninum/Makefile
+++ b/devel/libuninum/Makefile
@@ -15,7 +15,6 @@ COMMENT= Library for converting Unicode strings to numbers
LIB_DEPENDS= gmp.7:${PORTSDIR}/math/libgmp4
-USE_GCC= 3.2+
GNU_CONFIGURE= yes
CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
MAKE_ENV+= INCLUDES="-I${LOCALBASE}/include"
diff --git a/devel/loki/Makefile b/devel/loki/Makefile
index 89aa1cbedb07..770195d42a6a 100644
--- a/devel/loki/Makefile
+++ b/devel/loki/Makefile
@@ -16,7 +16,6 @@ COMMENT= A C++ library of common design patterns
USE_DOS2UNIX= yes
USE_GMAKE= yes
-USE_GCC= 3.4+
USE_LDCONFIG= yes
DOCS= README CHANGES doc/flex/flex_string.html \
diff --git a/devel/mq4cpp/Makefile b/devel/mq4cpp/Makefile
index 994e93debafb..a393632934a0 100644
--- a/devel/mq4cpp/Makefile
+++ b/devel/mq4cpp/Makefile
@@ -14,7 +14,6 @@ MAINTAINER= vanilla@FreeBSD.org
COMMENT= Message Queuing for C++
USE_LDCONFIG= yes
-USE_GCC= 3.4+
USE_AUTOTOOLS= libtool:15
USE_GNOME= gnomehack gnometarget pkgconfig ltverhack
USE_BZIP2= yes
diff --git a/devel/open-beagle/Makefile b/devel/open-beagle/Makefile
index 3f46a321797f..06f89f66d050 100644
--- a/devel/open-beagle/Makefile
+++ b/devel/open-beagle/Makefile
@@ -18,7 +18,6 @@ COMMENT= An Evolutionary Computation Framework
CONFLICTS= beagle-[0-9]*
USE_AUTOTOOLS= libtool:15
-USE_GCC= 3.3+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-optimization
USE_LDCONFIG= yes
diff --git a/devel/protobuf/Makefile b/devel/protobuf/Makefile
index eee7e17ea75d..9336fa204277 100644
--- a/devel/protobuf/Makefile
+++ b/devel/protobuf/Makefile
@@ -18,7 +18,6 @@ COMMENT= A data interchange format library
USE_GMAKE= yes
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GCC= 3.2+
USE_LDCONFIG= yes
tests: build
diff --git a/devel/py-ocempgui/Makefile b/devel/py-ocempgui/Makefile
index 9916f05c6bb1..e3b5bb31065c 100644
--- a/devel/py-ocempgui/Makefile
+++ b/devel/py-ocempgui/Makefile
@@ -21,7 +21,6 @@ BUILD_DEPENDS= ${LOCALBASE}/include/${PYTHON_VERSION}/pygame/pygame.h:${PORTSDIR
RUN_DEPENDS= ${LOCALBASE}/include/${PYTHON_VERSION}/pygame/pygame.h:${PORTSDIR}/devel/py-game
USE_GNOME= atk
-USE_GCC= 3.4+
USE_PYTHON= yes
USE_PYDISTUTILS=yes
PYDISTUTILS_PKGNAME= OcempGUI
diff --git a/devel/qmake4/Makefile b/devel/qmake4/Makefile
index 0a177f54423f..63257fa0ed38 100644
--- a/devel/qmake4/Makefile
+++ b/devel/qmake4/Makefile
@@ -73,10 +73,6 @@ do-configure:
.include <bsd.port.pre.mk>
.include "${.CURDIR}/../../Mk/bsd.qt.mk"
-.if ${OSVERSION} < 500035
-USE_GCC= 3.4+
-.endif
-
.if ${ARCH} == "alpha"
CXXFLAGS+= -mieee
.endif
diff --git a/devel/xfc/Makefile b/devel/xfc/Makefile
index 3aeb2d873fb5..71bcce5753b7 100644
--- a/devel/xfc/Makefile
+++ b/devel/xfc/Makefile
@@ -19,7 +19,6 @@ LIB_DEPENDS= sigc-2.0.0:${PORTSDIR}/devel/libsigc++20
USE_BZIP2= yes
USE_GMAKE= yes
USE_GETTEXT= yes
-USE_GCC= 3.4+
USE_GNOME= glib20 gtk20 atk pango pkgconfig libglade2 gnomehack
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/devel/xlslib/Makefile b/devel/xlslib/Makefile
index dc3690c3afe3..78324da40dce 100644
--- a/devel/xlslib/Makefile
+++ b/devel/xlslib/Makefile
@@ -17,7 +17,6 @@ COMMENT= A C++ library for generation of Excel(TM) files
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= libtool:15
-USE_GCC= 3.4+
post-patch:
@${REINPLACE_CMD} -e 's|^\(SUBDIRS.*src\).*|\1|' \