aboutsummaryrefslogtreecommitdiff
path: root/devel
diff options
context:
space:
mode:
Diffstat (limited to 'devel')
-rw-r--r--devel/anjuta/Makefile2
-rw-r--r--devel/bonobo-conf/Makefile4
-rw-r--r--devel/bonobo/Makefile4
-rw-r--r--devel/bug-buddy/Makefile4
-rw-r--r--devel/bugbuddy/Makefile4
-rw-r--r--devel/gconf/Makefile4
-rw-r--r--devel/gide/Makefile5
-rw-r--r--devel/glade/Makefile5
-rw-r--r--devel/glade2/Makefile4
-rw-r--r--devel/gnome-build/Makefile4
-rw-r--r--devel/gnome-crash/Makefile4
-rw-r--r--devel/gnome-vfs/Makefile1
-rw-r--r--devel/gnome-vfs1/Makefile2
-rw-r--r--devel/gnomebuild/Makefile4
-rw-r--r--devel/gnomecrash/Makefile4
-rw-r--r--devel/gnomedebug/Makefile4
-rw-r--r--devel/gnomevfs/Makefile2
-rw-r--r--devel/gnomevfs2/Makefile1
-rw-r--r--devel/libbonobo/Makefile4
-rw-r--r--devel/libgtop/Makefile6
-rw-r--r--devel/libsigc++/Makefile5
-rw-r--r--devel/oaf/Makefile4
-rw-r--r--devel/soup/Makefile4
23 files changed, 6 insertions, 79 deletions
diff --git a/devel/anjuta/Makefile b/devel/anjuta/Makefile
index 908c90ff5cb1..b891ee7d3a52 100644
--- a/devel/anjuta/Makefile
+++ b/devel/anjuta/Makefile
@@ -26,8 +26,6 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
post-patch:
- @${REINPLACE_CMD} -e 's#-lpthread#${PTHREAD_LIBS}#g ; \
- s#DATADIRNAME=lib#DATADIRNAME=share#g' ${WRKSRC}/configure
@${REINPLACE_CMD} -e 's|%%X11BASE%%|${X11BASE}|g' \
${WRKSRC}/src/Makefile.in
diff --git a/devel/bonobo-conf/Makefile b/devel/bonobo-conf/Makefile
index 63a6a751829c..1ffae2fb33ca 100644
--- a/devel/bonobo-conf/Makefile
+++ b/devel/bonobo-conf/Makefile
@@ -24,8 +24,4 @@ INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/devel/bonobo/Makefile b/devel/bonobo/Makefile
index 4b24cca5c10a..4e6fdfb827a5 100644
--- a/devel/bonobo/Makefile
+++ b/devel/bonobo/Makefile
@@ -29,8 +29,4 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/devel/bug-buddy/Makefile b/devel/bug-buddy/Makefile
index 6c5ccbbb96b4..769484703274 100644
--- a/devel/bug-buddy/Makefile
+++ b/devel/bug-buddy/Makefile
@@ -23,8 +23,4 @@ USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-post-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/devel/bugbuddy/Makefile b/devel/bugbuddy/Makefile
index 6c5ccbbb96b4..769484703274 100644
--- a/devel/bugbuddy/Makefile
+++ b/devel/bugbuddy/Makefile
@@ -23,8 +23,4 @@ USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-post-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/devel/gconf/Makefile b/devel/gconf/Makefile
index 9d6bde6ac647..8ead46f79df7 100644
--- a/devel/gconf/Makefile
+++ b/devel/gconf/Makefile
@@ -30,8 +30,4 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/devel/gide/Makefile b/devel/gide/Makefile
index 4e0ab38d5613..d4217578fb43 100644
--- a/devel/gide/Makefile
+++ b/devel/gide/Makefile
@@ -31,9 +31,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= gide.1
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
- s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
+ @${PERL} -pi -e \
+ 's|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/devel/glade/Makefile b/devel/glade/Makefile
index eac2fd1571a6..f36a9ef502f9 100644
--- a/devel/glade/Makefile
+++ b/devel/glade/Makefile
@@ -23,9 +23,8 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
- s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
+ @${REINPLACE_CMD} -e \
+ 's|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|[$$][(]top_builddir[)]/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/devel/glade2/Makefile b/devel/glade2/Makefile
index 7de9faca28da..0684b4a250c3 100644
--- a/devel/glade2/Makefile
+++ b/devel/glade2/Makefile
@@ -25,8 +25,4 @@ USE_GMAKE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/devel/gnome-build/Makefile b/devel/gnome-build/Makefile
index 81979b511d2e..cf5359be0fb4 100644
--- a/devel/gnome-build/Makefile
+++ b/devel/gnome-build/Makefile
@@ -26,8 +26,4 @@ INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/devel/gnome-crash/Makefile b/devel/gnome-crash/Makefile
index 227e75dcfb19..1a0c69c64ad5 100644
--- a/devel/gnome-crash/Makefile
+++ b/devel/gnome-crash/Makefile
@@ -22,8 +22,4 @@ USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
index 19b32290554c..225db7b0369a 100644
--- a/devel/gnome-vfs/Makefile
+++ b/devel/gnome-vfs/Makefile
@@ -48,7 +48,6 @@ LIB_DEPENDS+= fam.0:${PORTSDIR}/devel/fam
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "*info.in" | xargs ${REINPLACE_CMD} -e \
's|\@datadir\@/gnome|\@datadir\@|g'
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
diff --git a/devel/gnome-vfs1/Makefile b/devel/gnome-vfs1/Makefile
index 1cb3447521e5..58740eda5c16 100644
--- a/devel/gnome-vfs1/Makefile
+++ b/devel/gnome-vfs1/Makefile
@@ -34,8 +34,6 @@ CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
BSD_PTHREAD_LIBS=${PTHREAD_LIBS}
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name 'xml-i18n-*' | xargs ${REINPLACE_CMD} -e \
's|/usr/local/bin/perl|${PERL}|g'
@${REINPLACE_CMD} -e 's|\%\%LOCALBASE\%\%|${LOCALBASE}|g' \
diff --git a/devel/gnomebuild/Makefile b/devel/gnomebuild/Makefile
index 81979b511d2e..cf5359be0fb4 100644
--- a/devel/gnomebuild/Makefile
+++ b/devel/gnomebuild/Makefile
@@ -26,8 +26,4 @@ INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/devel/gnomecrash/Makefile b/devel/gnomecrash/Makefile
index 227e75dcfb19..1a0c69c64ad5 100644
--- a/devel/gnomecrash/Makefile
+++ b/devel/gnomecrash/Makefile
@@ -22,8 +22,4 @@ USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/devel/gnomedebug/Makefile b/devel/gnomedebug/Makefile
index f0b0a96f5deb..20187d6732f1 100644
--- a/devel/gnomedebug/Makefile
+++ b/devel/gnomedebug/Makefile
@@ -26,8 +26,4 @@ INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/devel/gnomevfs/Makefile b/devel/gnomevfs/Makefile
index 1cb3447521e5..58740eda5c16 100644
--- a/devel/gnomevfs/Makefile
+++ b/devel/gnomevfs/Makefile
@@ -34,8 +34,6 @@ CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${LOCALBASE}/include" \
BSD_PTHREAD_LIBS=${PTHREAD_LIBS}
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name 'xml-i18n-*' | xargs ${REINPLACE_CMD} -e \
's|/usr/local/bin/perl|${PERL}|g'
@${REINPLACE_CMD} -e 's|\%\%LOCALBASE\%\%|${LOCALBASE}|g' \
diff --git a/devel/gnomevfs2/Makefile b/devel/gnomevfs2/Makefile
index 19b32290554c..225db7b0369a 100644
--- a/devel/gnomevfs2/Makefile
+++ b/devel/gnomevfs2/Makefile
@@ -48,7 +48,6 @@ LIB_DEPENDS+= fam.0:${PORTSDIR}/devel/fam
.endif
post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "*info.in" | xargs ${REINPLACE_CMD} -e \
's|\@datadir\@/gnome|\@datadir\@|g'
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
diff --git a/devel/libbonobo/Makefile b/devel/libbonobo/Makefile
index 69a11e46390a..096163f99cb9 100644
--- a/devel/libbonobo/Makefile
+++ b/devel/libbonobo/Makefile
@@ -28,8 +28,4 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
MAKE_ENV= gnomelocaledir=${PREFIX}/share/locale
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/devel/libgtop/Makefile b/devel/libgtop/Makefile
index 9ef65f167344..bc962afe4b64 100644
--- a/devel/libgtop/Makefile
+++ b/devel/libgtop/Makefile
@@ -20,16 +20,12 @@ LIB_DEPENDS= guile.15:${PORTSDIR}/lang/guile
USE_PERL5= yes
USE_GMAKE= yes
USE_REINPLACE= yes
-USE_GNOME= gnomelibs
+USE_GNOME= gnomelibs gnomehack
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
post-install:
install-info --section="Programming \& development tools" \
--entry="* libgtop: (libgtop). libgtop programming manual" \
diff --git a/devel/libsigc++/Makefile b/devel/libsigc++/Makefile
index 410cc5dc823f..e21094cc3f8c 100644
--- a/devel/libsigc++/Makefile
+++ b/devel/libsigc++/Makefile
@@ -21,10 +21,7 @@ COMMENT= Callback Framework for C++
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
USE_REINPLACE= yes
-
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
- ${WRKSRC}/configure
+USE_GNOME= gnomehack
post-install:
.if !defined(NOPORTDOCS)
diff --git a/devel/oaf/Makefile b/devel/oaf/Makefile
index 808b11c57acd..5596d75ea0a3 100644
--- a/devel/oaf/Makefile
+++ b/devel/oaf/Makefile
@@ -32,8 +32,4 @@ CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
MAN1= oafd.1
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/devel/soup/Makefile b/devel/soup/Makefile
index a2554d679ff4..1eddf029c79c 100644
--- a/devel/soup/Makefile
+++ b/devel/soup/Makefile
@@ -25,8 +25,4 @@ CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-post-patch:
- @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
- s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>